openSUSE 11.2 Surround Sound Issue with HDA Intel ALC1200


I just installed openSUSE 11.2 last evening. Everything went well except that surround sound in HDA Intel ALC1200 does not work. It comes as regular sound [something like 2.1].

I’ve attached the output of /usr/sbin/ and this is what I got as output:

************* /usr/sbin/ OUTPUT *************

Click here to download Alsa script output file.

what happens when you switch ON digital audio ? (iec958) ?

Here is a thread on my experiences with surround sound: Exploring surround sound in Linux - openSUSE Forums

I note this works for my surround sound

speaker-test -c6 -Dplug:surround51 -t wav -l1 

You could install xchat, then go to IRC freenode #alsa and ask some of the sound guru’s there.

Hi, sorry for the late reply, didn’t get any notification that this thread has been replied [didn’t notice the option at the bottom].

Things are getting a bit weird now.

When I run this command, I get sounds perfectly.
speaker-test -c6 -Dplug:surround51 -t wav -l1

But when I run this command, I get sounds in only 3 speakers [2.1]
speaker-test -c6 -l5 -twav

When I play dts movie, the dialogs are always coming from the center speakers like 2.1 and not 5.1 *

Any ideas?:(*

What media player? Did you check the preferences of that player (sound engine, any surround sound options? ).

Whose gstreamer do you have installed if you use gstreamer? packmans? Novells? whose libxine1? Packmans? videolans? Novells ?*

I am using VLC Media Player [tried with Alsa instead of default, didn’t make much difference], it does have 5.1 option and what it did was, convert the 2.1 to something similar to Mono.

I also have gstreamer framework installed from Novell [but VLC is using it’s own I guess] which Kaffeine uses. libxine1 is from packman.

You could try other players such as smplayer.

Maybe replace the Novell gstreamer frame work with the Packman packaged. I assume your VLC and all codecs are packaged by Packman and not videolan. videolans are known to cause problems with Packman packaged apps.

In essence, once you confirm from the speaker tests that you can get 5.1, then its a matter of tuning.

Some users create custom .asoundrc files, but given many do not understand what the internals in such a file does, its a bit like pot luck.

SMPlayer does the same… I kinda figured out that, only the center speaker is active. There is surround sound however, but the front-right and front-left are very low in volume [despite increasing it]. Then I switched off Surround channel in the Mixer, it works close to right one.

Also I forced ‘S/PDIF’ option in VLC Player.

I re-installed VLC & gstreamer from Packman as well…

Anyways, I guess I am done for the day, will watch the movie and will start again tomorrow…

But I don’t understand this issue since all Linux Distributions uses Kernels from same sources isn’t it? So the drivers should be the same? If so, how can it be so different in Ubuntu & openSUSE?

Thanks again for the help :slight_smile:

You are asking questions in an area where I have a pet peeve.

Some distributions are very good at sending their patches/fixes “upstream” to the developers of the drivers/kernel, such that in turn the patches/fixes make their way back “downstream” to all Linux distributions. And for some distributions this happens quickly. Red Hat/Fedora are typically very good at doing this (sending their fixes upstream). SuSE-GmbH are also good (at sending their fixes upstream).

On the otherhand, Ubuntu do not have a good reputation in this regard. Often their fixes, when they are sent “upstream”, just go to Debian where they languish, and it takes an excessive time for them to to “upstream” and then back “downstream”.

One of the reasons why I refuse to use Ubuntu is because despite their being the most popular Linux distribution, they do not have the corresponding upstream/downstream volume of fixes/patches sent and the speed of the fixes/patches they do send are IMHO inadequate.

yeah, that sucks… anyways, I re-compiled the ALSA [yeah, a brave thing to do for user like me] and now it appears to be working right. Thanks for the help mate.