OpenSuSE 11.2 - Sometimes picks wrong resolution on startup

I’m running OpenSuSE 11.2 with an Nvidia GeForce 8200 on board graphics card and am running the drivers installed from the file which I obtained from the Nvidia web site. I also have this vga directive on the kernel line in /boot/grub/menu.lst

Yet, sometimes when the system starts up it will go into 640x480 mode instead of 1680x1050. If I shutdown and restart a few times it will eventually come up in the proper resolution. Any thoughts?


Try making sure your monitor is on first before turning on your computer. I’ve found that the auto-detection of the monitor resolution fails if the monitor isn’t on… (hope it’s simple as that for you)

Thanks linuxvinh. I tried that too. Yesterday

  • I uninstalled the drivers that I downloaded from the nvidia web site
    *rebooted (I was booted into a non-gui mode after uninstalling the nvidia drivers)
    *ran sax2 -r
    *let OpenSuSE revert back to the generic driver
    *used the drivers from the SuSE one-click install site
    *ran sax2 -r

That resulted in a much more detailed xorg.conf file. I’ve been using this config for about a day and so far so good. I’m in an optimistic, but waiting state.

Thanks for the suggestion.


  • Have you tried it without an xorg.conf?
  • Did you run nvidia-settings?
  • Check /var/log/Xorg.0.log for anything that might indicate a problem.

Didn’t try without an xorg.conf. I did use nvidia-settings (from the drivers from the nvidia site) to generate the xorg.conf file. Once I switched to the nvidia drivers from the SuSE web site (NVIDIA drivers - openSUSE) it seems to be behaving itself. I did this because there was a recommendation in the nvidia linux forum to use vendor specific drivers when possible for better integration with the distro.