OpenSUSE 11.2 - Samba Problems

Hello guys!

Until Saturday, my server was 100% ok with OpenSUSE 11.1

I upgraded it to OpenSUSE 11.2, it’s working, but with a few problems.

Main problem is with Samba Server Configuration. It’s loading at startup, but my Windows XP machines don’t are capable to login at server.

But, when I start Samba Server Configuration at YaST2, and simply click on ok, my machines are able to login at server and work perfectly.

From OpenSUSE 11.1 to 11.2 I copied the following files:

/etc/passwd
/etc/shadow
/etc/samba entire directory

I did it to preserve my IDs of server and domain, as I always did when I upgraded server and always worked at first time.

Follow my smb.conf (actually I need a help at smb.conf too, I think it’s too large in face of I really need.

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2005-09-13

[global]
socket options = TCP_NODELAY IPTOS_LOWDELAY
read raw = yes
write raw = yes
oplocks = yes
max xmit = 65535
dead time = 15
getwdcache = yes
workgroup = RealTux
printcap name = cups
cups options = raw
map to guest = Bad User
logon home = \%L%U.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = Yes
domain master = Yes
os level = 65
preferred master = Yes
logon script = %U.bat
logon path = \%L
etlogon
time server = yes
restrict anonymous = no
server string = OpenSUSE-RealTux
#max protocol = NT1
acl compatibility = winnt
ldap ssl = No
server signing = Auto
local master = Yes
security = user
unix password sync = no
log level = 0
passdb backend = smbpasswd
wins support = Yes
ldap suffix =

[homes]
comment = Home Directories
valid users = %S
browseable = No
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = /home/profiles
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

Thanks so much and sorry by my poor english!

Gabriel

On Mon November 16 2009 05:36 am, gabrielcjolo wrote:

>
> Hello guys!
>
> Until Saturday, my server was 100% ok with OpenSUSE 11.1
>
> I upgraded it to OpenSUSE 11.2, it’s working, but with a few problems.
>
> Main problem is with Samba Server Configuration. It’s loading at
> startup, but my Windows XP machines don’t are capable to login at
> server.
>
> But, when I start Samba Server Configuration at YaST2, and simply click
> on ok, my machines are able to login at server and work perfectly.
>
> From OpenSUSE 11.1 to 11.2 I copied the following files:
>
> /etc/passwd
> /etc/shadow
> /etc/samba entire directory
>
> I did it to preserve my IDs of server and domain, as I always did when
> I upgraded server and always worked at first time.
>
> Follow my smb.conf (actually I need a help at smb.conf too, I think
> it’s too large in face of I really need.
>
>> # smb.conf is the main Samba configuration file. You find a full
>> commented
>> # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if
>> the
>> # samba-doc package is installed.
>> # Date: 2005-09-13
>> [global]
>> socket options = TCP_NODELAY IPTOS_LOWDELAY
>> read raw = yes
The above is a default, no need to set it.
>> write raw = yes
ditto
>> oplocks = yes
ditto
>> max xmit = 65535
ditto
>> dead time = 15
ditto
>> getwdcache = yes
ditto
>> workgroup = RealTux
>> printcap name = cups
>> cups options = raw
>> map to guest = Bad User
>> logon home = \%L%U.9xprofile
>> logon drive = P:
>> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
>> -s /bin/false %m$
>> domain logons = Yes
>> domain master = Yes
>> os level = 65
>> preferred master = Yes
>> logon script = %U.bat
>> logon path = \%L
etlogon
>> time server = yes
>> restrict anonymous = no
>> server string = OpenSUSE-RealTux
>> #max protocol = NT1
>> acl compatibility = winnt
Its best to leave the above at the default, auto. This is based on the
version of the client.
>> ldap ssl = No
above not needed unless you have a ldap server
>> server signing = Auto
Mater of style, but I would suggest you leave the above at default
>> local master = Yes
>> security = user
Above is the default value
>> unix password sync = no
ditto
>> log level = 0
>> passdb backend = smbpasswd
>> wins support = Yes
>> ldap suffix =
The above is not needed unless you use ldap backend.
>>
>> [homes]
>> comment = Home Directories
>> valid users = %S
>> browseable = No
>> read only = No
>> inherit acls = Yes
>>
>> [profiles]
>> comment = Network Profiles Service
>> path = /home/profiles
>> read only = No
>> store dos attributes = Yes
>> create mask = 0600
>> directory mask = 0700
>>
>> [users]
>> comment = All users
>> path = /home
>> read only = No
>> inherit acls = Yes
>> veto files = /aquota.user/groups/shares/
>>
>> [groups]
>> comment = All groups
>> path = /home/groups
>> read only = No
>> inherit acls = Yes
>
> Thanks so much and sorry by my poor english!
>
> Gabriel
>
>
Gabriel;

Are you absolutely sure that both nmbd and smbd are starting automatically.
When you startup the server enter:


rcsmb status
rcnmb status

You need to make certain that BOTH nmbd and smbd are set to run at startup.
This can be set with the runlevel tab of YaST. If both these commands
report “running” and logins fails please post back.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Thanks so much!

Everything is fine now with samba… nmb was not loading at boot…