Opensuse 11.2 remote administration

:’( Opensuse 11.2 remote administration.
If configured at vnc and www (5901 and 5801) port we got just a black screen. No firewall to block it.
Any advise?

Some questions to help us:

  • What version of openSUSE are you using?
  • What Desktop Environment are you using?
  • Are you running vnc in openSUSE as a client or as a server?
  • If you are running openSUSE as a server, what Desktop are you serving out?
  • If you are running openSUSE as a client, what Desktop/operating system are you importing?
  • openSUSE comes with several types and methods for vnc, which one did you use?

You said: Any advise? – maybe this will help: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

"What version of openSUSE are you using? "
“Opensuse 11.2”

“What Desktop Environment are you using?”

"Are you running vnc in openSUSE as a client or as a server? "
If then with twm on separated port. But does not make sense other vnc running or not the result are same. Of course the vncserver on other port working fine.

"If you are running openSUSE as a server, what Desktop are you serving out? "

"openSUSE comes with several types and methods for vnc, which one did you use? "
The remote adminstration is configured from Yast/NetworkServices/RemoteAdministration. This use Xvnc?

That button in Yast actually opens the firewall on channel 1 (5901). The properties associated with that can be viewed in the Yast → net services → xinetd button. I see that the “remote admin” button actually turns on a 1024x768 screen of the same type as your default desktop (KDE for you). The software is TightVNC / xorg-x11-Xvnc

Sadly, it’s not working in openSUSE 11.2.

This page will give you a working TightVNC server for openSUSE 11.2 by a method that works:
TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

And if you look at this thread and check posts by oldcpu you’ll see how to use the other fork of vnc (namely x11vnc) in openSUSE 11.2:
VNC is sometimes working - openSUSE Forums

“Sadly, it’s not working in openSUSE 11.2.”
My statistic is the flowing:
OpenSuse 10.3 - working fine
SLES11 - working fine
OpenSuse 11.1 - respond “Not a valid vnc server”
OpenSuse 11.2 - balank screen (on vnc and on www port)
Of course I can setup any complicated remote acess, but this one click remote management was very comfortable service of Suse…

Thats the same history i experienced.

In my 11.1 it was just a shell script parameter in the wrong place, i think some geometry parameter (like the 768 in 1024x768) was treated as a port number which didn’t exist.
I fixed the script and it worked.

Now about 11.2:

Im not so experienced, but i “believe” this is the reason for the “black-screen”:
It seems that a Xvnc-Server is successfully started when a user connects to the port (e.g. 5801 or 5901) but no application or desktop is started. There is just nothing to be seen.
Thats why its black.

I tried around a bit with self-written scripts similar to svnserver to improve this but no success yet. The point is that the Xvnc (or new script) is to be started by xinetd which makes it a bit more complicated (unless i don’t understand some things yet.)

IME works fine if you use the startup command “dbus-launch vncserver” instead of the traditional command “vncserver”

But neither vncserver, nore sbus-launch work when they are started via /etc/xinetd.d/vnc.

Hello together,

maybe I have a solution for the problem.

In our systemlog was an entry when I tried to established a connection with the vnc-server:

Dec 29 09:37:52 S-BS-GE-NQE4 kdm: fe80::21a:4bff:feaf:b368:1[10545]: Cannot connect to fe80::21a:4bff:feaf:b368:1, giving up
Dec 29 09:37:52 S-BS-GE-NQE4 kdm[1442]: Display fe80::21a:4bff:feaf:b368:1 cannot be opened

VNC tries to establish a connection with the IPv6 address of eth0.

At first you have to activate IPv6 under the global options of the network manager.

After this you have to reboot your system!

In a terminal you can find out the IPv6 address of eth0
Just enter ifconfig:

eth0 Link encap:Ethernet Hardware Adresse 00:1A:4B:AF:B3:68
inet Adresse: Bcast: Maske:
inet6 Adresse: fe80::21a:4bff:feaf:b368/64

At last you must add an entry in the /etc/hosts file
for the IPv6 address

For example:

fe80::21a:4bff:feaf:b368 hostname.domain hostname

IPv6 address, hostname and domain should be the original variables of your system.

Please let me know if this solution works with your systems as well.

Good luck!

There is also a second localhost address necessary, like this: hostname.domain hostname

Since nobody mentioned trying the solution suggested by lsnrw I wanted to reply and say thanks. The addition to /etc/hosts of the IPv6 address of eth0 worked great on a OpenSuse 11.2 out-of-the-box installation! To me this is a favorable approach becauuse it is so easy to do.


thanx for this info!
T tried this out. Now i immediately get a “Network error: remote side closed connection” when i open localhost:5801 in my browser. Its the browser java client saying this…
Maybe i configured something wrong in my /etc/hosts; i don’t have the time right now to investigate, though.
I will check the config later and post another reply (maybe in some days…)


P.S.: I oversaw heapstors answer: I think it must really be some misconfiguration now in my system.


my problem is quite strange.
If my monitor is connected everything works, if not i just see that “black screen” with the cursor.

Does anybody have the same problem?

Running the OpenSuse 11.2 Gnome and already tested this( - OpenSuSE 11.2 Remote Administration (VNC) Black screen) solution

Just a note to say “At last!!!”

I added the IPv6 addresses for both of my lan cards to /etc/hosts and it works fine for me too.

Well done that man :¬)

I first want to THANK lsnrw for his post on this topic. That was the ANSWER TO ALL MY PROBLEMS.rotfl!lol!

I have tried so many different variations of the Install from using the GNOME Desktop, to installing ALL the Desktop Managers, and I have tried many different versions of TightVNC, FreeNX, PuTty, x11VNC and NONE HAVE WORKED. I was to a point that I knew 11.1’s Remote Desktop worked that I reverted my Systems back to it just for this Feature.

I have read so many different posts on the How To Remote Desktop fixes for openSuSE 11.2 and NONE have worked but as soon as I did the tip suggested by lsnrw IT WORKED NO RESTART NEEDED either.

I will ALSO NOTE that you MUST CONFIGURE your Installation – DO NOT USE THE AUTOMATIC CONFIGURATION for the AUTOMATIC CONFIGURATION will set you up with NETWORK MANAGER which as far as I could tell (and I tried this tip on several installs that were using Network Manager, but I might have missed something) Network Manager DOES NOT SUPPORT IPv6>:):’(

AGAIN THANK YOU VERY MUCH lsnrw I have been pulling my hair out trying to get 11.2’s remote Desktop to Work.

hi to everybody thanks for the info. The easiest thing is comment out all IPV6 references if you are not using IPV6. reboot and it works like a charm.