openSUSE 11.2 - problem with wired and wireless connection

I have openSUSE 11.2 64-bit KDE, I have installed it with lan cable connected, install updates and than switch to wireless.
Everything worked great until I went to my girlfreind with laptop, there I can connect to router, use Skype but can’t browse pages with firefox, can’t install packages with YAST :
Also wired connection gives the same result >:( but her PC have no problem with Internet.
I have traied ifup, deleting /etc/resolv/conf, disabling NetworManager routing options with no succes :frowning:
Any ideas?

On 11/22/2009 10:26 AM, rozbarwinek wrote:
>
> I have openSUSE 11.2 64-bit KDE, I have installed it with lan cable
> connected, install updates and than switch to wireless.
> Everything worked great until I went to my girlfreind with laptop,
> there I can connect to router, use Skype but can’t browse pages with
> firefox, can’t install packages with YAST :
> Also wired connection gives the same result >:( but her PC have no
> problem with Internet.
> I have traied ifup, deleting /etc/resolv/conf, disabling NetworManager
> routing options with no succes :frowning:
> Any ideas?

Some systems have had problems when the wired and wireless devices are both set
to “Start on boot”. If your is configured that way, change the wired interface
to “Start on cable connection”.

Others have had problems with the routing setup. Do an ‘/sbin/route -n’ command
and look for a line with the UG flags set.

As you tried, others have had problems with /etc/resolv.conf. Usually deleting
it does the trick.

Things to try:

  1. Pinging the router. If this fails, post the output of ‘/sbin/route -n’.

  2. Ping by IP. ‘ping 74.125.95.104’ If this works, ‘ping www.google.com

I have a very similar and probably related issue. Again OpenSuSE 11.2, x64. The Dell 1720 i’m installing on uses the Intel AGN wifi chipset. I’m also running with a Qwest DSL with a Motorola modem/wifi router.

I had (and still have on another system) OpenSuSE 11.1 x64 running with no issues.

The install of 11.2 on the Dell, worked fine till it came to check for updates (even on a wired connection). It failed to connect with any SuSE update servers. I completed the install, and to this moment cannot get normal web operations to complete.

Pings to the router, named addresses (Yahoo!, Google, etc) work fine as do IP address pings.

traceroute -n gives the following:
[size=]
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0
[/size]

What is REALLY odd and perhaps very telling to the more informed, is that all web browsing (lynx, FireFox, etc), ends with a can not connect to host error message.

BUT - via the text based “links” browser, there are NO connection problems. I’m guessing that “links” uses something different to resolve host names, where as the rest of the system is using the same (broken) method.

I’ve tried deleting the resolve.conf. No change. I’ve also had little to no success doing comparison contrast with the working 11.1 system and the broken 11.2 system.

Any help/hints/suggestions would be greatly appreciated.

  • John “S”

Yes, I can ping router, google etc.
I have even tried connect without router (direct with Internet cable) with no succes :\

Result of route -n and ifconfig:

inux-wrro:/etc # route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
linux-wrro:/etc # ifconfig -a                                                
eth0      Link encap:Ethernet  HWaddr 00:1E:33:7C:54:97                      
          UP BROADCAST MULTICAST  MTU:1500  Metric:1                         
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0               
          collisions:0 txqueuelen:1000                                       
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)                             
          Interrupt:27 Base address:0x4000                                   

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host     
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1141 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1141 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                              
          RX bytes:44027 (42.9 Kb)  TX bytes:44027 (42.9 Kb)     

vboxnet0  Link encap:Ethernet  HWaddr 0A:00:27:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


wlan0     Link encap:Ethernet  HWaddr 00:21:63:97:AA:4C
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::221:63ff:fe97:aa4c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:232 errors:0 dropped:0 overruns:0 frame:0
          TX packets:377 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:26979 (26.3 Kb)  TX bytes:54114 (52.8 Kb)

wmaster0  Link encap:UNSPEC  HWaddr 00-21-63-97-AA-4C-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

In addition to the above, I have tried the work arounds suggested in this thread:
https://bugzilla.novell.com/show_bug.cgi?id=553908

Which basically consists of finding the 'Ignore automatically obtained routes’checkbox in the Routing section of the Ipv4 settings of the networkmanager settings menu from the network tray. I have tried all four permutations of the ignore automatically obtained routes and apply to only this interface - with full reboots inbetween, all to no avail.

Thank goodness SuSE 11.1 still works - even after upgrading to the Factory KDE repositories.

  • John “S”

So what cause this? Kernel bug or knetworkmanager?
Does kubuntu 9.10 also have such bug?

I have tried wireless on Fedora and Ubuntu (various releases) and while wireless works, it’s always been buggy at best. Copying large amounts of data across the network would time out, downloading large amounts of data from the Internet would time out. I finally gave up on the wireless Linux thang and just use a cat5 cable.

I solved the problem by changing DNS manually to openDNS :slight_smile:
Now everything work great rotfl!

Help us out here rozbarwinek and tell us where you changed the DNS to openDNS.

Thanks.

Hi
Does your router have a configuration page for adding a DNS server? On
my linksys router I just added the DNS servers here, so any machine
that connects picks up those…

Else you would need to manually add via YaST Network devices.

They openDNS servers are;
nameserver 208.67.222.222
nameserver 208.67.220.220


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 3 days 23:52, 2 users, load average: 0.08, 0.13, 0.14
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Just open terminal and enter this:

kdesu kwrite /etc/resolv.conf

enter password, then add this at the end of the file and save changes:

nameserver 208.67.222.222
nameserver 208.67.220.220

Hope it work for you.

how can i add opendns with gnome?

Marslightyear wrote:
> how can i add opendns with gnome?

why would you think you need it?

to me, it looks like some more snake-oil made to sell to running
scared Redmond users…


palladium

read it helped users with a similar wireless problem. I keep gettings host issues even though networkmanager says I’m online and I’ve tried everything I’ve read on here I think.

I’ve got three OpenSuSE 11.2 laptops. There is something definitely wrong either in the way the DNS server entries are populated from DHCP or something else. The only way I could get WiFI to work on any of the laptops, is to hand set the DNS servers to those of OpenDNS. I believe but don’t recall confirming that any DNS server will work, but I know NetworkManager on OpenSuSE cannot set the DNS servers from DHCP discovery.

How did u set them to OpenDNS?

This is what I did to get my home WiFI working. I have varying degrees of success in allowing fully automatic connections with various WiFI hot-spots.

QWest is my DSL ISP (Colorado), I’m using there provided modem/router (Motorola 3347). The original problem is that fully automatic settings would establish a good connection with everything except name resolution. I could ping and load any IP address specified URL, but no browser could resolve a name like “http://www.cnn.com”. Well, almost no browser - the two text mode browsers, Links and Lynx - one of the two of them DID work. I don’t remember which, and have no idea why it did.

On a side note, I have several “real” and virtual Windows machines, ranging from WinXP SP2 to Win Server 2K8 SP1 X64. All of the Windows machines worked out of the “box”. In the case of virtual machines, as long as the virtual network adapter was configured as “bridged”, it all just worked, even if the Linux host did not.

What I ended up doing to make things work at home is to manually configure the home WiFI connection, taking DHCP out of the loop. In the Knetwork tray applet, select manage connections, select your connetion, then “edit”. Go to the tab for IP address, pick an IP address that you know is in the sub-domain of your network (and not used). The subnet mask should fill itself in auto-magically and then under DNS servers, fill in the IP addresses for OpenDNS.

My settings look like this:
Configure->Manual
IP Address->192.168.0.10
SubNet Mask ->255.255.255.0
Gateway->192.168.0.1
SearchDomains->
DNS Servers->208.67.220.220, 208.67.222.222

The only thing that would vary for “most” folks, is the IP Address, and possibly the Gateway IP address.

Hope this helps, sure wished KNetworkManager did the right thing out of the box!

  • John “S”

i hope this works for me too.