openSUSE 11.2 only detect 1 core on AMD Athlon 64 X2 3600

Here my system information:

OS: openSUSE 11.2 x86_64
Kernel:2.6.31.8-0.1-desktop (not recompiled)
CPU: AMD Athlon 64 X2 3600+
RAM: 2 Gb (128 share/reserved for video card)
Video: nVidia GeForce 8200 (on board)
Motherboard: EVGA nForce 730a (nVidia binary drivers)
Sound: Intel onborad sound card + ALSA drivers
FS: Ext4 on SATA HDD

Issue:

I was experiencing some issues with some system freezes. In the /sys/var/log/messages, I have noticed some:

Jan 22 22:10:39 THOR kernel: [61685.128310] BUG: soft lockup - CPU#0 stuck for 121s! [java:27580]

For different dates and and different applications: firefox, checkproc, dsn-resolver, vmware-vmx, amarok, Xorg, gpg, php. The stuck time varies from 62s to 145s

I have tried to disable the ACPI at the kernel option at boot (via grub) as suggested on different forum with no-success (now ACPI is re-enabled). I have disabled the splash to check if there is a boot problem (nothing detected).

When I was using VMware I was able to choose to use 1 or 2 cores. I can no longer use this option as the system seems to have lost the second core somewhere. When I was using TOP or other CPU/Memory monitor I was able to see the information for the 2 cores. Only 1 core showing in the monitoring tools and in the Yast Hardware information tool.

No need to say the system multitasking performances degraded a lot since.

Any idea where the other core went?

Problem solved.

When I installed the system using the boot DVD, I needed to use the nolapic option (F5) to avoid the black screen. When the install is done you must remove the nolapic option as it will disabled the SMP.

Found the info on here.

Has the 11.2 RC2 kernel stolen a CPU? - openSUSE Forums

I guess trying to solve a problem while being tired did not helped :X