openSUSE 11.2 on netbook? (Asus 1000H)

Just installed openSUSE 11.2 on my desktop and it’s great.

My kid was asking if we can install openSUSE on the Asus 1000H netbook.
Read some post here and think it is possible but just want to be sure.

So, anyone running openSUSE 11.1 or 11.2 on a Asus 1000H and can confirm if everything is okay? especially bluetooth :slight_smile:

Thanks in advance for the info

Have a look here
HCL/Laptops/Asus - openSUSE

Hi
So far so good here on a 1000HE, don’t know the differences between
this and the ‘H’’ version though.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel 2.6.31.5-0.1-desktop
up 0:02, 1 user, load average: 1.14, 0.84, 0.34
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Does this means downloading the “nornmal” 32 Bit PC version or is there a special version ?

and do a

dd if=openSUSE-11.2-KDE4-LiveCD-i686.iso of=/dev/sdx bs=4M

to create a bootable installation usb or do I need to use UNetbootin ?

Yes, u can :slight_smile:
My box is a Eee PC 1000HE. When I got this box I said to myself I ant going to use Winblows anymore and start using Linux as my main system. I installed OpenSuSE 11.1 on my Eee and it works right out of the box. 11.2 should work fine.

In case someone is looking for the same info in future,

this is to confirm that** openSUSE 11.2 works perfectly on a ASUS 1000H **on a default install.

Only one weird problem is upon first login, the keyboard is not detected when in firefox.

After reboot, everything is working perfectly lol!

Hi, I also want to try it on my netbook, just need to confirm, are you using KDE 4 or Gnome? Will KDE be slower than Gnome on netbook?

KDE4, didn’t tried Gnome in openSUSE.

Speed is acceptable as compared to the previous netbook distro that I’ve installed which is basically gnome based.

Hi,

If you really want speed, I suggest you take a look at XFCE, which is much faster than Gnome or KDE.

That said KDE and Gnome are both pretty lightweight compared to Windows and I would consider the difference, between the two, to be more personal choice than performance.

Regards,
Barry.

I have it running on a 1000HE no problems.

I even have eee-control running which controls the camera/bluetooth/FSB/WiFi and provides hot fn key support. This ver is 0.9.4 and the one in the SuSEEE YAST Repo/ is 0.9.2 and didn’t work with my 1000HE - (Although that may have been a eee-control daemon issue that I worked out playing about with 0.9.4). Anyhow as that didn’t work I manually installed 0.9.4 (in root terminal) as per the geekmind website;

cd locale && sh update.sh && cd …
python setup.py install --prefix=/usr
cp data/eee-control /etc/init.d/
eee-control-setup.sh

I think I had to add python-devel and maybe one other package from YAST to get the 2nd and/or 4th line line to run. Was a quick google I recall… :wink:

Then there are 2 things left to do.

  1. Edit she.py in /usr/local/lib/python2.6/dist-packages/EeeControl/she.py (Note - different path location than the eee-control in the YAST repo) to include these changes as the file locations have changed in later kernel

locations =
“/proc/acpi/asus/cpufv”,
“/sys/devices/platform/eeepc/she”,
“/sys/devices/platform/eeepc/cpufv”,
“/sys/devices/platform/eeepc/available_cpufv”
]

  1. The eee-control daemon doesn’t auto run at startup. To fix run YAST Admin and then System Services (Runlevel). In here highlight eeecontrold and click Enable. Click yes to start run levels 2 3 4 5.

The eee-control program is in Applications | System | More - I think… (don’t have the 1000He to hand). The tray app seems to run on startup after the 1st time. (YAST repo installs in Applications | System | Configuration)

That’s it I think… I can get the 1000HE running at about 7-8 Watts according to “powertop” in powersave mode with camera and bluetooth turned off. Not bad at all. Only thing is camera is re-enabled on boot but you can assign to a hot fn key to turn off.

Enjoy!

Oh yes - this was KDE 11.2 not Gnome.

I have 11.1 running perfectly on my ASUS PC1000H.
NOTE: I had to re-install “bluez” after updating to KDE 4.2 but that most likely won’t effect the current versions 4.3.3 and 4.3.4 AFAIK

To answer Malcolm’s question the difference between the H and the HE is bluetooth. The HE has it, the H doesn’t.