opensuse 11.2 noob, wireless apparently connected but browser can't connect

Hi everyone,
I just installed Opensuse 11.2 today. I currently can connect to the internet through my modem/router using the wired connection only. I want to be able to connect wirelessly using this computer. My modem/router can handle both wired and wireless connections.

My wireless adapter is a USB type. Although I am pretty much a total Linux noob I have managed to successfully download and install the drivers for it. Opensuse appears to be seeing the adapter fine and also I was able to configure it to connect to my home network (was able to see the SSID fine when I scanned). When I unplug my ethernet cable and click on the ‘Computer’ button in the lower left of my desktop, the status shown for Network is:
Wireless
Connected to: my SSID].

This all seems to suggest to me that my wireless adapter is connecting to my wireless network OK. But when I open Firefox it cannot connect to any webpage. If I plug the ethernet cable back in Firefox can connect to websites fine. So obviously there is a problem with my wireless set up on this computer. I know that wireless is not malfunctioning in the router because I can connect fine wirelessly on a Windows laptop I have.

The computer is fairly old with an Athlon XP 1600 processor.

Can anyone offer any help, some troubleshooting tips, anything at all? It would be very much appreciated.

Thanks,
Leo

The problem may be that you are not getting the DNS entries or gateway entries updated. Please see the output of the following:

su
tail /etc/resolv.conf
route

There is a problem with the knetworkmanager in the default installation related to this and you have to first upgrade it to the more recent version.
(Also, same problem is discussed in many other posts).

Thanks for responding syampillai.

The following are the results I got when I put in the code you posted.
Still having the problem, can you offer anymore help? I did a google search on “netconfig(8) manual” but didn’t get wnywhere.

linux-lud1:/home/leo # su
linux-lud1:/home/leo # tail /etc/resolv.conf

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search gateway.2wire.net
nameserver 192.168.2.1
linux-lud1:/home/leo # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 0 0 0 eth0
192.168.2.0 * 255.255.255.0 U 0 0 0 wlan1
link-local * 255.255.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default mymodem 0.0.0.0 UG 0 0 0 eth0
linux-lud1:/home/leo #

Looks like only your router is being configured as a DNS. Try a static IP address and nameservers 8.8.8.8 and 8.8.4.4 (they’re Google’s public DNS’s), gateway address 192.168.2.1

Please let us know if this works

Success!!
I did what you said and it worked Knurpht! :slight_smile:
Wireless is now able to make web connections on the Linux computer.
Thanks very much Knurpht and Syampillai!

Looks like you can get around this by doing an nslookup on download.opensuse.org and replacing the server names with the IP you get back in the Yast software sources configuration, then updating, but really… unacceptable in a distro that bills itself “The Enterprise Linux”

On 02/20/2010 01:06 PM, opensusenoob wrote:
>
> Looks like you can get around this by doing an nslookup on
> download.opensuse.org and replacing the server names with the IP you get
> back in the Yast software sources configuration, then updating, but
> really… unacceptable in a distro that bills itself “The Enterprise
> Linux”

That is SLES, not openSUSE. It is a totally different product.

As for openSUSE, perhaps you have never made a mistake, but the rest of us have.
These errors in the installation media have been fixed, but they do cause some
problems. Next time, please do testing of pre-release material so that we will
benefit from your expertise.

Never claimed to have never made a mistake, but this seems like pretty basic functionality to be overlooked in a major release and would be categorized as a blocker any place I’ve ever worked. A newbie who only has wireless can’t access the internet, can’t update, and can’t fix the problem without an update. Seems worthy of at least a minor release to fix the installation media to me.

I tried OpenSuSE because I had a pleasant experience with it in the past and was looking for something with a longer support cycle and more rigorous QA than the short-term Ubuntu releases. OpenSuSE has been touted as an enterprise-ready linux for the masses. Sorry if the critcism seemed harsh.

welcome to OpenSuse; your continued contribution would be valued; as lwfinger said, if you test the pre-release that would be a very useful contribution

Ok i think I am having the same problem but cant seem to fix it tried setting the ip manually but to no avail. For some odd reason if i put the IP adress of a website in it will bring it up but if i use a domain name it ignores it now if i ping ether one they come up just fine I just dont get it all of my browsers are doing the same thing Im new to open sues and over like it but this is giving me one hell of a headache I should mention all i have for that computer is wirless this system is hardwired but unless i can get updates and burn them to cd thats out lol

linux-lud1:/home/brenna # tail /etc/resolv.conf
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search Belkin
nameserver 192.168.2.1
linux-lud1:/home/brenna # route
Kernel IP routing table
Destination	GAteway 	Genmask		Flags 	Meric	Ref 	Use 	Iface
192.168.2.0 	*      	 	255.255.255.0	U	2	0	0	wlan0
default		192.168.2.1	0.0.0.0		UG	0	0	0	wlan0

On 02/20/2010 11:26 PM, Tripic wrote:
>
> Ok i think I am having the same problem but cant seem to fix it tried
> setting the ip manually but to no avail. For some odd reason if i put
> the IP adress of a website in it will bring it up but if i use a domain
> name it ignores it now if i ping ether one they come up just fine I just
> dont get it all of my browsers are doing the same thing Im new to open
> sues and over like it but this is giving me one hell of a headache I
> should mention all i have for that computer is wirless this system is
> hardwired but unless i can get updates and burn them to cd thats out lol
>
>
>
> Code:
> --------------------
> linux-lud1:/home/brenna # tail /etc/resolv.conf
> # See also the netconfig(8) manual page and other documentation.
> #
> # Note: Manual change of this file disables netconfig too, but
> # may get lost when this file contains comments or empty lines
> # only, the netconfig settings are same with settings in this
> # file and in case of a “netconfig update -f” call.
> #
> ### Please remove (at least) this line when you modify the file!
> search Belkin
> nameserver 192.168.2.1
> linux-lud1:/home/brenna # route
> Kernel IP routing table
> Destination GAteway Genmask Flags Meric Ref Use Iface
> 192.168.2.0 * 255.255.255.0 U 2 0 0 wlan0
> default 192.168.2.1 0.0.0.0 UG 0 0 0 wlan0
> --------------------

If you can ping with an IP number, but a name fails, then the problem is with
DNS. Your resolv.conf looks OK, but it seems to be failing anyway. Try deleting
it and remake the connection. That will recreate the file. If it still does not
work, add the line “nameserver 8.8.8.8” to the end of resolv.conf. That will use
one of Google’s public servers.

Hi
Maybe the OP could also check the router, if it has the ability to
manually configure the DNS servers (maybe it’s not getting them
properly from the ISP?) to add the google one or I prefer to use openDNS
ones.


nameserver 208.67.222.222
nameserver 208.67.220.220


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 2 (i586) Kernel 2.6.33-rc7-3-default
up 1:19, 3 users, load average: 0.05, 0.08, 0.16
GPU GeForce 6600 TE/6200 TE - Driver Version: 195.36.03

I just had a problem with similar symptoms. After considerable frustration, I think I found an easy solution.

Problem: I just did an upgrade from 11.1 to 11.2. The wireless, which had been working fine, stopped working after the install.
Although I don’t think this matters, it was a 4965 using iwlagn.

The hardwired ethernet card was being activated at boot time, even though there was no cable connected to the internet. Because it thinks the hardwired card is functional, I believe that it tries to send traffic through that interface and ignores your wireless card, even when the physical cable is disconnected.

Solution: Go into Network Settings from Yast. Edit the Ethernet Network Card. Set it so that it starts on cable connection, rather than on boot. Turn off your laptop and your router. Then turn on the router, after it is up, power on your laptop.

I hope this works for you as well as it worked for me.

There is a major bug in OpenSUSE 11.2 X64, that seems to have been around for some months. It impacts DNS, DHCP, Wget, Firefox, etc., and possibly IPV6 and Avahi, and there are comments all over the discussion boards about various secondary consequences of it, and some proposed fixes, but the correct solution is not prominently noted.

The effect of the bug is that ping to a static IP works, but DNS lookups do not, and thus browsers do not work by URL (but will by IP address), and packages cannot be updated from repositories.

Some have suggested turning IPV6 off, some telling Firefox not to use IPV6, and some to edit /etc/resolv.conf --although this is a temporary solution as the file may get overwritten, or it may prevent future updates by Yast.

vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
THE TEMPORARY FIX IS:

sudo echo “nameserver 8.8.8.8” >> /etc/resolv.conf

WHICH MANUALLY POINTS DNS TO GOOGLE’S NAMESERVER

THEN, FOR THE PERMANENT FIX:

MANUALLY RUN UPDATES TO DOWNLOAD THE PERMANENT FIX FROM THE REPOSITORIES; PARTICULARLY TO DHCPD!!! [Update cites Bugzilla 565030 and 569972]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

If you are lucky, the fix will be in the update and the bug will go away.

On 02/28/2010 08:06 PM, slingshot2000 wrote:
>
> There is a major bug in OpenSUSE 11.2 X64, that seems to have been
> around for some months. It impacts DNS, DHCP, Wget, Firefox, etc., and
> possibly IPV6 and Avahi, and there are comments all over the discussion
> boards about various secondary consequences of it, and some proposed
> fixes, but the correct solution is not prominently noted.
>
> The effect of the bug is that ping to a static IP works, but DNS
> lookups do not, and thus browsers do not work by URL (but will by IP
> address), and packages cannot be updated from repositories.
>
> Some have suggested turning IPV6 off, some telling Firefox not to use
> IPV6, and some to edit /etc/resolv.conf --although this is a temporary
> solution as the file may get overwritten, or it may prevent future
> updates by Yast.
>
> vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
> THE TEMPORARY FIX IS:
>
> sudo echo “nameserver 8.8.8.8” >> /etc/resolv.conf
>
> WHICH MANUALLY POINTS DNS TO GOOGLE’S NAMESERVER
>
> THEN, FOR THE PERMANENT FIX:
>
> MANUALLY RUN UPDATES TO DOWNLOAD THE PERMANENT FIX FROM THE
> REPOSITORIES; PARTICULARLY TO DHCPD!!! [Update cites Bugzilla 565030 and
> 569972]
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>
> If you are lucky, the fix will be in the update and the bug will go
> away.

This bug was fixed a long time ago.

Thanks! I will. I really want to get OpenSUSE working for me and others, as I think the community has the most polished KDE distro and, as much as I like XFCE, I think Qt / KDE probably represents be the future of the Linux desktop, plus I saw that the MeeGo project has adopted the openSUSE build system :slight_smile:

Thank you thank you thank you! You have just preserved the last shred of my sanity. :slight_smile: As a complete noob to openSUSE and Linux, I was in deep trouble.