OpenSUSE 11.2 - No sound (again) ...


Before I start let me say I tried the remedies prescribed
in “”, but
none fix my problem.

Summary points:

  • Computer model: Dell XPS720 w/ a Sound Blaster Audigy 4 card.

  • On-board sound card is disabled in the BIOS.

  • When the computer books, I hear the normal speaker
    “thump” sound when the sound driver loads, hinting it’s
    not a driver problem.

  • I checked the Audio mixers (pavucontrol,
    gnome-volume-control), and nothing is muted.

  • Config files like “/etc/modprobe.d/50-sound.conf” seemingly
    have the right entries.

  • When I test the sound with
    “user$ speaker-test -Dplug:front -c2 -l5 -twav” I can
    hear the very VERY faint testsound (I mean I have to
    turn the volume all the way up to barely hear it).

  • pavucontrol and other volume control tabs always
    show dummy-output, or blank instead of SBAugidy-4.
    And when it occassionally shows SBAudigy-4, still no
    sound output. This is true even when “pulseaudio”
    daemon is running.

  • Finally this all work in FedoraCore-10, but not
    FedoraCore-12. That’s why I switched to openSUSE
    (in addition to opsenSUSE supporting XEN nicely).
    The point is, something about HAL has probably

  • I placed myself as a member of the “audio” group,
    just in case.

  • Codecs are all installed.

Nothing is working out. And I get the feeling it has to do
with the X windowing system (I run IceWM from run-level
3 to avoid all those unnecessary daemons at run-level 5).
I’ll be it’s capturing something when I start it.

Any ideas on anything. I’m stuck. This is so crappy.:frowning:

Thanks In Advance,


Let me update the above.

To test further, I logged out of the windowing system
completely and onto the Unix cli prompt. At the unix
prompt, with and without DBUS and HALD running, the result
of running the test sound command
“$ speaker-test -Dplug:front -c2 -l5 -twav”
as both myself and root is the same: an extremely extremely
very faint sound from the speakers (oscillating from back
and forth, left/right/left/right). However faint it is,
it’s also distorted, probably becauese I have to turn the
volume knob all the way up. The sound is so faint that
it’s indiscernable.

I guess the point is that it’s truly something basic
system wise. It’s an DELL XPS720; on-board audio is
off. Below I provided lsmod output, and other goodies.
Any ideas. I’m stuck. Thanks!!!

root@linux-o3u6$ cat /proc/asound/modules
0 snd_emu10k1

root@linux-o3u6$ cat /proc/asound/cards
0 [Audigy2 ]: Audigy2 - SB Audigy 4 PRO [SB0380]
SB Audigy 4 PRO [SB0380] (rev.4, serial:0x20071102) at 0xccc0,
irq 17

root@linux-o3u6# cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-emu10k1

ZcKW.koLs3KhhqB9:SB Audigy

alias snd-card-0 snd-emu10k1

nmvega@linux-o3u6$ lsmod
Module Size Used by
snd_pcm_oss 60032 0
snd_mixer_oss 22728 1 snd_pcm_oss
snd_seq_midi 10304 0
snd_emu10k1_synth 9672 0
snd_emux_synth 52008 1 snd_emu10k1_synth
snd_seq_virmidi 9192 1 snd_emux_synth
snd_seq_midi_event 10600 2 snd_seq_midi,snd_seq_virmidi
snd_seq_midi_emul 9416 1 snd_emux_synth
snd_seq 78560 5 snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
edd 13232 0
vboxnetadp 8448 0
vboxnetflt 19184 0
vboxdrv 1810796 2 vboxnetadp,vboxnetflt
bridge 75144 1
stp 3340 1 bridge
llc 8848 2 bridge,stp
fuse 87984 1
loop 22292 0
sbp2 31216 0
dm_mod 101544 0
joydev 14400 0
snd_emu10k1 183392 1 snd_emu10k1_synth
snd_rawmidi 32064 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
snd_ac97_codec 148216 1 snd_emu10k1
ac97_bus 2632 1 snd_ac97_codec
snd_pcm 117808 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_seq_device 10460 6 snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer 32152 3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc 12600 2 snd_emu10k1,snd_pcm
snd_util_mem 6440 2 snd_emux_synth,snd_emu10k1
snd_hwdep 11216 2 snd_emux_synth,snd_emu10k1
snd 97608 15 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
ohci1394 38340 1
dcdbas 13464 0
pcspkr 3720 0
sr_mod 20964 0
cdrom 48232 1 sr_mod
ieee1394 121024 2 sbp2,ohci1394
serio_raw 7916 0
sg 40128 0
i2c_nforce2 10256 0
tg3 141100 0
nvidia 9647368 28
wmi 9600 0
button 8360 0
ext4 426008 2
jbd2 115712 1 ext4
crc16 2504 1 ext4
fan 6352 0
processor 56932 0
ide_pci_generic 5484 0
amd74xx 8080 0
ide_core 148064 2 ide_pci_generic,amd74xx
ata_generic 6508 0
pata_amd 16748 0
sata_nv 32084 2
thermal 25160 0
thermal_sys 21888 3 fan,processor,thermal

Can you provide more information ? … I know its a pain to do so, but it might help better understand what is happening … Please provide the information recommended to be provided in the second half of the multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums

i.e. :

please post in this … sub-forum, providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Are you using creative’s linux drivers for that card or the open source? I know when I was running a creative card I had to use the creative driver to get it to work, which was fine but every time I got a kernel update the sound would stop working and would have reinstall the driver. Sorry if I totally miss the mark, but thought it may be an idea.