openSUSE 11.2 Milestone 4 + Nvidia drivers?

Anyone managed to install the nvidia drivers on milestoen 4 yet?


ERROR: The kernel header file '/usr/src/linux/include/linux/version.h' does not
       exist.  The most likely reason for this is that the kernel source files
       in '/usr/src/linux' have not been configured.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at

linux-kernel-headers and kernel-syms are both installed and I did exactly what I did for milestone 3 to get the drivers working, no luck this time.

Strange I had the same sort of error and message when recompiling latest VBox kernel module on M3 and kernel was at 2.6.30-10.1 and another user on 2.6.30-10.3 had clean compile of it. I tried reinstalling VBox - no change. It was obviously a buggy kernel-something. My kernel and kernel-syms were at the same level (must be! I think) but iirc -headers wasn’t (no matter). No progress, waited for next update. On the latest M4,, no problem recompiling VBox module. So, wait for a fix is my guess. :expressionless:

Hmmm strange,

I managed to compile and install nvidia drivers today. I followed exactly these guide -> NVIDIA/The hard way - openSUSE

I did a fresh install for milestone 4 with the kde live cd.
I installed both kernel-source and kernel-syms and when i tried to compile the nvidia driver i got an error, i don’t remember what exactly(something about different version of gcc used for nvidia and the kernel?). So i went into the linux folder and did a “make mrproper”, “make cloneconfig” and “make modules_prepare”. After this it compiled ok 'till the end where i got an error about saying it cannon load the module “nvidia.ko” because…i don’t remember :). So i did a “sh -k $(uname -r)”, i was asked at the end if i want the installer to modify my xorg.conf, i said yes, i restarted the system and then the system booted up perfectly with the nvidia driver working.

I have no idea if it has anything to do with you problem, but i hope it helps!

I updated to Milestone 4 via the repositories without any problems. I recompiled my NVIDIA driver the same way that I did on milestone 3. sudo sh NVIDIA…run -q then sax2 -r -m 0=nvidia I of course have the Linux Kernel headers and syms installed.

The driver works great and Compiz too :slight_smile:


For Nvidia i have installed kernel-default-devel only… and the process work fine.

Yes, it has been simplified in 11.2 to install all development files by installing kernel-default/desktop-devel :slight_smile:

Is a “init 3” as root enough to kill xorg?

Yes, unless you have X server set to run also on the 3rd level which by default is not :slight_smile:
It actually isn’t necessary to call init 3.
It suffices when you login to first TTY by going there with Ctrl+Alt+F1, invoke /etc/init.d/xdm stop, install drivers and once again /etc/init.d/xdm start.

Perhaps you can detail how you went about doing this, for those of us that are not so saavy?

I installed the kernel other users recommended but the Nvidia installer still gave errors of not being able to locate it.

Please advise, if possible. Thanks.