OpenSUSE 11.2 Milestone 1 Findings

So I’ve installed openSUSE 11.2 on 2 different systems so far.

On the (home)server out of necessity, since my system seems to be quite fond of corrupting it’s disk and I was hoping the new Kernel would fix things… it did not.
System doesn’t seem to have gotten any faster either.

On the desktop, my god … is it fast. Starts like Windows XP does after it’s just installed. Running as smooth as can be, and the desktop only got 1GB of RAM atm.

The Good

  1. Speed
  2. Wording in yast when it’s trying to install a 32 bit package instead of 64 bits to resolve some error it calls it “inferior architecture” or something like that. Quite like it, as it’s an indication something is being resolved in an odd way.
  3. The orange Aardvark for YaST stands out way more iconwise, much easier to find in the menu/taskbar.
  4. The install didn’t even require a reboot!
    And it’s the same old well thought out process, select your settings, click ok… grab a coffee and it will be done a 20-30 minutes.
  5. YaST software management got some improvements layout wise (QT version at least did) and they do ease the use… takes some getting used to however.

The Bad

  • Overview of what happened after installing software using YaST software management is disabled by default.
    (Can be enabled via YaST Control Center > System > /etc/sysconfig Editor and then under System > YaST2 > GUI you change the PKGMGR_ACTION_AT_EXIT setting from ‘close’ to ‘summary’)
    In my opinion this should be enabled by default, it’s just confusing having a program closing itself when it’s done… I’ll start wondering if I ran it in the first place or if it crashed.

  • KDE4 Network Manager is still buggy

  • IP6 is STILL
    enabled by default… who made that decision. It’s responsible for over half the wired network problems help threads and I doubt anyone would have problems having to manually activate it if they are among the few people that want/need it.

ctrl+f4 still takes me to virtual desktop #4 instead of closing the tab in Firefox… but then again,ctrl+w closes a tab quite nicely as well.

Seeing the huge speed boost on my desktop I am tempted to install it on my laptop, as I have to reboot it quite often to switch OS and who knows… maybe I’ll finally get a wireless PEAP connection working.

Okay… so I ended up installing it on my laptop, still not much luck with the wireless it seems but…

  • GTK based applications look a ton better, it no longer looks like they’re preventing you from using them under KDE by making them as ugly as possible. (Scrollbar in particular looks a ton better imo)
  • Shutdown hanging on unmounting NFS shares no longer happens
  • Can’t tell for sure yet, but it seems desktop effects (kwin) might actually work decently now with a dual monitor setup.
  • Got the same speed increase with booting as on the desktop.

Might install it on an older laptop as well which has some problems with the graphics driver under 11.1 (not under 11.0).

What wireless device does your laptop use? Do you think this is a kernel incompatibility, or just a setup issue where 11.2 milestone1 is still incredibly unfriendly in automatically setting up one’s wireless?

Interesting that you have a dual monitor setup, and that graphics are working. Out of curiousity, what graphic hardware do you have, and what graphic driver are you using?

Interesting, you are not the first to mention this. I confess I did not notice the boot speed increase, but then I don’t pay attention typically to the boot speed. … I need to make a deliberate effort to note. … I think I’ll do a test now comparing 11.1 to 11.2-milestone1 boot speed, and see what I get.

Thanks for sharing your observations. Don’t forget to write bug reports on things you believe must be fixed! Submitting Bug Reports - openSUSE

OK, I did a VERY UNOFFICIAL boot test on my 9 year old Sandbox PC, which is has an athlon-1100 32-bit CPU, with 1GB RAM on an old MSI KT3 Ultra motherboard, with a nVidia FX5200 AGP graphic card. All boot times started at Grub menu selection. Run level 3 tests completed when log in seen. Run Level 5 tests completed when panel in lower right corner (in KDE) was fully populated.

My boot times were:

  • 49 seconds - openSUSE-11.2 milestone1 to Run Level 3
  • 53 seconds - openSUSE-11.1 to Run Level 3
  • 76 seconds - openSUSE-11.2 milestone1 to Run Level 5 with KDE-4.2.3 (with panel fully populated, else boot is 8 to 10 seconds sooner)
  • 77 seconds - openSUSE-11.1 to Run Level 5 with KDE-3.5.10 (with panel fully populated else boot is 8 to 10 seconds sooner).

So on my old Sandbox PC, I think I have confirmed your observation, although I do not believe on my old hardware, the improvement in boot time is as significant as what some have observed. Hardware, and the hard drive partitioning setup of various PCs, may play a roll here.

Still, 11.2 milestone1 boot is faster. Its DEFINITELY the correct direction to go.

I got the most common wireless card there is, an intel agn 4965.
The network managers (KDE/Gnome/wicd) seem to hate it and sometimes don’t even see ONE network while theres 12+ around.
iwlist scan always sees all of them.
Installing the wireless-tools helped me in the past, but doesn’t seem to make a difference nowadays.

Never ever had it working at college where the connection is WPA2/PEAP. It doesn’t seem to get the certificate or something.

My graphics hardware atm is 2 monitors of 1680*1050 hooked up to a Nvidia 9600M running the proprietary 180.51 drivers. (installed using the ‘hard way’). Which worked quite fine before, especially with KDE4.2 but for some reason disabled the desktop effects on every boot. Logging out / nvidia-xconfig / logging in did fix it though… as did booting with just one monitor.
Now it just works.

And the time it takes to boot performance gain is certainly very hardware depedent as on my server it isn’t noticable. And a guestimate of my desktop/laptop I’d put at -20s/-10s.

Seems like I cheered to soon thinking it did unmount nfs properly now, as it did not on the second reboot (think they might not have been mounted at all at the first boot ;))

A fix for wireless shoulld be out shortly

I created a new stickie here, calling for tester of openSUSE-11.2 milestone:
openSUSE-11.2 - CALL FOR TESTERS - openSUSE Forums

Note, we need you testing NOW!! not later, as the longer you wait to test, the more difficult it will be to get your bug fixes done before the 11.2 release.

The above stickie location may move, as we already have 2 stickies in pre-release/beta. We may merge that with one of the existing stickies (or visa versa). The precise location for this “call for help” post is being discussed internally now amongst the mods/admins. Hence that link may change with time.

Again a bugreport 504601

usblp hp s4280 and f4280 dont get output
the processing is halted , or in a loop or straight forward to a nonexisting lp printer

this is my 2e burgreport about this

I am downloading the installation dvd now. Going to wipe a laptop I have here and test it on that. Should be fun. I will install KDE4 since this is what i am formiliar with. Any advice on how to test things? As in methods. I know a bit about bug reporting so I will do my best to come up with some good ones! :slight_smile:

On openSUSE-11.1 with KDE-4.1.3, the hotplug automounting of my Canon Ixus 800 IS (to call digikam to download pix) did not work with KDE-4.1.3. It did work under KDE-3.5.10 on same PC.

So on the same PC, with KDE-4.2.3 and openSUSE-11.2 milestone1, I plugged my Canon Ixus 800IS and it was automounted, recognized, digikam option available, I selected that option, and downloaded the pictures easily (albeit rather slow - possibly due to old PC being so old).

So this has been fixed and the fix is in 4.2.3 in openSUSE-11.2 milestone1 and its VERY NICE to see implemented.

I have no advise wrt methods, other than if things do not work, give some thought to what log files, and diagnostic information you may be able to provide.

My recommendation is to test the things that are most important to you, that you really want to see working in 11.2. Even basic things need to be tested. Also the items you use all the time (and hence are very familiar with their expected behavour) are good things to test, as you are likely one of the best people qualified to test such functions.

Some pet peeves or simply important things to me that I want to test are :

  • some desktop candy that 'till now only worked under KDE3;
  • hotplug auto mounting of camera
  • hotplug auto mounting of firewire and usb external drives (NTFS) and also memory sticks (VFAT);
  • audio
  • vnc
  • k3b
  • word processing, spreadsheet, browsing
    *]and of course recognition of all my PC’s hardware (including things such as webcam)

I think it also has to do with actual kde4 versions of certain programs in this case digikam. By default 11.1 installs the kde3 version and it will therefore not be an option in the device manager. I noticed the same when I installed kde4-digikam on my 11.1 machine. All of a sudden my camera works with an option.

I tested openSUSE-11.2 with KDE-4.2.3 with my web cam in a limited test.

According to “lsusb” (which does function) my web cam is a :

0471:0311 Phillips PCVC740K ToUcam Pro [pwc]

I started kopete, and tried to configure the web cam, and kopete crashed immediately upon start of the configuration. I saw that it recognized the camera but then it crashed immediately after, I believe without me pressing anything (except < Print Screen > ). (and “print screen” did not work, and I do have KDE4-ksnapshot installed. )

The error message I obtained was:
“A fatal error occured. The application (kopete) crashed and caused the signal 11 (SIGSEGV).” … When I selected details under the crash handler, it also had a failure, indicating the back trace did not work.

So two possible bugs are :

  • kopete does not
    function with my Phillips Webcam on KDE-4.2.3 with 11.2 milestone1 (kopete does function on same PC with openSUSE-11.1 and KDE-3.5.10).
  • print screen does not
    function in KDE-4.2.3 as built on 11.2 milestone1

I can see now, I need to have my digital camera handy during subsequent tests, as the print screen does not function, and I need some easy means to capture the error messages as they flash by.

[/li]Hmmm … I just rebooted and tested kopete on 11.1 with KDE-3.5.10. The webcam does not function under openSUSE-11.1 with kopete either. However it does work under openSUSE-11.1 with the packman packaged “camorama”.

So at the moment I am unable to compare apples to apples and I can not categorically state that the web cam does not function in openSUSE-11.2 milestone1. It could be it does and I simply need to find the appropriate application to conduct a test.

My findings of openSUSE 11.2 Milestone 1 is that they are already heading
in the right direction, and if the devs can keep this up then by the time
11.2 is finalized it will be a great release. I love the fast boot and
how responsive it is on my old PC, it is running on a first gen slot 1 P3
with ~312 MB of ram, on this system booting takes less than a minute! As
for KDE I haven’t played with it much my test system here is only text
mode, but I was surprised to see that they didn’t go with Firefox 3.1
beta for the firefox in this release, I have it installed on my Mac and
it is great for a beta. The biggest downside I see with it right now is
that it doesn’t see my network card on boot so I have to run yast lan and
rcnetwork restart before it sees my card and configures it, which is no
big deal and there is a bug report filed for it so now I wait.

“We must plan for freedom, and not only for security, if for no other
reason than only freedom can make security more secure.” Karl Popper

My Canon Powershot G9 never hotpluged in 11.1 but does in 11.2. I took a look at /lib/udev/rules.d/50-udev-default.rules and this seems to be the difference, I can copy that file over to 11.1 and the camera hotplugs. I’m running Gnome so it seems to be a generic solution. The new 50-udev-default.rules also makes USB support in VirtualBox work with no mods, possibly it will cause problems for certain printers, LaserJets, but we will have a look at that later. The difference between the two files is quite significant:

hank@ernst:~> diff 50-udev-default.rules-11.1 50-udev-default.rules-11.2
1a2
> # initramfs:default
3,9c4,13
< KERNEL==“pty[pqrstuvwxyzabcdef][0123456789abcdef]”, GROUP=“tty”, MODE=“0660”, OPTIONS+=“last_rule”
< KERNEL==“tty[pqrstuvwxyzabcdef][0123456789abcdef]”, GROUP=“tty”, MODE=“0660”, OPTIONS+=“last_rule”
< KERNEL==“ptmx”, GROUP=“tty”, MODE=“0666”, OPTIONS+=“last_rule”
< KERNEL==“tty”, GROUP=“tty”, MODE=“0666”, OPTIONS+=“last_rule”
< KERNEL==“tty[0-9]", GROUP=“tty”, MODE=“0620”, OPTIONS+=“last_rule”
< KERNEL=="vcs|vcs[0-9]
|vcsa|vcsa[0-9]*”, GROUP=“tty”, OPTIONS+=“last_rule”
< KERNEL==“console”, MODE=“0600”, OPTIONS+=“last_rule”

> SUBSYSTEM==“block”, SYMLINK+=“block/%M:%m”
> SUBSYSTEM!=“block”, SYMLINK+=“char/%M:%m”
>
> KERNEL==“pty[pqrstuvwxyzabcdef][0123456789abcdef]”, GROUP=“tty”, MODE=“0660”
> KERNEL==“tty[pqrstuvwxyzabcdef][0123456789abcdef]”, GROUP=“tty”, MODE=“0660”
> KERNEL==“ptmx”, GROUP=“tty”, MODE=“0666”
> KERNEL==“tty”, GROUP=“tty”, MODE=“0666”
> KERNEL==“tty[0-9]", GROUP=“tty”, MODE=“0620”
> KERNEL=="vcs|vcs[0-9]
|vcsa|vcsa[0-9]", GROUP=“tty”
> KERNEL==“console”, MODE=“0600”
12,16c16,19
< KERNEL=="tty[A-Z]
|pppox*|ircomm*|noz*”, GROUP=“uucp”
< KERNEL==“ppp”, MODE=“0600”, OPTIONS+=“ignore_remove”
< KERNEL==“mwave”, NAME=“modems/mwave”, GROUP=“uucp”
< KERNEL==“hvc*|hvsi*”, GROUP=“uucp”
< KERNEL==“lirc0”, SYMLINK+=“lirc”

> KERNEL==“tty[A-Z][0-9]|pppox[0-9]|ircomm[0-9]|noz[0-9]”, GROUP=“dialout”
> KERNEL==“ppp”, MODE=“0600”
> KERNEL==“mwave”, NAME=“modems/mwave”, GROUP=“dialout”
> KERNEL==“hvc*|hvsi*”, GROUP=“dialout”
20d22
< KERNEL==“null”, SYMLINK+=“XOR”
22,23d23
< KERNEL==“ram0”, SYMLINK+=“ramdisk”
< KERNEL==“ram1”, SYMLINK+=“ram”
27,28c27,28
< KERNEL==“ts[0-9]|uinput", NAME=“input/%k”, MODE=“0600”
< KERNEL=="js[0-9]
”, NAME=“input/%k”, MODE=“0644”, SYMLINK+=“%k”

> KERNEL==“ts[0-9]|uinput", NAME=“input/%k”, MODE=“0640”
> KERNEL=="js[0-9]
”, NAME=“input/%k”, MODE=“0644”
31,33c31,34
< KERNEL==“vbi0”, SYMLINK+=“vbi”
< KERNEL==“radio0”, SYMLINK+=“radio”
< KERNEL==“video0”, SYMLINK+=“video”

> SUBSYSTEM==“video4linux”, GROUP=“video”
> KERNEL==“vttuner*”, GROUP=“video”
> KERNEL==“vtx*|vbi*”, GROUP=“video”
> KERNEL==“winradio*”, GROUP=“video”
36,41c37,46
< KERNEL==“agpgart”, MODE=“0600”
< KERNEL==“card[0-9]“, NAME=“dri/%k”, MODE=“0666”
< KERNEL==“fb0”, SYMLINK+=“fb”
<
< # DVB video
< SUBSYSTEM==“dvb”, PROGRAM=”/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter%%i/%%s $${K%%%%.
} $${K#*.}'”, NAME=“%c”

> KERNEL==“agpgart”, MODE=“0600”, GROUP=“video”
> KERNEL==“card[0-9]", NAME=“dri/%k”
> KERNEL==“pmu”, GROUP=“video”
> KERNEL=="nvidia
|nvidiactl*”, GROUP=“video”
> SUBSYSTEM==“graphics”, GROUP=“video”
> SUBSYSTEM==“drm”, GROUP=“video”
>
> # DVB (video)
> SUBSYSTEM==“dvb”, ENV{DVB_ADAPTER_NUM}==“?“, NAME=“dvb/adapter$env{DVB_ADAPTER_NUM}/$env{DVB_DEVICE_TYPE}$env{DVB_DEVICE_NUM}”, GROUP=“video”
> SUBSYSTEM==“dvb”, ENV{DVB_ADAPTER_NUM}==”“, PROGRAM=”/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter%%i/%%s $${K%%%%.
} $${K#.}'“, NAME=”%c", GROUP=“video”
44,48c49,50
< KERNEL=="dv1394
”, SYMLINK+=“dv1394/%n”
< KERNEL==“video1394*”, NAME=“video1394/%n”
<
< # firmware class requests
< SUBSYSTEM==“firmware”, ACTION==“add”, RUN+=“firmware.sh”

> KERNEL==“dv1394[0-9]", NAME=“dv1394/%n”, GROUP=“video”
> KERNEL=="video1394[0-9]
”, NAME=“video1394/%n”, GROUP=“video”
51c53
< #SUBSYSTEM==“usb”, ENV{DEVTYPE}==“usb_device”, NAME=“bus/usb/$env{BUSNUM}/$env{DEVNUM}”, MODE=“0644”

> SUBSYSTEM==“usb”, ENV{DEVTYPE}==“usb_device”, NAME=“bus/usb/$env{BUSNUM}/$env{DEVNUM}”, MODE=“0664”
55a58
> SUBSYSTEM==“ppdev”, GROUP=“lp”
57c60
< KERNEL==“lp[0-9]*”, GROUP=“lp”, SYMLINK+=“par%n”

> KERNEL==“lp[0-9]*”, GROUP=“lp”
60c63
< # block, tapes, block-releated

> # block
62,64c65,67
< SUBSYSTEM==“block”, KERNEL==“sr[0-9]", SYMLINK+=“scd%n”
< KERNEL=="hd
”, SUBSYSTEMS==“ide”, ATTRS{media}==“floppy”, OPTIONS+=“all_partitions”
< KERNEL==“fd[0-9]”, GROUP=“floppy”

>
> # floppy
> KERNEL==“fd[0-9]”, GROUP=“floppy”
66,70c69,86
< KERNEL==“sch[0-9]", GROUP=“disk”
< KERNEL=="sg[0-9]
”, ATTRS{type}!=“3|6”, GROUP=“disk”, MODE=“0640”
< KERNEL==“ht[0-9]|nht[0-9]”, GROUP=“disk”
< KERNEL==“pg[0-9]", GROUP=“disk”
< KERNEL=="pt[0-9]
|npt[0-9]*”, GROUP=“disk”

> KERNEL==“hd*”, SUBSYSTEMS==“ide”, ATTRS{media}==“floppy”, OPTIONS+=“all_partitions”
>
> # cdrom
> SUBSYSTEM==“block”, KERNEL==“sr[0-9]", SYMLINK+=“scd%n”, GROUP=“cdrom”
> SUBSYSTEM==“block”, KERNEL=="hd
”, SUBSYSTEMS==“ide”, ATTRS{media}==“cdrom”, GROUP=“cdrom”
> SUBSYSTEMS==“scsi”, ATTRS{type}==“4|5”, GROUP=“cdrom”
> KERNEL==“pktcdvd[0-9]", NAME=“pktcdvd/%k”, GROUP=“cdrom”
> KERNEL==“pktcdvd”, NAME=“pktcdvd/control”, GROUP=“cdrom”
>
> # tape
> KERNEL=="ht[0-9]
|nht[0-9]", GROUP=“tape”
> KERNEL=="pt[0-9]
|npt[0-9]|pht[0-9]”, GROUP=“tape”
> SUBSYSTEMS==“scsi”, ATTRS{type}==“1|8”, GROUP=“tape”
>
> # block-releated
> KERNEL==“sch[0-9]", GROUP=“disk”
> SUBSYSTEMS==“scsi”, ATTRS{type}==“0”, GROUP=“disk”
> KERNEL=="pg[0-9]
”, GROUP=“disk”
72c88
< KERNEL==“rawctl”, NAME=“raw/%k”, GROUP=“disk”

> KERNEL==“rawctl”, NAME=“raw/rawctl”, GROUP=“disk”
74,78c90,92
< KERNEL==“pktcdvd[0-9]*”, NAME=“pktcdvd/%k”
< KERNEL==“pktcdvd”, NAME=“pktcdvd/control”
< KERNEL==“qft0”, SYMLINK+=“ftape”
< SUBSYSTEM==“bsg”, NAME=“bsg/%k”
< SUBSYSTEM==“aoe”, NAME=“etherd/%k”, GROUP=“disk”

> SUBSYSTEM==“bsg”, NAME=“bsg/%k”
> SUBSYSTEM==“aoe”, NAME=“etherd/%k”, GROUP=“disk”, MODE=“0220”
> SUBSYSTEM==“aoe”, KERNEL==“err”, MODE=“0440”
81c95
< KERNEL==“tun”, NAME=“net/%k”, MODE=“0666”, OPTIONS+=“ignore_remove”

> KERNEL==“tun”, NAME=“net/%k”, MODE=“0666”
90,91c104
< KERNEL==“rtc|rtc0”, MODE=“0644”
< KERNEL==“rtc0”, SYMLINK+=“rtc”

> SUBSYSTEM==“rtc”, DRIVERS==“rtc_cmos”, SYMLINK+=“rtc”
93c106
< KERNEL==“hw_random”, NAME=“hwrng”, SYMLINK+=“%k”

> KERNEL==“hw_random”, NAME=“hwrng”
97,100c110,111
< KERNEL==“sbpcd0”, SYMLINK+=“sbpcd”
< KERNEL==“slram[0-9]*”, SYMLINK+=“xpram%n”
< KERNEL==“sxctl”, NAME=“specialix_sxctl”, SYMLINK+=“%k”
< KERNEL==“rioctl”, NAME=“specialix_rioctl”, SYMLINK+=“%k”

> KERNEL==“sxctl”, NAME=“specialix_sxctl”"
> KERNEL==“rioctl”, NAME=“specialix_rioctl”
101a113,117
> KERNEL==“hiddev[0-9]", NAME=“usb/%k”
> KERNEL=="legousbtower[0-9]
”, NAME=“usb/%k”
> KERNEL==“dabusb[0-9]", NAME=“usb/%k”
> KERNEL=="usbdpfp[0-9]
”, NAME=“usb/%k”
> KERNEL==“cpad[0-9]*”, NAME=“usb/%k”
105c121
<

> ACTION==“remove”, NAME==“”, TEST==“/lib/udev/devices/%k”, OPTIONS+=“ignore_remove”

Wow! Thats pretty neat. I’m hoping we can attract more users to test openSUSE-11.2, so we can flush out the good and bad, and work toward making this a good release. openSUSE-10.2 was one of my favourites (a big improvement over openSUSE-11.1) and while I like openSUSE-11.1, it would be really nice to see 11.2 as a big jump in improved functionality over 11.1.

sadly the issue with intel i845 onboard video is still present from 11.1. is this going to be fixed? otherwise it looks like i’ll have to stick to 11.0 :frowning:

This is not the place to ask. Please raise a bug report on it. Then track the bug report and see what is noted there.

The stickie giving guidance is here: openSUSE-11.2 - CALL FOR TESTERS - openSUSE Forums

Thanks for picking this up, and PLEASE do write the bug report. 11.2 is still 6 months away from release, and there is still hope if users bring this to the attention of those who can fix it.

right. done.