openSUSE 11.2 mass install on 12 identical PC's?

Hi, I’ve been using Linux for years, but am new to openSUSE, thanks to the really nice 11.2 release.

I have 12 identical PC’s in my classroom at work, and I would like to install OpenSUSE 11.2 on all of them, doing a master install/configure on one machine and cloning all the others to be identical to the master install. (All 12 are networked via Ethernet).

I know how to install and configure the master machine, but not how to duplicate it to all the others. I’d rather not use up 12 hours or more installing and configuring every PC individually. Particularly since the IT goons will probably come along and reinstall Windows every so often without my permission or input, so I’ll have to re-install Linux again.

Does OpenSUSE provide any tools for this task (multiple identical installs on identical machines), or if not, is there any other way to do this?

Also, is there a way to push updates to all 12 PC’s from one of them, rather than downloading hundreds of megabytes of duplicate updates to each machine individually?

Thanks for any replies.


You can clone the drives using Gparted Live CD or Parted Magic Live CD.

If the clone is to be 100% identical and the PCs are 100% identical, and there is NOT one bit different, you could also clone with dd …

However my experience from reading various threads is users often mess this up by either deviating intentionally or unintentionally.

… anyway, here is a guide that may give you some ideas:
Cloning an old drive to a new drive - openSUSE Forums

note if cloning you must change the /etc/fstab and /boot/grub/menu.lst to be generic because the hardware IDs will be different.

I do have quite some experience on this. Identical machines often are not identical. Despite identical brand and modelnumber. But it can be done, with some manual preparation, and the use of ‘dd’.

During install, tell the partitioner to mount partitions by Device Name, instead of the default by Device ID. At bootloader configuration, also change the kernel and initrd’s paths that way.

After the install, use that machine for cloning. This means you take out the disk of nr.2, connect it in nr.1, check in the BIOS that nr.1’s own is the first disk, nr.2’s the second.
Then do:

dd if=/dev/sda of=/dev/sdb

This clones the disk. I would start nr.2, see if it runs as good as nr.1, then repeat same procedure for the disks of the other ones, but now I have 2 PC’s to clone disks in, the rest of the math is yours.

On the updates: you could sync the openSUSE Update repo to your ‘master’, export it with NFS, so the others would only pull in the updates through the local network. On occasions like this I tend to download the entire repo just once, to update after install, get the syncing working afterwards.

Just throwing a couple ideas out, but what about something like AutoYaST, or creating an installation server?

Thanks for all the replies. Much appreciated.

While’ I’ve used dd for individual disk backups in the past, I’m not a big fan because it is “dumb” and takes forever to image large hard drives, even if the filesystems are mostly empty, because it copies every bit, where it contains data or not.

I also would have a hard time physically removing and re-installing drives from each PC in turn - not only do these things use special security-type screws, the PC’s are suspended in sliding cages under the desks in the classroom. I’d have to spend lots of time crawling around on the floor with a set of special screwdriver security bits. In fact, I could probably do a full install on each machine (the usual way, by sticking the installation DVD in each one in turn) in less time.

Wrath5000’s post is interesting: I hadn’t heard of AutoYast before (I’m new to SUSE/OpenSUSE). With only 12 PC’s to deal with, an automated Yast install would probably be a simpler solution than trying to get installs done over the network. A Google search turned up some comprehensive but old (2006) information, which is hopefully still valid:

Knurpht, thank you, an Nvidia tip you gave someone else already helped me. (I updated my kernel so the one-click Nvidia driver install didn’t work). Back to this thread, any tips on what exactly I need to do to get the openSUSE update repo on a local machine, and get the other machines pointed at it? I get the general idea, but am foggy on the details.



Gnobuddy wrote:

> Wrath5000’s post is interesting: what is AutoYast (presumably a way to
> automate an install?), and where can I find a bit more information on
> it? With only 12 PC’s to deal with, an automated Yast install would
> probably be a simpler solution than trying to get installs done over the
> network.

There is a FAQ for autoyast on
and a somewhat old documentation on
maybe you will find a newer one.

Thanks for the reply, Martin.

Unfortunately three different PC’s and two laptops (5 machines in all) on which I had installed OpenSUSE 11.2 have now demonstrated the same sequence of progressively more buggy behaviour: first the desktop plasmoid disappears, then applications minimize without placing an icon in the panel so you can’t re-open them, then various binaries segfault when launched (Kaffeine, Kate, Konqueror among them). The machine I’m typing this on (a Dell Optiplex 760) has already developed the first two of these problems, so the third is probably not far behind.

I don’t know if these issues are caused by KDE 4 problems (seems likely), or the underlying OpenSUSE 11.2 software. Either way, they are show-stoppers, so I’m forced to search for a more stable KDE distro. I find Gnome almost unusable, otherwise I’d try Gnome on OpenSUSE 11.2.

Pity, I really liked OpenSUSE 11.2, particularly its speed - it runs very noticeably faster than recent Kubuntu/Ubuntu versions on the same hardware. I’ll look forward to the next OpenSUSE release. Meantime, Kubuntu 10.04 beta (with KDE 4.4.1 after installing updates) appears more stable…so far, at least.


Gnobuddy, I get none of this behaviour on 5 different PCs on which I have installed openSUSE-11.2 KDE4 (4 desktops and 1 laptop). [6 PC’s if one’ includes openSUSE-11.1 in addition to 11.2. No such problem as you describe].

The only thing I can conclude is my lack of any such problem is systemic, and your problem is systemic. ie I am doing the same thing over and over such that my KDE4 works, and you are doing the same thing over and over such that yours breaks.

What would be useful would be to figure out what it is that you are doing to break things, where I am simply not able to reproduce this systemic behavior of yours in any way.

I should add that these 6 PCs are used a LOT for all sorts of things. They are really run thru the paces with no breakage.

Like I say, I think it systemic and it would be useful if you could quantize this so what ever it is you are doing can be nailed down.

Sounds like it could be hardware issues as Oldcpu suggested–perhaps the hard drives? Another possibility is a bad download/burn. Did you check md5 sums and check the install media before embarking on your 12-PC foray? Did you burn at the lowest speed?

I don’t know if these issues are caused by KDE 4 problems (seems likely), or the underlying OpenSUSE 11.2 software. Either way, they are show-stoppers, so I’m forced to search for a more stable KDE distro. I find Gnome almost unusable, otherwise I’d try Gnome on OpenSUSE 11.2.

Xfce is a nice alternative to KDE and Gnome. It’s fairly lightweight and still quite feature-rich. It might be worth a try:)

Actually, by systemic I mean PEBKAC, where the same thing is unwittingly being done over and over. I was simply trying very hard to be tactful.

It’s very easy (and satisfying to the ego) to dismiss this as the problems of just another stupid user (me). However, convenient though that “explanation” may be, it simply doesn’t match the facts.

Let me give you a few more details: the same flaky behaviour has now shown up on multiple PC’s, with multiple hardware configs, belonging to multiple users, with multiple usage modes. One PC is my personal one at home, a Core 2 Duo/ECS motherboard machine I put together myself. Another is an HP Pavilion desktop belonging to a friend, which is based around a quad-core AMD Phenom. He is dual-booting it with Windows XP, and there are no problems with the machine while it is running Windows (i.e, there is clearly no hardware problem). A third is an HP Pavilion laptop belonging to a student who got excited when he saw me using Linux, and asked me to install it for him. The laptop is also dual-booting Windows, The remaining machines are Dell Optiplex 760’s with Core2 Duo/Intel motherboards installed in my classroom and used by my students.

So: I’m finding buggy behaviour with OpenSUSE 11.2 on a fairly wide range of PC hardware, used by several different users, and at least two of the machines are proven to have no hardware problems while running Windows. A third is now happily running Kubuntu 10.04 beta 1 with no evidence so far of any flaky behaviour, so I would say hardware problems are ruled out there as well.

Based on the facts, we’ve ruled out hardware problems, and we’ve ruled out user problems. That leaves software problems.

Why are some other users experiencing no problems? My guess would be that some portion of the software load is different. I’m using the 64-bit DVD version of OpenSUSE 11.2, with the KDE desktop and all official OpenSUSE updates applied. The Flash plugin is installed on all of the PC’s I’ve mentioned - it’s essential to their use. My home PC and my friends Pavilion both had Nvidia video cards, so I installed the Nvidia non-free drivers for those. The laptop has a Radeon video card, and the classroom PC’s have Intel graphics.

For whatever it’s worth, I’ve been using Linux since 2001, switching to it permanently in late 2001 or early 2002 with Mandrake 8.2. I’ve used FreeBSD a little, tried numerous Linux distros, and settled on Gentoo Linux as my main distro for many years, switching to Kubuntu these last couple of years as the entire Gentoo ecosystem slowly began to disintegrate. I’ve barely used Windows or OSX in a decade now, except a handful of times while visiting friends, or to play with the one Windows program I still use from time to time(an RC flight simulator).

None of that makes me a Linux expert, but since I’ve performed stage I Gentoo installs successfully in the past, clearly I’m not a raw newcomer to the OS randomly poking at shiny things on the desktop and breaking them through sheer ignorance. :slight_smile:

I note that OpenSUSE 11.3 Milestone 2 has been released, and will keep an eye on it as it evolves. Hopefully it will combine the speed and cohesiveness of 11.2 with the traditional SUSE stability.

Enjoy your weekend, everyone.


I also would guess it is software, or rather it is software used in a way different from the way I use the same ( ? ) software.

I have 11.2 installed on 5 PCs. Two 64-bit and 3 x 32-bit. All are running KDE-4.3.5.

One of the 64-bit has a nVidia GeForce GTX260. The other 64-bit has an ATI Radeon HD3450. Both cases proprietary drivers installed “the hardway” which is not hard. Both run fine with KDE-4.3.5. No crashes. No problems. No instability.

Of the 3 x 32-bit openSUSE-11.2. installs, two have nVidia cards (one PCI GeForce 8400GS and one AGP GeForce FX5200) with the proprietary nVida driver installed “the hardway” (which is not hard). The remaining PC has legacy ATI hardware, using the openSource Radeon driver. I updated the driver from the X11 : Xorg repository as the radeon driver packaged with openSUSE-11.2 is known to be buggy. All three have no crashes. No problems. No instability.

So why no crashes. The PCs get heavy use. Very heavy use. They just work !

Based on the facts, we’ve ruled out hardware problems. IMHO we are looking at how users use their software. …

Rather than complain about instability that I can NOT reproduce, nor can my friends who use openSUSE reproduce (which counting my friends would increase the # of openSUSE KDE-4.3.5 installed that I am tracking to > 12 with NO such problems) why not instead make an effort to figure out WHY you have problems that neither I nor my friends can reproduce ?

ie. what is in the log files when these instabilities occur?

Its easy to rant and complain. Its something else to contribute and try to figure out why one has a problem that no one else has.

Are all of these installs from the same disk? I’ll ask again: did you check the md5 sums after downloading, but BEFORE burning? Did you run checkmedia from the install disk BEFORE installing? Did you burn at the LOWEST speed?

If you answered “no” to any of the above questions, your installation media is a potential source for your compounding issues.

I’d recommend checking your install disk(s).

Based on the facts I would say you can rule out general opensuse 11.2 problems as well, because it is working for many people on many different devices. It would be a real surprise for me, if exactly the machines you are using are not compatible with OpenSuse (but all of them with other Linux distributions). So, you can rule out the users, the hardware, the software… what stays is the way you installed the system and, of course, the installation media. So, I would recommend to check the media and if it’s ok and still not working, I would recommend to rethink about your way of mass-installs.

I’ve seen AutoYaSt and the option to store the profile but never really understood how it worked.

If you use AutoYast to store a profile of one version (openSUSE 11.0 for example) can it be used to to install software and such with a newer version (e.g. 11.2) or does it have to be the same version?

I agree with Wrath… create a boot load on the network server and boot each computer from over the network boot.


Not sure if this is still relevant but I’ve been using “clonezilla” for a while now to reproduce an installed system.