Opensuse 11.2 KDE Wireless Network Connects BUT..

What’s getting me is this part of the error

/media.1/media

@deano_ferrari
Any ideas

Is this some hangover form the source install media

ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:0F:B0:5B:77:6A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                        
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)              
          Interrupt:19 Base address:0xa000                    

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:56 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                            
          RX bytes:3496 (3.4 Kb)  TX bytes:3496 (3.4 Kb)       

wlan0     Link encap:Ethernet  HWaddr 00:11:F5:42:41:7E  
          inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1              
          RX packets:6048 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5642 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5202160 (4.9 Mb)  TX bytes:1485376 (1.4 Mb)

wmaster0  Link encap:UNSPEC  HWaddr 00-11-F5-42-41-7E-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

cat /etc/resolv.conf:

### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 192.168.1.254

/sbin/route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 wlan0

i’ve been reading some threads about the abstractcommand.cc:195 (updates of repos)…

here’s the thread that made him get going again…

problem updating - openSUSE Forums

but i haven’t tried it, i know sir cef and sir dean knows another ideas about this matter… :slight_smile:

@caf4926
Yes, I’m thinking that zypper has got horribly confused part way through the refresh process. I’m wondering whether a brutal ‘rm -r /var/cache/zypp/raw’ might be needed, before attempting a refresh.

I remember a similar thread to this:

http://forums.opensuse.org/get-help-here/applications/388749-repo-non-oss-failed-cache-repo-139-a.html

dean,

should i try the command in konsole?..

i’ve read the thread, looks like it’s bloody scary…

It always pays to be wary, but in this case its just a cache. Make sure you type the command carefully (its done with dangerous root privileges that you now know about). I think ‘zypper clean -a’ will act similarly AFAIR.

Then try

zypper ref

Did you ever manage to disable ipv6 (by editing menu.lst) as explained by caf earlier?

yeah, first i thought it crashed but it is so sensitive it should be on what is in oirginal spacing, lines, shouldn’t be move but you can add some like (ipv6.disable=1)…

here’s the result:

linux-8glv:/home/aeiou07 # zypper clean -a
All repositories have been cleaned up.
linux-8glv:/home/aeiou07 # zypper ref
Retrieving repository ‘openSUSE-11.2-Non-Oss’ metadata ]Failed to download /media.1/media from http://download.opensuse.org/distribution/11.2/repo/non-oss/

i’m curious about this things in Yast GPG public key management:

Key: 1C721C2456B4177A
Name: openSUSE:Factory OBS Project <openSUSE:Factory@build.opensuse.org>
Finger Print: 00860AA0163A3CFEF326C1D91C721C2456B4177A
Created: 01/22/2008
Expires: 04/01/2010 (The key is expired.)

Key: A84EDAE89C800ACA
Name: SuSE Package Signing Key <build@suse.de>
Finger Print: 79C179B2E1C820C1890F9994A84EDAE89C800ACA
Created: 05/05/2008
Expires: 05/05/2010 (The key is expired.)

Key: E3A5C360307E3D54
Name: SuSE Package Signing Key <build@suse.de>
Finger Print: 4E98E67519D98DC7362A5990E3A5C360307E3D54
Created: 05/05/2008
Expires: 05/05/2010 (The key is expired.)

Actually, I’ve found a similar story to yours here:

PC Pitstop Forums > SuSe Network Manager

And in Milestone 6 release notes, it was reported

Downloads/updates with aria/metalink support will fail, work-around: “export ZYPP_ARIA2C=0″.

Now, I wouldn’t have expected a problem in the final release, but this workaround was used here as well:

zypper refresh problem - openSUSE Forums

Apparently the problem is not caused by the repositories but by the updated libzypp which uses aria2

@caf4926
What do you make of this?

There have been DNS and aria2 issues in 11.2 as you know and every case seems to differ. It seems to be a case of try everything and see.

If you on eth0, try a live cd for performance
Does it perform differently in a live session than the installed OS. I say this because there is always the possibility of a defective install medium giving some corruption. Of course that could apply equally to a Live cd if it was defective too.
So it’s always worth checking the install media. That might seem a bit backward, but sometimes we have to go back to basics.
@deano_ferrari has offered some good links too

yeah, i’ve read those threads and nothing goes seem to be fixed, still going back to beginning…

sir caf, i did check installation media after the burning and before installing to hd… and all went fine… but when i go updating the repos, fails…

Have you tried clearing the cache?

Also perhaps this
Clear Temp Files at Boot - openSUSE Forums

Have you tried setting up DNS manually in the eth0 config rather than leaving it to DHCP

Did you try what caf suggested last post?

The other thing I noticed from your ifconfig results was that you were using a wireless interface. Have you tried updating with a wired ethernet connection?

Nearly out of ideas here, but you might also want to read this thread (though I don’t think it will help you:

YAST, zypper corrupted after aborting update - openSUSE Forums

Your error is very different, but maybe related???

Essentially a problem with libzypp (during an update) required this workaround:

cd /usr/lib64 (for 64-bit system)
cd /usr/lib (for 32-bit system)
ln -s libzypp.so.631.0.4 libzypp.so.619

First i tried the clearing cache what sir caf said, then i changed my DNS manually, tried to check update with update applet it stays in query, so i make it manual in yast still the “abstractcommand.cc:195” still occurs…

and then here’s sir dean the result in libzypp:

linux-iq3x:/usr/lib # ln -s libzypp.so.631.0.4 libzypp.so.619
ln: creating symbolic link `libzypp.so.619': File exists
linux-iq3x:/usr/lib # zypper in -f yast2
System management is locked by the application with pid 4688 (/usr/lib/YaST2/bin/y2base).
Close this application before trying again.
linux-iq3x:/usr/lib # zypper in -f yast2
Retrieving repository 'openSUSE-11.2-Non-Oss' metadata \]Failed to download /media.1/media from http://download.opensuse.org/distribution/11.2/repo/non-oss/


Haven’t tried updating in wired… :slight_smile:

wired still the same, abstractcommand.cc:195 still occurs… :frowning:

Haven’t tried updating in wired…

Give that a go.

And for heavens sake. Right click on the updater applet - cofigure - ‘Do not Start at Boot’ - Quit - and then reboot.

i tried this morning connecting directly (wired) and updating still same problem (AbstractCommand.cc:195 still occurs)…

here’s the whole story maybe there’s something wrong with my process. after i download it, without any changes from the beginning, after i download the live KDE 11.2 torrent from opensuse’s webstie i installed it, at first i connected through wireless, try the update abstractcommand.cc:195 occurs, and firefox only open some websites. so, i try to reinstall it again, second time, installed it again, connect to wireless, update applet went succesful, installed new additional softwares for playing avi’s and streaming, in short the packages, so it went fine, then next morning, the update applet found new repos to update so i let it do its job, then an error occur about downloading the new update repos, then i abort it, read some threads about it but failed to found solution with the particular problem. so, i think there’s something about the installing the os, but the check installation media said md5 said ok, so it means the media installer are fine. so, installed it again and all problems from first installation goes back.

i don’t know what seems to be a problem, the installer, or the server where repos download.

what you think sir caf and sir dean?..

going to the beginning maybe the right thing we should do… :slight_smile: