OpenSuse 11.2 KDE version disappointed me

I am just a novice Linux user. Though I don’t know much of the command-line/system administration techniques, I have tried a lot of distributions in search of a good desktop-oriented distribution. I’ve already used Ubuntu, LinuxMint, Mandriva and Zenwalk besides so many others. I always have a very good impression on OpenSuse. But the KDE version just disappointed me.

  1. After installing, I have opened the KDE network manager and configured my LAN manually. It’s saying it is connected but nothing works, neither the browser nor the update manager. There is an icon in the tray saying that my manually configured network is connected. But no application is able to connect to the internet. Then after so much of searching, I just opened yast and changed the network conf to traditional “ifup” method, configured the interface and then rebooted. Then it is working. This is just a disappointment to any new comer. Why the applications are not able to recognize the KDE network manager configuration, except the “auto eth0” ?
  2. I configured my HP Deskjet 930C printer and gave some print outs. To my surprise, there is no icon in the tray showing the status. How can I cancel the print-que in between ?
  3. This is more a KDE problem than of OpenSuse. The default view of fonts is not at all good. There is no anti-aliasing by default. They are not smooth. Of course we can configure them, but we should we at all ? In GNOME, there is no such problem. The fonts are smooth by default.

I am downloading GNOME version. I will see how it works. I am just not going away from OpenSuse just because of some minor problems. Because I want to give it so much trials that I already gave to other distributions.

I am waiting for any replies, to know if I did something wrong.

You != everyone else. NetworkManager worked right out of the box for me.

Some people prefer non-aliased fonts so it’s up to the user to enable them.

this problem has bitten every openSUSE KDE4 release thus far and has not been fixed. I have read of other distributions having a similar problem with KDE4, although one user on our forum claimed Kubuntu had it sorted, but as is typical for the highly technical and highly linux knoweldgeable ubnutu/kbuntu user, noted they could not advise what network app kubuntu was using, nor advise what the kbuntu config files were. … which is just great (NOT) for all the other Linux distributions knowing the molasses speed in which Ubuntu/Kubuntu pass fixes upstream

I would be very surprised if there is no printer control under the system (or other) menus. Its very easy to add an icon to the desktop.

I note the packman packaged hplip is not out yet for 11.2:
PackMan :: Package details for hplip

I assume you installed the appropriate hplip packages as packaged by SuSE-GmbH ?

IMHO users who have specifc aspects that can be be major pet peeves if they do not work, need to mellow out and wait a few months before installing a new distribution. Not enough volunteers test a distribution, nor write bug reports, and hence often it is only when the MASSES start using a distro that such specific points get picked up and addressed.

fonts … if one wishes to get 24 different opinions from 24 different people, just ask them about fonts.

I’ve had people rant about fonts, show me a screen print of the fonts they love, and I’ve almost rolled over in disgust at what they call good fonts. And they felt the same about what I liked. Its simply too subjective.

But I DO hope you manage to configure to the fonts you like.

Well, any chance your sound is broken also? I’m looking for basic sound problems to help users with (not pulse audio problems, just really really basic problems) and its looking like 11.2 has thrown me out of volunteer work.

Maybe you could mute your PCM, and then post asking for help? I could give you a script to run, point out the PCM being muted, and we would be be happy? … ok … understand … no such luck ! :frowning:

Anyway, if you are doing anything wrong, its not waiting a few months, or not writing bug reports (or not writing openfate suggestions) on features that you want and do not see.

Sounds like you downloaded the livecd. I prefer the DVD. This way I can install all that I want. I can install both GNOME and KDE.

Now for me, my lan was automatically configured and working right out of the box.
I also have an HP printer (psc 2110) and I have the HP icon in my tray.
As to the fonts, again, since I use the DVD, I get the fonts I want, so I don’t have the problem.

I think your problem may be that the live cd doesnt have all the software you need.

Hai ! I appreciate the immediate replies. In future, I will definitely try to help OpenSuse evolution by contributing in the testing of the RC releases and filing any bugs.

I installed GNOME version and found the same problem with the printer icon in the tray. There is no icon in the tray during printing. I am using parallel port printer. Does it has anything to do with it ? More over, the default drivers suggested by the yast also are not working for the printer.

Regarding fonts… may be you are right. It is very subjective.

Sound is working for me well.

I will try to stick to the KDE version and learn something about OpenSuse.

I figured, there is some undue criticism regarding “Ubuntu” here. I don’t know why. But to my observation, every distribution has got it’s own positives and negatives. But due to my respect for community based projects and opensource, I am always ready to face any problems that come across during early days of adaption of any new distribution. I faced some problems during my intial use of Ubuntu also. But slowly I solved them all with the help of community like you.I expect the same thing with OpenSuse.

I looked, but could not find your answer wrt “hplip”. Please, do you have hplip and hplip-hpijs installed? To answer, just post the output of:

rpm -qa '*hplip*'

You can also use zypper to do your search. Zypper/Usage/11.2 - openSUSE

O.K ! I will post the output as you told on Monday. Because it is my office system.

I have installed the hplip-hpijs package. Now my printer is working fine. But still I don’t get any icon in the tray during printing. I have even installed the KDE4-printer-applet package. But nothing is showing up in the tray. How to access the print job directly ?

Now I have installed OpenSuse KDE version both at my home and office. I have removed Ubuntu completely to start my journey through OpnSuse. I can say I am satisfied. I have spent a few hours configuring it according to my preferences. At home, I have installed all the codecs also.

Now, can anybody suggest me some site/forums etc where I can get information on how to configure cakephp on OpenSuse ? How to enable mod-rewrite in apache ? etc …

I have enabled mod-rewrite and started working with mysql also. The OpenSuse documentation helped me. Thank you very much.

Where can I get the latest kplayer for x86_64 architecture for OpenSuse 11.2 ?

after you have installed the appropriate hp printer drivers form yast2 and then set up your printer in yast2 you need to launch the HP print manager manually and set up some options there.

You can set it to always show, show only when printing or never show.

It sounds like you want a sys tray manager so you would want to select “always show”

You can find the HP device manager from Kickoff - it is in Applications > System > Monitor