OpenSuSE 11.2 Intel WiFi Link 5100 not activated

Hi, I just installed OpenSuSE 11.2 on my Dell Inspiron 1545 and strangely the wireless doesnt work (it worked with ubuntu, arch, mandriva and even a development version of 11.2 out of the box).
KNetworkmanager doesnt offer the option to activate wireless as the entry is greyed out.

Some Output:

linux-7jje:/home/jakob # lspci | grep Network
0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
linux-7jje:/home/jakob # iwconfig wlan0
wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=off
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Changed wireless control from networkmanager to ifup in yast, output:

linux-7jje:/home/jakob # ifup wlan0
    wlan0     device: Intel Corporation Wireless WiFi Link 5100
    wlan0     warning: wpa_supplicant already running on interface
RTNETLINK answers: Unknown error 132
Starting DHCP4 client on wlan0. . . .
    wlan0     DHCP4 client NOT running
RTNETLINK answers: Unknown error 132
Cannot enable interface wlan0.
interface wlan0 is not up

Any help?

On my Dell Studio 1537 with an Intel WiFi Link 5300, using the openSUSE-11.2 KDE4 liveCD, I was able to use the wireless by going to YaST > Network Devices > Network Settings and
[1] acknowledge the warning about NetworkManagement controlling the Network
[2] under Global Options Tab select the “Traditional method with ifup”
[3] disable ipv6 (it will ask for a reboot, don’t do that now)
[4] Overview Tab - select my wireless card and select edit. Go for the default settings except as I noted below
[5] while in Edit Select “next”
[6] Under Network Name ESSID select scan network, and then in drop down list select my SSID
[7] Select my authentication mode (in our case it is WPA-PSK)
[8] Enter my passphrase
[9] Select Next
[10] Select OK
[11] You may get a notification from Network Management that it is disabled.

Be certain to check both wireless access to ping your router and also wireless access to the Internet. I had a case with 11.1 (not 11.2) where I could ping my router (and had LAN access) but could not access the Internet. Fortunately lwfinger sorted my problem (I had applied an inappropriate setting to both wired and wireless which caused the ifup hiccup).

Thx for your long answer!

Well… I have to say… it was my fault.

While booting the Live-CD I had to hit F2 to change the language, Fn + F2 didn’t work, so I hit just F2 which disables my WiFi, but it worked to change the language, as this is a Bios-setting after the installation the WiFi was not automatically up again.

So after cleaning up my own mess, WiFi worked out of the box with every encryption as usual with this chipset.

Glad to read its working now. Thankyou for sharing your solution.