OpenSUSE-11.2 installation problems


I gave upon 11.3 M4.Tried installation by text mode but there’s another screen showing various USB devices status superimposing on the Linux text install. Returned to Live installation via Live CD. Installation completed > restart >autoconfig failed. Tried live installation again but Suse kept suggesting installing into one of the empty 2 Gb partitions. Also had problems with Gparted Live 0.5.1-1 CD because somehow the keys froze. Had to replace it with 0.5.2-1.

I am installing 11.2 on a laptop but right now I am stuck with frozen “Creating cache files for fontconfig”. This has taken over an hour and nothing seems to be happening.
I have successfully installed openSUSE 11.2 on an older laptop and a desktop. Also experienced installing Windows 7, Ubuntu and PC-BSD on both types of machines. Never had so much problems like this before!

I am stuck with frozen “Creating cache files for fontconfig”

You may have to force a shut down and reboot.
Then boot to level 3


Did what you just suggested. After booting into run level 3, screen shows text lines then YAST…

“Starting installation…The previous installation has failed. Would you like it to continue? Note: you may have to enter some information again. No? Yes?” I think openSUSE would do an autoconfig of the connected devices if I answer Yes. BUT…

Now my mouse and touchpad are frozen because the throbbing circle just sits there!

I figured that somehow I failed to disable ACPI even before installing openSUSE. Is there a way to do this?

Like you typed 3 also add

acpi=off noapic


Your method works as far as acpi goes, but “3 and acpi=noirq” does not (got this from an old opensuse forums post). Autoconfig at first shows some error about the touchpad but this could be because I was using the mouse at the same time, will try just using the touchpad next time, to see what happens. Then Autoconfig asked if I want to retry “download.opensuse.update” or something like that but connection failed despite several attempts. This could be because the opensuse server in Belgium is down for maintenance at this moment. Here’s what the laptop screen now showing in part:

Starting SSH daemon: done
Starting firewall initiation: done
Master resource control: runlevel 3 has been reached.
Failed services in runlevel 3: network-remotefs
Skipped services in runlevel3: acpid smbfs nfs splash

Welcome to opensuse 11.2…login…password
Have a lot of fun…


Now how do I make acpi=off permanent?

And should I force a reboot then boot into the normal (level 5) kernel?

If you login at the command line
try typing:


To add acpi=off
you need to edit /boot/grub/menu.lst
and add it to the default boot arguments

I’ll give you instruction if you need. Are you kde or gnome?

Hi again,

I am using Gnome for this laptop. Could you give me instruction on how to:

  1. even reach grub menu,before editing it.Right now I still have not reached the normal boot level 5. Hit normal kernel boot but then Gecko just sits there.

  2. add acpi=off to grub menu

At first I thought perhaps the install CD is defect, but this is the same one that I used to successfully install 11.2 on a desktop PC a month ago. I am typing this on this desktop PC and from opensuse 11.2

Thanks a lot for your help.

Have you tried failsafe boot?

Some thoughts

If you can login, then become su, try doing

zypper up

You could try getting in to the system management like this:
Boot to Level 3, then Yast and More… - openSUSE Forums

There is no point editing the menu until you have a working system. You can add arguments manually until then.

Hi oldcpu,

Some good news: I booted into runlevel 3 with acpi=off and noapic, then startx as you suggested. Now I am inside YAST and would you believe it, I am itching to edit /boot/grub/menu.lst. Am looking at the GRUB menu right now. Please show me how to make permanent changes so that ACPI is turned off for good.

thanks a lot for your help and patience.

I’m caf4926 BTW

Yast - System - Bootloader
select the default boot and choose edit
add acpi=off to the Optional Kernel Parameters

Hello cafe4926,

Sorry for mis-calling your ID. It’s been a very long night and I am about to go to bed. I will edit GRUB menu tomorrow. By the way (BTW), the touchpad and mouse on my laptop sometimes freeze in openSUSE and I noticed that the fast scrolling text on screen at first said something about fatal Plugnplay BIOS error. I may have to update BIOS. Is there a way to reduce the scrolling speed so that I can read the error message?

Check in this file:



1)In terms of editting GRUB menu, do you mean “Optional Kernel Commandline Parameters”? If so, I went to the line having “openSUSE11.2…default” then use the right arrow key to go just past “showopts” then " (space)acpi=off". Is this right? Secondly, do I also need to add “noapic” after this as well?

  1. /var/log/boot.omsg gives the following selected results:

PnPBIOS: disabled by ACPI PNP

isapnp: no Plug and Play Device found

Mind you this is yesterday evening when I was still unable to log in at runlevel 5 of the Grub menu (opensuse 11.2)

  1. This morning before sending this reply message I was unable to login at runlevel 5. Had to login at runlevel 3 with acpi=off noapic then STARTX, etc.

IMHO this line of support should be moved OUT of the Pre-Release/Beta area.

Since I think it is 11.2, it does not belong here and as long as it is here it will NOT be given the level of support that it might otherwise get as some advanced users will refuse to look at the Pre-Release/Beta area.

Hi oldcpu,

Sorry about this. Could you move all my posts from #33 onward and caf4926’s replies over to a new thread entitled “openSUSE 11.2 blank screen on installation” or something like that? I don’t know how and I am not a moderator.

Thanks a lot for your help.

I moved the entire 11.2 installation part of the beta thread to a new one (on 11.2 installation).


Still blank screen despite booting into runlevel 3 with acpi=off and noapic.

I am reinstalling 11.3 M4. Mediacheck is OK. See my new post entitled “opensuse 11.3 installed but blank screen at boot”.

At the blank screen
If you try pressing Ctrl+Alt+F2

Do you get a login option?


I got /# /#. If I type sax2 -p I get file not found or command not found. Then /# /# but the screen does not respond after this.

Let me tell you how my install goes.

Using a CD, from a Live desktop session
When install completes, first reboot fails to black screen. I force shutdown and next boot in Failsafe and the post install resumes in basic Yast.
When this completes it should arrive at a login but it seems to stall, so i do CtrlAlt+F2
This gets me console login
I become su

Do normal boot, to a desktop