Opensuse 11.2 Installation Freezes

I am trying to install 11.2 but it keeps freezing. I press install and the Linux kernal loads and afterwards I get a black screen and after 30 seconds the DVD player stops running. I have also tried to the online network install and the exact same thing happens. I also tried a DVD I have of 11.1 which I know is good since I have successfully installed it on other machines and the result is also the same. My computer currently has a dual boot of XP and Kubuntu 9.10. I am returning to Suse after experimenting with Kubuntu but thought I would leave the Kubuntu on the machine (prefer Suse but Kubuntu installed very easily on my computer). Could the Kubuntu be causing this problem or is the difficulty something else? I have also tried the safe install and the other options to no success. I would appreciate any help. Thanks.

Did you try a live CD install?

I have a tri-boot with XP Ubuntu 9.10 and SUSE 11.2, however i had suse installed before ubuntu. I don’t think this would cause a problem though.

It is not your installed systems so its something else
its right after the kernel load?
nothing on ctrl+alt+f1, f3 or f4

Do you have an ATI HD radeon ? If so, this is causing the problem. I wonder if “rdblacklist=radeonhd” as kernel parameter would prevent loading the radeon driver (?) Installing 11.1 would probably work fine. Your Kubuntu is not the cause of the problem.

try press and hold Shift on the keyboard when booting the installation media. This starts the text-mode boot menu instead.

I don’t have an ATI HD radeon. I have tried holding the shift key and it didn’t make any difference. Also I pressed ctrl+alt+f1, f3 or f4 after I got the black screen (I assume this was when I was supposed to press them) and nothing came up. Yes it is right after the kernel load, the screen goes black and the DVD drive runs for about 30 seconds and then also stops.

Did you check the md5 check sum of the iso?? Burned at lowest possible speed? ran varify after the burn?

Try the disk on another machine.


and nothing came up. Yes it is right after the kernel load, the screen goes black and the DVD drive runs for about 30 seconds and then also stops.

perhaps a dirty dvd lens?
can you run a memory test or firmware test?
try cleaning your lens and your disk and try again

Did you try text option here

I doubt it is the DVD lens as otherwise the player is working fine and a couple of weeks ago I installed Kubuntu from DVD with no problem whatsoever (other than that I don’t like it). I did do the memory test but not the firmware test. I didn’t check the md5 check sum of the ISO. However, I did have the same problem with the online download and a 11.1 DVD that I have used successfully to install on other computers. I’ll try the text mode that caf4296 posted and if that doesn’t work, I will try downloading Suse again using a bit torrent which I have read is more accurate (I used Opera this time) and will try burning the DVD at the lowest possible speed. Will let you know what happens. Thanks for all the help.

You can type in kernel arguments like in this image:

Here are some to try:


you can add a combo - actually that is usual Eg:
acpi=off edd=off pci=noacpi

I tried the combo and it also didn’t work. Also the text installation doesn’t go black but gets me to a screen that lists various processes that have been carried out apparently successfully but then doesn’t go any further. I will try downloading it and burning it again before trying the other kernel arguments you have listed.

I tried all the listed kernel arguments with no success. I also tried running the live CD and the same thing happened as during the installation. Burning a new DVD also did not help things. The memory test works but the firmware test goes to the black screen just like the installation. I don’t think it has anything to do with the DVD player because I recently installed Kubuntu successfully and I also have a Debian based distribution that I am able to run off the live CD.

The only thing I can think of that may be causing problems is my current computer has 3 harddrives, 2 that belonged to an older machine that had Suse 11.1 installed. I have deleted those files but did not do so before I installed Kubuntu. The Kubutu Grub still lists Opensuse 11.1 even though I have since deleted it off the harddisc it was on. It was never installed on this machine though. Could this be causing problems?

Could this be causing problems?
I doubt it

If you boot the live cd but put the 3 in the boot line to get it to boot to level 3 of the cd
see the image in post #11

at the login type: root
then hit enter a couple of times

you should now be root in the live cd
now type: /sbin/yast2 live-installer

I think that’s correct

CanadianGrizzly wrote:

> I didn’t check the md5 check sum of the ISO.

STOP! don’t spend another minute on this problem until you know for
absolute sure that your install disk is 100% correct.

the only way to know that is to check the ISO before burning the disk
and then check the disk,

doing it any other way is just playing russian roulette because
Garbage in/Garbage out is still a fact.


The problem is that the Check Media Installation menu item brings me to the black screen just like the installation does. Is there another way to check the md5 check sum of the ISO? I burned the CD’s on CDBurner XP which doesn’t seem to list any sums. Haven’t had any problems burning CDs with this program including my Kubuntu and Debian CDs. Also when I enter the letter 3 in the boot line I get the black screen. I don’t seem to be able to get past the black screen after the kernel load no matter what menu item I choose or what setting I change it goes to black screen. The only times it doesn’t is with the memory test which works and when I do the text installation in which case I get a screen of processes which have been completed that also doesn’t go any further.

Does your kubuntu have k3b it should. use that to check your
11.2 image md5 sum against
295d713314a30ad017948f0d542c6d92 openSUSE-11.2-DVD-i586.iso

or if you are using 64 bit the nr will be different as will the live cd,s

6a09295e34dc030319d040f67f4742c6 openSUSE-11.2-DVD-x86_64.iso

I did everything again in Kubuntu. I downloaded 11.2 again using a bit torrent and burned the DVD using K3B. The check sum was correct but when I ran it I ended up with the same black screen as before. I am getting close to giving up on this and resigning myself to using Kubuntu.

Try booting with option “acpi=force”. On some ATI hardware this does change the “black screen” issue.

Search the forums for ‘ATI black screen’, IIRC there are more boot options you could try.

BTW. I’m no fanatic, nor mentally bound to openSUSE, just to open source, but since I use them both: kUbuntu is by no means what it could and should have been. And it’s not only the looks.

I tried your suggestion but just like the others it didn’t work. The search tip was good and I found a lot of threads but was unable to get any of the solutions to work (and it seems I am not the only one unable to get it to work). I think there is a major bug in 11.2. I might get it to work eventually but there is a limit to how much time and patience I can give to this problem. If anyone else has a suggestion I may try a few more times but if not I guess I will wait for the next release and hope the problem has been solved. Here are a couple of links to threads with people having the same or similar problems to myself:

OpenSuse 11.2 Black Screen - openSUSE Forums

Black Screen - openSUSE Forums