OpenSuSE 11.2 installation doesn't load

I just tried to update my desktop to OpenSuSE 11.2 from the DVD. The same disk worked on my laptop. (11.2 is awesome, by the way! :slight_smile: )

However, when I try to install it on my desktop which had been using 11.1, the installation will not load and remains on a text-less blank screen until I reset the computer. Grub loads from the DVD fine and I ran into no problems when I tried loading the 11.1 installation program a few minutes ago.

My motherboard has an AMD 790 FX chipset. My graphics card is an NVIDIA 8800 GT.

Thanks in advance for your help!

So you don’t even get the boot menu from the 11.2 DVD?

No, I get the boot menu. Sorry I wasn’t clear. When I try to load the actual installation process it reaches 100% on the “Loading Linux kernel…” dialog and then hits the blank, black screen.

So hit F3 and select Text Mode
See if you get any further](

Tried that, and it hangs with a line at the end which reads:
[0.452001] <ffffffff8100d70a>] child_rip+0xa/0x20

Did you run the Media check?

I see you used on your laptop OK.

Try adding these arguments at the boot line
acpi=off edd=off noapic

On my laptop, yes. It says it’s fine. I tried and failed to do so on my desktop as I still get the unfortunate blank screen. If I go to text mode and do the same thing, I get the same message as before:

[0.452001] <ffffffff8100d70a>] child_rip+0xa/0x20

Perhaps it’s something to do with the kernel?

Okay, those boot options worked. I can now see the lovely progress bar! Thanks so much, I really appreciate it! :smiley:

If you know, why would it require me to turn off ACPI,APIC, and EDD when it didn’t in 11.1?

It may be one or all those arguments that worked. it was easier to quote them all and let you run with it than get you try them individually ir in combinations.

Basically google can do the work for you - eg:
Advanced Configuration and Power Interface - Wikipedia, the free encyclopedia

You may or may not need to employ on or all or a combination of those to boot the installed system.

Thanks for the quick reply.

Playing around with it a bit more, I see that I needed to turn off ACPI. Yet, when I run the firmware test(ACPI off, or it won’t load), it reports the ACPI test as having “passed.” Just in case it’s relevant.

Random things happen - We live and learn.
Just hope all goes well for you;)

Indeed we do. Thanks for everything!!

You are most welcome. I’m just happy to have been of some use.:wink: