Opensuse 11.2 Gnome will not load (sometimes) on Lenovo Y550

I just bought a brand new Lenovo Y550 Ideapad with the following specs:

Intel Centrino 2 2.53ghz
4gb DDR
GEFORCE GT 240M 1GB video card

I bought it blank and installed Opensuse 11.2 Gnome 64bit as the main OS (using it right now).

Using the “long method” instructions found on this website, I installed the Nvidia 190.42 graphics driver from the Nvidia website. It is working perfectly.

My OS worked great for a while (love it), but now I am unable to boot up completely into Gnome. The bootscreen goes fine until I get past the automatic login screen for gnome, then the display stays on the default green background. My lights indicate that my computer is working, but no panels or icons load onto the desktop. After about two minutes, a notification pops up saying that I am connected to the wireless network, but there are still no panels or icons on the desktop. My mouse pointer works fine, so I know that the display is not frozen.

I end up having to shut off my computer and restart it. Usually this takes two tries before the Gnome desktop completely loads and I am able to use my computer.

Does anyone have any idea why this might be happening?

I’m relatively new to Linux, so if I need to do anything “fancy”, you’ll probably have to be patient with me and walk me through it :wink:

This is caused by the Automatic Login You need to disable it.
To escape Automatic Logon hang ups or any X/Gnome/KDE hang up press Control-Alt-Backspace keys simultaneously two times quickly.