Opensuse 11.2 Firefox unresponsive to Flash Player Standard

For some reason in with flash websites, which is most of the websites, although the content loads and plays fine, i can’t click on any of the flash buttons or UI, which gets annoying on product websites ( Alienware Computers - Custom-Built Gaming Desktops and Laptops ) or to rewind parts of a youtube video or go HD (like this ) but videos like this

I had some problems with the flash UI also. This is how I managed to fix it:

Edit → Preferences → Applications

Under ‘Content Type’ I changed the Shockwave flash file to “Use shockwave flash (in firefox).” It was originally set to “Use flashplayer (default).”

it was already set to that, and setting it the reversed way still doesn’t make a difference…

Which version of adobe flash is installed on your system?

Flash Player

ok im on to something, i just reinstalled

flashplayer works perfectly fine in everything, but once i downloaded packman gstreamer bad and ugly (for mp4 playback) now flashplayer only works in only a handful of videos/playback.

uh anyone? this is an annoying issue…

ok issue solved by myself, i uninstalled the packman flashplayer, and installed the 64 bit flash player from adobe labs, works fine now.



I installed the latest flash, flash-plugin/ Flash PlugIn and standalone Player, but still no controls as in the you-tube video posted in this thread.

deinstall your falshplayer from adobe and reinstall it with the package pullin-flashplayer. Thats a package which will download the appropriate version of flash.

I had this problem with mouse click not registering in flash windows. Found it particularly annoying not being able to close ads in youtube vids. Heres a bug report with workaround that solved the problem for me

See comment 26

Hope this helps


file: /usr/lib/nspluginwrapper/i386/linux/npviewer

. /usr/lib/nspluginwrapper/noarch/npviewer

That did the trick … flash works correctly now!

openSUSE released new versions of flash player and pullin flashplayer. The online update will solve all problems.

so i deleted flash and flash pullin. reinstalled the puller and now…what next.
reinstalling flahs via yast doesn’t help at all.

no such file!
file: /usr/lib/nspluginwrapper/i386/linux/npviewer

even starting in the term after: export GDK_NATIVE_WINDOWS=true
doesn’t hlep although that helps with eclipse


On my system, the file /usr/lib/nspluginwrapper/i386/linux/npviewer is owned by the package nspluginwrapper-1.2.2-5.6.1.i586. It would be a slightly different location on a 64 bit install. Make sure you have the nspluginwrapper package …

FYI … I also installed the flash plugin from the adobe site:
[root@dolphin]# rpm -qa |grep -i flash

Good luck!

wow a much annoying bug has gone. Thanks.

installed flash-plugin. i only had pullin and player and finally added that line to npviewer.
Works rotfl!

This is what I had to do. I also had to uninstall nspluginwrapper.