opensuse 11.2 fails to load xdm upon startup

All:

I just installed Opensuse 11.2, and have come across the following error upon bootup:
the display manager screen refuses to load, unless I type STARTX at the cli line.

the error messages read:
**failed services in runlevel 5
/etc/init.d/xdm.orig start returned 6
earlyxdm postfix
**
Further, I am unable to activate the xdm service under Yast.

Has anyone else run across this error? Not sure how to resolve.

Thanx for your help!

Robere :slight_smile:

I moved this thread to Install/Boot/Login as it was in the wrong area before. I hope it gets a better response in this forum area.

Hi,
Exactly the same problem here.
Opensuse 11.2 64 bits.
Using an acer 5100, ATI Radeon Xpress 1100.
The system is up to date.
After login at cli, startx works.

Did you use the expert mode in yast system services
Also see the yast system /etc/sysconfig editor, under desktop display manager displaymanager, your’s might had been set to use the console, if it is change it to xdm.

What about /usr/bin/xdm at cli ?

I’m having similar problems (I don’t get a GDM and earlyxdm and xdm fail). I suspect it is related to my swapping graphics cards between an ATI and an nVidia. I’m using an X1950XTX at the moment with the “radeon” drivers (radeonhd seem to crash at any 3D stuff other than Compiz, and fglrx doesn’t support the card/distro combination). Using “sudo gdm” works, but I’ll try xdm and see if it errors.

/usr/bin/xdm does nothing, but /var/log/xdm.errors contains:

xdm error (pid 4270): server /usr/bin/X cannot be executed
xdm error (pid 4268): Server for display :0 terminated unexpectedly: 1
xdm error (pid 4280): server /usr/bin/X cannot be executed
xdm error (pid 4268): Server for display :0 terminated unexpectedly: 1
xdm error (pid 4285): server /usr/bin/X cannot be executed
xdm error (pid 4268): Server for display :0 terminated unexpectedly: 1
xdm error (pid 4299): server /usr/bin/X cannot be executed
xdm error (pid 4268): Display :0 is being disabled

I tried removing my xorg.conf in case xdm didn’t like something that SaX had configured, but that didn’t make a difference. Any other suggestions would be gratefully appreciated, as it’d be one less bug in my current setup :\

I’ve found my problem (and the annoyance of the 10 minute edit period):

ll /usr/bin/X
lrwxrwxrwx 1 root root 14 2009-12-09 19:12 /usr/bin/X -> /var/lib/X11/X

both paths show on red backgrounds - for some reason it points to /var/lib/X11/X, but it doesn’t exist! Now to find the solution…

[edit] Re-installing the XOrg xserver package solved that - not sure if it’ll work for other people as well, and I have even less clue about how my X file ever got linked where it did in the first place! Now to go and try to fix my radeon/radeonhd issues and MTP in Banshee :\

Glad you got your problem solved IBBoard. For future information the ll showed the file in red indicating it is a link. Looking at my system /var/lib/X11/X is a link to /usr/bin/Xorg. This was presumably done so that whatever X server you configure can show up as /usr/bin/X. Your link may have never been set correctly due to an error during config.

Well, more accurately it had a red background because it was a broken link (linked to a non-existent file). Normally they show up a pale blue for me (different to the mid-blue of folders). I still don’t know what caused it to get incorrectly linked, but as I said I just re-installed the package and it put the correct link back.