Opensuse 11.2 does not boot after install

Hi, I just installed opensuse. When I first installed it I had to change the mode to no local apic so that the installer would detect my hard drive. After that I installed onto my sata seagate hard drive, giving the os the full hard drive. After the install the splash screen appears but the bar doesn’t load. It eventually switches to a text screen that says:

doingg fast boot
creating device nodes with udev
trying manual resume from /dev/disk/by-id/ata-st31500341as_9vs01ygq-part1
resume device /dev/disk/by-Id/ata-st31500341as_9vs01ygq-part1 not found (ignoring)
trying manual resume from /dev/disk/by-id/ata-st31500341as_9vs01ygq-part1
resume device /dev/disk/by-Id/ata-st31500341as_9vs01ygq-part1 not found (ignoring)
waiting for device /dev/disk/by-Id/ata-st31500341as_9vs01ygq-part2 to appear: …
Could not find /dev/disk/by-id/ata-st31500341as_9vs01ygq-part2.
Want me to fall back to /dev/sda2? (Y/n)
waiting for device /dev/sda2 to appear: … Not found – exiting to bin/sh
sh: Cabot set terminal process group (-1): inappropriate ioctl for device
sh no job control in this shell

Any help would be really appreciated because I have been trying to get this to work alll day with no success. Thanks

Same here on a pata-drive (multi-os-boot). After upgrading from OS11.1, I get the “waiting for device to appear”-error. If I start Windows 98(!) on sda1, grub is not appear after reboot. After automatic repair system from installation-dvd, grub appears, but I still get the “waiting for device /dev/sda3 to appear: … Not found”-error.

I have been plagued by this problem in Suse 11.1. In my experience it is a problem peculiar to kernel-pae.

I have on occasions managed to solve it by installing kernel-default in place of kernel-pae which the install had chosen. I was only able to do this as the installation dropped into X before rebooting.

However I recognise this is of no help in a situation where the installation does an automatic reboot.

Does anyone know whether it is possible to select a particular kernel to override the installation choice?

Try setting the disk’s access to LBA in the BIOS.

Yes, it is set to LBA in the BIOS.

However I thought this only applied to accesses via the BIOS, whereas the OS accessed the drives directly?

In my case only a re-installation of 11.2 with formating the root with ext4 fixed the problem.

I had this problem in 11.1. I could only get the install disk to see the hard drive by supplying the kernel parameter “insmod=ide-generic”.

Irritatingly this module isn’t passed to the installed kernel (why not??? - a separate issue), resulting in the “waiting for /dev/disk/by-id/…” failure trying to boot the installed system >:(

For anyone else with this problem here’s how I eventually fixed it in 11.1 :slight_smile:

(Important caveat: the following procedure only seems to work if there is only one linux partition (apart from swap). Otherwise the partitions get mounted on the same mount point.)

Here goes:

Choose “Repair Installed System” from the install DVD (with insmod=ide-generic boot parameter).

Use Ctrl+Alt+F2 to switch to command window.

Mount installed system root partition / to /mnt

mount /dev/hdax /mnt

where x is root partition number.

Edit /mnt/etc/sysconfig/kernel to add ide-generic to the start of the modules list on the INITRD_MODULES line.

Execute the following commands (see the RECOVERY section near the end of “man mkinitrd”):

          1. mount --bind /dev /mnt/dev
          2. chroot /mnt
          3. mount /proc
          4. mount /sys
          5. mkinitrd

Then to be absolutely safe, type ‘sync’ (without quotes).

Reboot. Et voila… at least it worked for me.