OpenSuse 11.2 + Creative X-Fi Xtreme Audio

I installed opensuse 11.2 and my pci-e sound card (xtremeaudio) appears as SB1040 at yast-sound but i can’t get any sound. I have read the sound troubleshooting and nothing. I have disabled my on board card.
For cat /proc/asound/modules I get:

0 snd_hda_intel

And for cat /proc/asound/cards I get:

0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xefafc000 irq 16

If I try to remove that card on yast-sound and add X-fi a get:

An error occurred during the installation of


The kernel module error for sound support could not be loaded. This can be caused by incorrect module parameters, including IO or IRQ parameters.

Can someone help me?

Hello! I’m owner of the same sound card, but mine’s designed for PCI slot. This card has no real X-Fi chip inside, so there is no real driver issue (as you’ll see it uses some older one)… just some disappointment might be that you bought ‘fake marketing product’. It has those ‘superb’ effects only in Windows environment [e.g. Crystalizer & 3D surround]. However, the overall sound quality is awesome (plus AmaroK for KDE4 has equalizer already). And now to the point…

Here’s output cut from lspci -vv:

02:07.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
        Subsystem: Creative Labs Soundblaster X-Fi Xtreme Audio
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32 (500ns min, 5000ns max)
        Interrupt: pin A routed to IRQ 18
        Region 0: I/O ports at cc00 [size=32]
        Capabilities: <access denied>
        Kernel driver in use: CA0106

And one more:

math3z@octavia:~> cat /proc/asound/cards
 0 [CA0106         ]: CA0106 - CA0106
                      X-Fi Extreme Audio [SBxxxx] at 0xcc00 irq 18

Conclusion: NO Pulseaudio = NO trouble :slight_smile: PS: Integrated Realtek soundcard on nForce3 chipset is disabled in BIOS as well.[/size]

I have the same card and have been trying to get it to work as well. i have tried all of the older creative labs drivers, and none of them work.

@math3z: what drivers did you use? how did you set it up? through CLI or YAST?

I confess I read the above posts and understood none of them. :frowning:

… one comment reference openSUSE-11.2 and Creative X-Fi Xtreme Audio … the openSUSE tool YaST has not (yet) been modified to configure the Creative X-Fi Xtreme. Hence you must not use it to configure your Creative X-Fi Xtreme Audio.

YaST will (on openSUSE-11.2) create an /etc/modprobe.d/50-sound.conf file, which will likely stop your Creative X-Fi Xtreme from working. … so if you have that file, you should back it up somewhere (NOT in /etc/modprobe.d directory, but somewhere else) and then remove that file in /etc/modprobe.d.

Also the configuration tool “alsaconf” has been depreciated for openSUSE-11.2 and does not work in 11.2 (as alsaconf creates an /etc/modprobe.d/sound file, where that file is NOT used in 11.2). Hence do not use ‘alsaconf’.

Getting Creative X-Fi Xtreme Audio to work should be as simple as removing the /etc/modprobe.d/50-sound.conf file, reboot, and then going to one’s mixer and setting the appropriate mixer settings.

@math3z: what drivers did you use? how did you set it up? through CLI or YAST?

It worked just out-of-the-box bro. Properly detected during initial openSUSE installation…

Oldcpu - I tried your suggestions but still no sound. The sound configuration in Yast has detected the card (but it says “not configured SB1040”). I’ve moved the 50-sound.conf file and also a 50-sound.confYast2save file (probably from when I cofigured the card) and made sure the sound isn’t muted, but no luck. The card works in dual boot XP. Help!

I assume you are using openSUSE-11.2. Is that correct?

Why are you looking in YaST? It does not support Xfi. Each time you go in there it will create a 50-sound.conf file, which defeats the purpose of removing the file. For X-Fi do NOT use YaST. Let me repeat, as I don’t think I made that clear. For X-Fi do NOT use YaST. Also, do NOT use alsaconf as it is depreciated for openSUSE-11.2. You HAVE to rely on alsa automatically configuring your card.

So remove the 50-sound.conf file ! Do NOT leave ANY backups in the /etc/modprobe.d/ directory. If you have a backup, PUT IT SOMEWHERE ELSE. NOT in /etc/modprobe.d/ directory. I hope that is clear.

Reboot. Test.

If no sound, then we need more information as noted in the 2nd half of the multimedia stickie. What we need (and I quote from that stickie):

please post … providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Also, when testing your sound, use a decent sound test. Do NOT use a multimedia app for your test, as you could be introducing codec and other config problems that have NOTHING to do with basic sound. … Please try EACH of the tests recommended in the troubleshooting guide here: (2 speaker-tests and one aplay test): Step-1 - How To Test Your Sound - SDB:AudioTroubleshooting - openSUSE

Good luck !

Yes I’m using 11.2. I did a search so missed seeing the multimedia sticky. Will spend some time getting more info this weekend.

Hello oldcpu. I managed to get the checks done today, as follows.

Location:;a=blob_plain;f=utils/ [following]
–2010-03-17 12:34:34--;a=blob_plain;f=utils/

peter@linux-stqx:~> rpm -qa ‘alsa

peter@linux-stqx:~> rpm -qa ‘pulse

peter@linux-stqx:~> rpm -q libasound2

peter@linux-stqx:~> uname -a
Linux linux-stqx #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 x86_64 x86_64 x86_64 GNU/Linux

Speaker tests as follows - same result as user and as root:

linux-stqx:/home/peter # speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.21

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Device or resource busy
Playback open error: -16,Device or resource busy
Playback open error: -16,Device or resource busy
Playback open error: -16,Device or resource busy

linux-stqx:/home/peter # speaker-test -c2 -l5 -twav

speaker-test 1.0.21

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
0 - Front Left
This test stopped here - wouldn’t go any further.

Contents of modprobe.d:


Did you take the time to check those URLs after posting? None of them work for me.

Please try again:


and select SHARE/UPLOAD and that will give you a URL. Post here the URL.

If for some reason you can not see the URL, then run that with the no-upload option via:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt. Open the file alsa-info.txt with an editor, and copy and paste the contents to a pastebin site such as , press dump on that site, and post here the URL that it provides you.

I need the output of that file.

also, next time you get the error
“Playback open error: -16,Device or resource busy” in a speaker test, try to restart your sound driver with:

su -c 'rcalsasound restart'

and enter root password and run the test again.

Sorry about the URL - it was the only one I could find in the output.
I’ve run the script again as you suggest and dumped the output here:

When I tried the rcalsasound restart, first as user then as root, I got the following:

ALSA lib pcm.c:2211 (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory

A point of clarification, as your reply makes me think you did not understand my very specific suggestion. I had recommended you send:

su -c 'rcalsasound restart'

That means send that command as a regular user. By typing “su” without a user specification, that means to switch users to root. The " -c " means ONLY switch users to the following command in quotes.

There is no need to run that command twice. Just run it once like it was recommended.

But I acknowledge your point that it did not succeed.

I confess I am not all that familiar with an X-Fi. Out of curiousity, if you switch ON the digital PCM (which is clearly OFF) does that make any difference?
Simple mixer control ‘IEC958 Default PCM’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]

What are you using for a test of functional sound?

There are different versions of Creative X-Fi and that diagnostic tells me yours is a CA0110.

I did a search on that on the openSUSE web site and found this:

CA0110 seems buggy for 11.2, yes. It’s also buggy on upstream, too.
Unfortunately, there is no solution yet.

If it’s a X-Fi board with CA0110 (i.e. only HD-audio / Vista mode, no emu20kx
chip), it’s known that it doesn’t work.

Takashi Iwai is an alsa developer. So if he states it unfortunately does not work yet with Linux, then it likely does not work yet with Linux. Any Linux.


Ok many thanks for your help. I guess I’ll just have to await developments.

Actually, the XtremeGamer (the SB0073, which uses the same PCB as the XtremeAudio, but has a real XFi DSP, complete with passive cooling) is supported by openSuSE starting with 11.2 (actually, the support was added during the beta for 11.2 via a kernel update and updates to alsa); in fact, 11.2 picks it up during install/boot. The XtremeAudio (which relies on host CPU cycles) is only supported by 11.2+ (again, patches for alsa and kernel driver updates). I largely came back to openSuSE because of that right-from-the-start (even on live media!) support (the only other live CD that supported the XtremeGamer out of the box at the time was 'buntu 8.10 and later). In fact, though it’s supported by Fedora 12+, RHEL 6 beta still has issues.

That is why I have LONG specified the XtremeGamer (as opposed to the XtremeAudio, even before I moved to x64 bag-and-baggage) as any card functionality that relies heavily on CPU cycles (it’s why I look with askance even on USB wireless adapters) is also the MOST likely to require proprietary/Windows-only (or both) firmware/support.