OpenSUSE 11.2 crash as Xen-domU

I’ve installed OpenSUSE 11.2 x64 on my Intel Core 2 Quad machine with 8GB of RAM. Installation went perfect. After the main installation, I’ve installed the XEN-kernel. Booting into the XEN-kernel goes fine.

But, now I want to install the first domU (paravirtualized). I use the same installation disk but OpenSUSE 11.2 won’t install. It crashes directly. Neither the x64 or the x86 version works.

The strange thing is that I can install OpenSUSE 11.2 as “full virtualized”.

Also, OpenSUSE 11.1 (paravirtualized!) as a domU works perfect!!

Could you ran same vm-install via command line with --debug
option ?
View :-

Sorry, one more question.
Could you try manually install Suse 11.2 PV DomU via local mirror ? Like this :-

  1. Set HTTP server up and running at your Dom0

cd /etc/apache2

vi default-server.conf

DocumentRoot “/srv/www/htdocs”

Configure the DocumentRoot

<Directory “/srv/www/htdocs”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

Restart Apache on OpenSuse 11.2 Dom0 and mount loop suse112.iso as follows :-

mount -o loop suse112.iso /srv/www/htdocs/suse

Then launch browser to http://IP-Dom0/suse and make sure local
mirror has been setup.

  1. Download via wget something like ( i mean real paths might
    differ) :-

wget http://IP-Dom0/suse/boot/x86_64/vmlinuz-xen
wget http://IP-Dom0/suse/boot/x86_64/initrd-xen

  1. Then create profile kind of

#cat suse.install
vif ='bridge=br0]
vfb= ‘type=vnc,vncunused=1’]

xm create suse.install
vncviewer localhost:0
and proceed with install like here:-
Install OpenSuse 11 PV DomU at Xen 3.2 Ubuntu Hardy Dom0 via local HTTP Server (all 64-bit) « Xen Virtualization on Linux and Solaris

Thanks for the tip! What i’ve done now:

  1. Started vm-install from YaST2.
  2. I’ve choosen “Network URL” as installation-source.
  3. I used the URL “”.

Now my installation is running!

Perfect !
Could you try this with different URL:-
Fedora Project

I’ve not much time for today. I will try tomorrow.

I’ve also tried to install a new 11.2 domU without success. The x86 and x86_64 had the same issue. Also no matter if you use DVD (which I used for installation), SuSE Repo, or local HTTP. Also no differenc between YaST and vm-install. I don’t have an HVM posibilty, I only like to install paravirtualized.

Last lines from output of vm-install and console
vm-install -n clone3 -g none -c 2 -m 1024 -v -o opensuse11 -d /xen/clone/images/root.img -s --debug

Afterpressing ENTER, I can’t read the last messages, the console closes and some more error messages appear. But I think they are not valid, because the kernel has been found. (screenshot2.png)

Also copying a running dom0 in an image don’t solve the problem. The boot process stops and there is no chance to do any action. (screenshot3.png)

Thanks for any hint to get this problems solved.

Hi, I see the same problem from a local iso image but the install-from-URL method works to a local installation server.

Sorry, I don’t understand. I told, that I don’t have success with DVD, SuSE repo and local http source, are you able to install with a local http source?

I still cannot get one Suse-11.2 DomU running on a Suse11.1/2-Xen-Host-

vm-install -n suse11.2 -c 4 --nic=mac=00:aa:bb:bb:yx:xx -d file:/data/xen/Ftpe01Root -M 1024 --graphics none -s ftp://<servername>/pub/suse/i386/11.2
(this is the local DVD-Image, but it doesn’t make any difference if I try http://download.opensuse …)

Same thing works fine with the 11.1-image (on 11.1 and 11.2-Host)
So the DVD/Online-Repo of 11.2 seems to causes the problem?!

Can anyone please give me a hint?


3.704596] WARNING: at /usr/src/packages/BUILD/kernel-xen- dmi_matches+0xbc/0xd0()                    
3.704602] dmi check: not initialized yet.                                                                                                                 
3.704606] Modules linked in:                                                                                                                              
3.704609] Pid: 1, comm: swapper Tainted: G        W #1                                                                                  
3.704613] Call Trace:                                                                                                                                     
3.704618]  &lt;ffffffff800119b9&gt;] try_stack_unwind+0x189/0x1b0                                                                                              
3.704624]  &lt;ffffffff8000f466&gt;] dump_trace+0xa6/0x1e0                                                                                                     
3.704629]  &lt;ffffffff800114c4&gt;] show_trace_log_lvl+0x64/0x90                                                                                              
3.704635]  &lt;ffffffff80011513&gt;] show_trace+0x23/0x40                                                                                                      
3.704640]  &lt;ffffffff8046af06&gt;] dump_stack+0x81/0x9e                                                                                                      
3.704645]  &lt;ffffffff8004f4c0&gt;] warn_slowpath_common+0x80/0xd0                                                                                            
3.704651]  &lt;ffffffff8004f59b&gt;] warn_slowpath_fmt+0x4b/0x70                                                                                               
3.704657]  &lt;ffffffff803a578c&gt;] dmi_matches+0xbc/0xd0                                                                                                     
3.704662]  &lt;ffffffff803a5848&gt;] dmi_check_system+0x38/0x90                                                                                                
3.704666]  &lt;ffffffff807b9114&gt;] atkbd_init+0x23/0x4e                                                                                                      
3.704671]  &lt;ffffffff80009076&gt;] do_one_initcall+0x46/0x1f0                                                                                                
3.704676]  &lt;ffffffff80791569&gt;] do_basic_setup+0x63/0x8c                                                                                                  
3.704680]  &lt;ffffffff80791631&gt;] kernel_init+0x9f/0xf9                                                                                                     
3.704685]  &lt;ffffffff8000d38a&gt;] child_rip+0xa/0x20                                                                                                        
3.704688] --- end trace a7919e7f17c0a79b ]---                                                                                                            
3.704902] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0                                                                                        
3.705335] TCP cubic registered                                                                                                                            
3.705397] registered taskstats version 1                                                                                                                  
3.705428] PCI IO multiplexer device installed.                                                                                                            
3.705440]   Magic number: 1:252:3141                                                                                                                      
3.705456] XENBUS: Device with no driver: device/vbd/51712                                                                                                 
3.705459] XENBUS: Device with no driver: device/vif/0                                                                                                     
3.705461] XENBUS: Device with no driver: device/console/0                                                                                                 
3.705466] /usr/src/packages/BUILD/kernel-xen- unable to open rtc device (rtc0)                                
3.705565] Freeing unused kernel memory: 368k freed                                                                                                        
3.705689] Write protecting the kernel read-only data: 7340k                                                                                               

Moving into tmpfs… done.
3.199944] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
3.199953] EDD information not available.
insmod: error inserting ‘/modules/edd.ko’: -1 No such device

>>> openSUSE installation program v3.4.7 (c) 1996-2009 SUSE Linux Products GmbH <<<
Starting udev… 3.275883] udev: starting version 146
3.303314] netfront: Initialising virtual ethernet driver.
3.968518] xen-vbd: registered block device major 202
3.968541] blkfront: xvda: barriers enabled
3.968730] xvda: unknown partition table
3.700368] init[1]: segfault at c0 ip 00007f4c5a960453 sp 00007fff12bb14b0 error 4 in[7f4c5a91e000+151000]

Linuxrc crashed. :-((
Press ENTER to continue.

udevd[143]: bind failed: Address already in use

udevd[143]: error binding control socket, seems udevd is already running

5.855849] init[1]: segfault at c0 ip 00007f90f46b2453 sp 00007fff431b38e0 error 4 in[7f90f4670000+151000]
5.856476] Kernel panic - not syncing: Attempted to kill init!
5.856484] Pid: 1, comm: init Tainted: G        W #1
5.856488] Call Trace:
5.856503]  &lt;ffffffff800119b9&gt;] try_stack_unwind+0x189/0x1b0
5.856512]  &lt;ffffffff8000f466&gt;] dump_trace+0xa6/0x1e0
5.856517]  &lt;ffffffff800114c4&gt;] show_trace_log_lvl+0x64/0x90
5.856523]  &lt;ffffffff80011513&gt;] show_trace+0x23/0x40
5.856530]  &lt;ffffffff8046af06&gt;] dump_stack+0x81/0x9e
5.856535]  &lt;ffffffff8046afa5&gt;] panic+0x82/0x16e
5.856542]  &lt;ffffffff80051bcb&gt;] find_new_reaper+0xfb/0x100
5.856548]  &lt;ffffffff8005324c&gt;] forget_original_parent+0x4c/0x2d0
5.856553]  &lt;ffffffff800534f5&gt;] exit_notify+0x25/0x210
5.856558]  &lt;ffffffff8005498a&gt;] do_exit+0x1ca/0x340
5.856562]  &lt;ffffffff80054b5c&gt;] do_group_exit+0x5c/0x110
5.856569]  &lt;ffffffff80064dba&gt;] get_signal_to_deliver+0x21a/0x4f0
5.856575]  &lt;ffffffff8000c22f&gt;] do_signal+0x7f/0x210
5.856582]  &lt;ffffffff8000c42f&gt;] do_notify_resume+0x6f/0x80
5.856587]  &lt;ffffffff8000ce91&gt;] retint_signal+0x49/0x88
5.856594]  &lt;00007f90f46b2453&gt;] 0x7f90f46b2453

cannot give you a solution, only I can confirm exactly the same beahviour. tried with stock kernel 2.6.31.yyyyy-xen and kotd

No success!

This look a lot like

did reappear?

greets chris

Hi all

Got solved by using latest KOTD



Hi everyone,

I’m installing my VMs on a SLES 10 SP2 64bits Dom0 and I have the same issue here, not only with openSUSE 11.2 DomU (both 32 & 64bits), but also a few month ago with openSUSE 11.x 32bits.

At that time I was able to install only x64 openSUSE versions, but now I can’t install 11.2 x64 neither (although I haven’t checked again with previous versions recently).

seuchato: About the kernel you mention, this is for Dom0 or DomU?

I haven’t attempted to do a network install so I guess this will be my next step (mounting the DVD ISO as loop and sharing the directory via http).

Another ideas?



Well, I just tried a network installation (local ftp server) and I received the same error but this time during the installation process (I think it was at the first reboot), so I’m on the same place as before… :’(

Hi guys,

I’m running into the same issues on my testing server I just installed with openSUSE 11.2 x86-64 with latest patches from yesterday (13.02.2010). But what I noticed is, that if I cange from “No Graphics Support” to “Paravirtualized Graphics Adapter” in vm-install dialog, the linuxrc loads successfully and the installation starts.

Would be nice to see if others could also workaround by

vm-install --graphics para ...]

instead of

vm-install --graphics none ...]

Regards, Torsten