openSUSE 11.2 couldn't setup network on install

Hello all, I’ve just installed openSUSE 11.2, one problem is suse didn’t find an internet connection when suse performed the …“automatic system configuration. This routine attempts to configure your network and Internet access and sets up your hardware”… Where can I manually configure the network. I’m in the network folder now no luck. I’ve been using every documentation I could find Novell Documentation and DVD installation/11.2 - openSUSE
Network Status: Unknown network status

I’m online with a Win Computer.
First time user: Status Confident. :stuck_out_tongue:

Thanks if you look :wink:

Zelong.

I think you need to post what kind of network adapter you are using. In Windows, the device manager will provide an interface make (brand) and model number. Knowing this and the type of connection (wireless or wired) would then be helpful to help setup your network in openSUSE. By the way, openSUSE version 11.3 comes out in just 10 days which will provide even more network adapter support, should you not get this to work under version 11.2.

Thank You,

Hi James thanks for reply. I have a DLink- DSL-504T Modem Router four ports Wired. I have just been connecting main computer with Suse’s connection, it works. Just not with Suse I’ve looked for a firewall in Suse only found an empty foulder. I also started PCLinuxPC Live cd and guess what it can’t access the net either. I turned the router firewall off rebooted still no good. Lan led/lights are on. Given accesse to 10.1.1.3(Suse). Something simple of cource, hmmm just Dunno what.

Suse’s for web server:
Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Realtek PCI GBE Family Controller

Main Computer:
Windows IP Configuration

    Host Name . . . . . . . . . . . . : lastbreth
    Primary Dns Suffix  . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No <---- this a problem????
    WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 00-1F-X0-XX-17-XX
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 10.1.1.2
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Default Gateway . . . . . . . . . : 10.1.1.1
    DHCP Server . . . . . . . . . . . : 10.1.1.1
    DNS Servers . . . . . . . . . . . : 10.1.1.1
    Lease Obtained. . . . . . . . . . : Monday, July 05, 2010 2:55:08 AM
    Lease Expires . . . . . . . . . . : Monday, July 05, 2010 3:55:08 AM

Zelong.

So, if openSUSE does find the PC adapter, you could go in to Yast/Network Devices/Network Settings (Requires root password to start Yast). If you get a warning that the network manager is running, then using the bullet setting on the Global Options tab, change from ‘User Controlled from Network Manager’ to ‘Traditional Method using ifup’. Next, go to the Address Tab and select the bullet for ‘Statically Assigned IP address’ and enter the IP Address. . . : 10.1.1.2, Subnet Mask . . .: 255.0.0.0 and Default Gateway . . .: 10.1.1.1 as you have in Windows.

I must tell you that using the starting address of 10 is most often seen in a business and not at home. Most home IP’s start with 192.168.x.x further, using the mask of 255.0.0.0 is also very unusual as the most common mask at home is 255.255.255.0. With your Mask, you are indicating that the first number designates the subnet, while the remaining three designate the node on the subnet. This setup would have very few subnets and lots of nodes on each one.

So what does all of the really mean? Well when you are trying to do something at home, it may be more common to use a home setup in the odd situation where something is not expecting such a business setup at home. However, if everything is set right, it can and will work.

If my suggestions works, you may wish to change your router setup to something more conventional. Also, as to your other question, setting a PC as a router, is not all that common when used at home.

Thank You,

Hi James thanks your good, Suse found adapter(than I did :slight_smile: )
RTL-8139/8139C/8139C+(Not Connected)
BusID : 0000:02:02.0
Can’t “configure network because kenel device (eth0, wlan0) Not Present…missing firmware -for wlan devices”.

This is my old computer(running Suse) back from my son I didn’t upgrade the earth-net card(in it’s time) because it wasn’t broken, I’ve had my times with firmware upgrades/down. And it’s time I up the firmware on this Old DSL-504T as well.
Than I remembered the importance of MAC address of the adapter.

Thanks for your reply again, I have found ‘User Controlled from Network Manager’ and ‘Yast’ and others :slight_smile: in searching, I could rave on But more important is what you have stated about using 10.1.1.X address and mask 255.0.0.0, the earlier models of the -504T was 192.168.1.X I may off changed it. I’ll up the firmware than make it 192.168.1.X, there’s good reasons that you have pointed out 10.1.1.X is a small internal network.

I’m not sure about “as to your other question, setting a PC as a router” I wouldn’t do that, I have a router. I like All computer power going one way.
I will be back jdmcdaniel3 , I have an excitement of how can I run a Apache server for my website which is a project too and I’ve had ago at red hat many years ago and later suse came out which was a better point and click. So now it must be time to use this OS, I’m waiting to see all power and ram being used rather than held back, not refreshed and page-file being used. This OS may suit me, I use gimp, Notepad++(not sure if there’s at version for suse I’ll find out) firefox, thunderbird and more when I find them.

If your interested in High speed flight I mean Hypersonic=mach 5.5 have a look a my Hypersonic flight my website is built around Lost Moon Tapes Apollo 11.

I thank you for your input.
Zelong.

Zelong I did check out your web sit. It looks pretty cool and it appears you are into things that fly…fast.

As for your network setup, I would consider doing a BIOS update, if a newer one exists. And, as you have seen, a new version of openSUSE (11.3) is due in just 10 days and worth a try. I have used many older laptops/desktops and most often, old is better with Linux, at least for the main stream stuff like Dell or HP.

Please let us know if you want try try more things here. We do have some more tests we can run in the terminal mode that might help determine the network problem.

Thank You,

G’day again yes I do like things going fast, did my website load super fast? it’s html lite graphics and video code.
I’ve also realized this router is so old time for a new one.
Yes the “openSUSE (11.3)” well suits me I have 10 days to work 11.2 out and find out(beta test it) all about it. Get apache web server going and start a forum as well, than Format lol and start a fresh.

Zelong.

To answer your question about how fast the two Web links came up the first time was less than five seconds each. So, yes they came up fast as far as I am concerned. Of course they come up real fast now after I have been to the Web sites more than once. It looks like you put in a lot of work on the subjects and did a very good job.

Thank You,

Well jdmcdaniel3 I fixed the network card problem I bought a new one much easyier the firmware problem I had is common with Linux OS’s it seems seach RTL-8139/8139C/8139C+ and see a lot of Ubuntu.
I’m on the Suse 1.2 computer now downloading packages.

Thanks again for your time I’ll be back in from time to time I’ve got some questions I’ll check out FAQ’s or first time uses first, there common questions.
So I’m feeling my way around all good. :good:

Zelong

Happy to hear of your success Zelong. As for any hardware issue, if it is not a laptop problem, I just replace the hardware with something known to work with Linux. It just saves a lot of frustration, that is for sure. Laptop issues, when they exist, are harder to deal with, as most of the hardware can not be changed out, so you got to make it work.

Please come back by anytime and let us know if you have any other questions or problems and good luck with your cool Web Site.

Thank You,