Opensuse 11.2, broke my sound


I’m new at linux so forgive my newbyness :frowning:

Everything was working fine with default settings, but I ran the “AC’97 audiopack driver” from realtek to see if I would get the equalizer they put in their windows drivers (my 2.1 speakers sound horrid without one)

Long story short, now I have no audio

“An error occured,
The kernel module snd-hda-intel for sound support could not be loaded”

Is there anyway to fix this, so it uses the default 11.2 driver/settings again? :’(

Thanks in advance!

This is probably part of the install script that broke stuff, if that helps.

echo "Remove old sound driver"
if  -d /lib/modules/$KERNEL_VER/kernel/sound ]; then
   rm -rf /lib/modules/$KERNEL_VER/kernel/sound/pci > /dev/null 2>&1
   rm -rf /lib/modules/$KERNEL_VER/kernel/sound/acore > /dev/null 2>&1
   rm -rf /lib/modules/$KERNEL_VER/kernel/sound/driver > /dev/null 2>&1

## remove driver modules
if  -f /etc/rc.d/init.d/alsasound ]; then
   /etc/init.d/alsasound stop
   rmmod snd-page-alloc > /dev/null 2>&1 
   rmmod soundcore > /dev/null 2>&1

I suspect you kept your old alsa apps, and just compiled on top of them.

So what you could do is type:
rpm -qa 'alsa
and that will show what alsa apps you have installed.

For example on my 64-bit openSUSE I get:


Then go to YaST > Software > Software Management and search for alsa. And then beside each of the installed ‘alsa’ apps that you noted from above, select “update”. I think that will force a re-install of those apps and that will hopefully write over the damage you did by trying to install the realtek drivers (that was a bad idea - ask here first next time BEFORE deciding to do such an install). Then reboot and test.

This looks rather ugly. Its making me think you may need to backup your /boot/grub/menu.lst and force a re-install of your kernel on top of the existing one (then restore the /boot/grub/menu.lst before rebooting). … But lets first see what the re-install of the alsa apps does.

Hi, thanks for the quick response, truly not my smartest moment, that’s for sure :slight_smile: Live and learn.

Here’s the rpm -qa output ,


I did a reinstall of these packages, to no avail :frowning:
Perhaps the best idea would be to reinstall completely, or is that too drastic?

Thanks for your time :slight_smile:

There is a version of alsa built into the kernel. It appears your failed effort to install the realtek sound driver removed the alsa modules in the kernel.

I can give you a zypper command to restore those. But first I need to know the output of:
uname -a

Here is the output you wanted :slight_smile:

Linux werkstation #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

Ok, with your PC connected to the Internet, please send the following 3 zypper commands in sequence, from a terminal with root permissions, one at a time (simply copy and paste this into a terminal) and then execute.

zypper ar multimedia
zypper install alsa-driver-kmp-desktop
zypper rr multimedia

then reboot, and test.

If that does not work, then in addition, send the following 3 more zypper commands:

zypper ar multimedia
zypper install alsa alsa-docs alsa-plugins-32bit alsa-utils alsa-oss alsa-oss-32bit alsa-plugins libasound2
zypper rr multimedia

then restart and test your sound. I’m a bit worried the last 3 zypper commands may not install those rpms (it may say already installed when in fact they are not), and you may need to simply download the rpms from that url:

and then install them off your hard drive

The first “alsa-driver-kmp-desktop” did not work, I tried the other commands but you were right, they claimed to be already installed.

Running the rpm’s manually is problematic I’m afraid :expressionless:

[PK_TMP_DIR|dir:///var/tmp/TmpDir.lEq9W3] Repository already exists.

Note you MUST run the “zypper rr multimedia” command !!

Install them manually is easy. You noted your pc was 64-bit.

Go here: Index of /repositories/multimedia:/libs/openSUSE_11.2/x86_64

Then download the files:

  • alsa-oss-1.0.17-27.1.x86_64.rpm
  • alsa-utils-1.0.21-15.1.x86_64.rpm
  • alsa-plugins-1.0.21-19.1.x86_64.rpm
  • alsa-1.0.21-51.1.x86_64.rpm
  • libasound2-1.0.21-51.1.x86_64.rpm

then go to the directory where they are installed and with root permissions type:

rpm -Uvh alsa-utils-1.0.21-15.1.x86_64.rpm alsa-oss-1.0.17-27.1.x86_64.rpm alsa-plugins-1.0.21-19.1.x86_64.rpm alsa-1.0.21-51.1.x86_64.rpm libasound2-1.0.21-51.1.x86_64.rpm       

restart your PC and test the sound

Done, done and done :slight_smile:

I’m able to run the automated configuration of sound now in yast->sound


The “Sound preferences” however is still not listing the hardware, and output is still set to “dummy output”, so no sound yet, but we’re getting there rotfl!

Did you restart ?

Can you run:
**and select SHARE/UPLOAD when asked, and then when it is complete please post here the URL it provides?

I did yes,

Here is the URL you requested:

Hope it makes more sense to you, than it does to me :wink:

OK, I note:

Driver version:     1.0.21-git20091202
Library version:    1.0.14
Utilities version:  1.0.21

Looks like I was too slow in my edit.

You need to look at my edit in the post above, and download and install libasound2. :slight_smile:

It provides the library version. Version 1.0.14 is from the bad drivers you installed.

Here’s the output of running the libasound2 rpm,

rpm -Uvh libasound2-1.0.21-51.1.x86_64\(2\).rpm 
Preparing...                ########################################### [100%]
	package libasound2-1.0.21-51.1.x86_64 is already installed

Yast is showing this version of Libasound2 to be installed, and not the 1.0.14 version that the alsa info is showing.

1.0.21-51.1 (x86_64)

How odd :sarcastic:

Did you reboot after installing libasound2?

If you type:
rpm -qa ‘alsa
does that confirm all the applications, including alsa-driver-kmp-desktop correctly installed?

If so, and if you rebooted, then I’m thinking you may need to force a re-install of kernel-desktop (to restore the apps removed by the driver you tried to install).

In which case, backup /boot/grub/menu.lst.

Then go to yast > software > software management and select kernel-desktop for an install to force a re-install of that kernel.

When it is complete, do NOT reboot, but rather examine its update to /boot/grub/menu.lst and make certain it is the same as the old.

If it is not, then backup the new /boot/grub/menu.lst to some name, and then restore the old /boot/grub/menu.lst.

Then reboot.

Good luck.

rpm -qa *alsa*

rpm -qa alsa-driver-kmp-desktop

rpm -qa libasound2

Newest alsa log thingy:

Did a reinstall of the kernel-desktop, menu.lst wasn’t changed so I rebooted, but alas, no changes :frowning:

Hope this new info helps you a bit, thanks tons for the help so far :slight_smile: Sleepy time for me now.

That suggests that the alsa with the kernel does not come with kernel-desktop, but rather with one of the other kernel apps ? I do not know how this new kernel division with kernel-desktop works. What does:
rpm -qa ‘kernel

Try also removing:
and then re-installing:
then rebooting.

The output,


Removing , and reinstalling did nothing.
I think it’s more borked than we think :slight_smile:

It’s ok though, please don’t waste any more time on this problem, I’ll just reinstall, the install is a few days old so no biggie.
Thanks a lot for all the time you put into this, I’ve learned my lesson ^^:FIM:

Sorry to read that we failed.

But what you noted above, where drivers are specifically removed, is a bit frightening:

IMHO the force of the kernel install should have fixed this. I suspect you simply could not get a force of the kernel module and instead received warnings that the kernel is already installed.