OpenSuse 11.2 + ATI catalyst 10.4 drivers = crash

I am unable to get the ATI drivers to install. It crashes each time with a heap error.

 ATI Technologies Linux Driver Installer/Packager
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 7.4 64-bit

When I try to generate a distrobution package i get the following:

           ┌──────────────── Finished ─────────────────┐
                                                     │ Installation complete!*** glibc detected *** ./ double free or corruption (fasttop): 0x00000000006718f0 ***                        └───────────────────────────────────────────┘
                             ======= Backtrace: =========
                                                                                                                                                 ======= Memory map: ========
            00400000-004bc000 r-xp 00000000 fd:05 5244047                            /home/spoofy/Download/fglrx-install.IrcZ3P/
                                                                                                                                                           005bb000-005c3000 rw-p 000bb000 fd:05 5244047                            /home/spoofy/Download/fglrx-install.IrcZ3P/
                                                                                                                                         005c3000-006a1000 rw-p 00000000 00:00 0                                  [heap]
                                                       7f58fc000000-7f58fc021000 rw-p 00000000 00:00 0
                                                                                                       7f58fc021000-7f5900000000 ---p 00000000 00:00 0
                                                                                                                                                       7f5903aac000-7f5903ac2000 r-xp 00000000 fd:04 867                        /lib64/
                                                                                   7f5903ac2000-7f5903cc1000 ---p 00016000 fd:04 867                        /lib64/
               7f5903cc1000-7f5903cc2000 r--p 00015000 fd:04 867                        /lib64/
                                                                                                            7f5903cc2000-7f5903cc3000 rw-p 00016000 fd:04 867                        /lib64/
                                        7f5903cc3000-7f5903e14000 r-xp 00000000 fd:04 122                        /lib64/
                                                                                                                                      7f5903e14000-7f5904014000 ---p 00151000 fd:04 122                        /lib64/
                                                                   7f5904014000-7f5904018000 r--p 00151000 fd:04 122                        /lib64/
7f5904018000-7f5904019000 rw-p 00155000 fd:04 122                        /lib64/
                                                                                              7f5904019000-7f590401e000 rw-p 00000000 00:00 0
                                                                                                                                              7f590401e000-7f5904072000 r-xp 00000000 fd:04 128                        /lib64/
                                                                           7f5904072000-7f5904271000 ---p 00054000 fd:04 128                        /lib64/
        7f5904271000-7f5904272000 r--p 00053000 fd:04 128                        /lib64/
                                                                                                      7f5904272000-7f5904273000 rw-p 00054000 fd:04 128                        /lib64/
                                   7f5904273000-7f5904275000 r-xp 00000000 fd:04 150                        /lib64/
                                                                                                                                  7f5904275000-7f5904475000 ---p 00002000 fd:04 150                        /lib64/
                                                                7f5904475000-7f5904476000 r--p 00002000 fd:04 150                        /lib64/

7f5904476000-7f5904477000 rw-p 00003000 fd:04 150 /lib64/
7f5904477000-7f5904479000 r-xp 00000000 fd:04 158 /lib64/
7f5904479000-7f5904678000 —p 00002000 fd:04 158 /lib64/

7f590488c000-7f590488d000 r–p 00000000 fd:04 659812 /usr/lib/locale/en_US.utf8/LC_MEASUREMENT
7f590488d000-7f5904894000 r–s 00000000 fd:04 400878 /usr/lib64/gconv/gconv-modules.cache
7f5904894000-7f5904895000 r–p 00000000 fd:04 659715 /usr/lib/locale/en_US.utf8/LC_IDENTIFICATION
7f5904895000-7f5904897000 rw-p 00000000 00:00 0
7f5904897000-7f5904898000 r–p 0001d000 fd:04 665 /lib64/
7f5904898000-7f5904899000 rw-p 0001e000 fd:04 665 /lib64/
7fff15279000-7fff15291000 rw-p 00000000 00:00 0 [stack]
7fff153ff000-7fff15400000 r-xp 00000000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
./ line 41: 30976 Aborted ./${ARCH_DIR}/setup 2> /dev/null
Removing temporary directory: fglrx-install.IrcZ3P

I’ve tried using both the repo and installing from command line with no luck. I have a Radeon 4290 … anyone else run into something like this?

I wasn’t able to get 10.4 to work. Replies too much on new components & libraries, I believe. Try 10.3, it works on my 5770

ATI Catalyst Drivers Downloads

Hope it helps

No I have not seen this. But some general suggestions to confirm you followed all advice properly, note :

  • you must 1st remove ANY fglrx rpm BEFORE you start trying to build the driver
  • if installing from "command line’ you must build the driver from a properly entered run level 3 and not from a shell in run level 5
    *]you should have kernel-source (and possibly kernel-syms and linux-kernel-headers) installed, in addition to gcc and make when trying this. The kernel-syms and kernel-source versions must precisely match the version of your kernel

yeah tried all of those. Just for grins I doubled checked. No fglrx package installed, ran install from console at init 3… I don’t know a good way to validate that all the kernel packages installed are the same though.


rpm -qa '*kernel*'

kernel-source, kernel-syms and your kernel (default or desktop … ) should all have the same identical version. Linux-kernel-headers if installed will likely be slightly different.

fuzzy:/home/spoofy # rpm -qa ‘kernel

I see you do not have kernel-syms. Is it needed ? … In truth, I do not know.

A silly question, but I assume you have rebooted since the last kernel update?

for some reason it wants to install the kernel-xen-devel stuff when I install kernel-syms. I’m not sure why but it did it anyway, rebooted, and tried again with the same error.

My card is a Radeon HD 4290 which is an integrated motherboard/chipset (890gx) .

What is the exact name of the file associated with the catalyst driver you are trying to install ?


OK, and to install it you booted your PC, pressed '3 in the grub splash / boot menu, and then logged in as a regular user at the full screen run level 3? Login that way as opposed to typing “init 3” from X window (the reason being in a very small isolated cases, the drivers do not unload properly when typing ‘init 3’) . Then type ‘su’ to get root permissions, and then type with root permissions.

sh ati*.run --buildpkg SuSE/SUSE112-AMD64

that creates an fglrx rpm. Install that rpm with

rpm -Uvh fgl*.rpm

… I understand you get an error when creating the rpm ? Is that right ?

after a few hours and a bit more frustration i decided to install 11.3 milestone 6. It includes updates to the opensource ATI driver and that works just fine.

Glad to read you are having some success.

11.3 has xorg-1.80 with improvements to X in graphics, it has an updated Mesa (driver), improved radeon driver, and improved graphics hooks in the 2.6.34 kernel. Overall, for ATI graphic users, 11.3 is a better release. Its not perfect (very very very far from it) but it should be significantly better than 11.2.

Hi, just wanted to mention. I experienced almost this exact same bug. Only I wasn’t building rpm package, I was doing the ‘direct’ install method of ati driver, or whatever its called. It would progress to the end, and then crash with the ‘glibc double free or corruption’ error.

latest Cataylst v 10.4. opensuse 11.2 x86_64.

I updated to the newer 31.12 kernel in the update repo, then did an ati build rpm package method of install. That has worked (so far). No errors from the ati build process anyway. :expressionless: