openSUSE 11.2 and midi files

I recently installed openSUSE 11.2 on a computer in place of Ubuntu 9.10.

In Ubuntu, Totem will play a midi file.

How do I make that happen in openSUSE? I don’t know which package I need to install to make that happen.


Multi-media and Restricted Format Installation Guide - openSUSE Forums


I had gone through all the stuff outlined in the web site you suggest. When I try to play a midi file using Totem, I get this message:

The playback of this movie requires a audio/midi decoder plugin which is not installed.

Other thoughts? I’m lost at this point.

Don’t use Totem
Use smplayer, vlc, …blah blah… there are plenty to choose from

When I tried vlc, it said that “… vlc does not support the midi format. Unfortunately, there is no way for you to fix this.”

When I tried MPlayer, it said, “Seek Failed”, whatever that means.

So, I’m kind of stuck.

I suppose there is “something” out there that I could stumble across that will work, but I’m now thinking there is something more serious and basic wrong with my setup that nothing is working on midi files - would you agree?

MIDI players are usually dedicated to that. They are a different technology than binary audio files and require a software synthesizer. Timidity looks like it is capable of doing this:

If you search for midi in
you will see timidity and wildmidi. Both available in gst-plugins-bad, the former since version and the latter since (or so I suppose it means the number).

So you need the package gstreamer-0_10-plugins-bad. But, at least the Packman version, doesn’t provides the plugin… ask Packman to add it: Packman Info Page


I got Timidity to work.