Opensuse 11.2 and dosemu

I have just installed 11.2 and most things are now working but I am having a problem with dosemu. If I start it from a terminal I get “segmentation fault” If I start it as root, it works ok. I assume it is a permissions problem but I cannot find it! Any help gratefully received!

all is NOT well : I have exactly the same prob . . . can only use Dosemu as Root

Plus, a DOS program that I need and which worked perfectly, on OpenSuSE 10.3 & Dosemu - now that essential [to me] DOS application will NOT run, and complains that some “File Missing” [but does not indicate what file is missing]

The Applic. authors cannot find the prob - they conclude there is something wrong in Dosemu for OpenSuSE 11.2

. . . anyone, please, go any poss solution??


I now remember that I had this problem when I went to 11.1 and that I found a solution but I cannot remember what it was!
(A sign of advancing age!)
Setting vm.mmap_min_addr to 0 does not help.


  • I do hope this gets fixed . . . it is troublesome needing to run Dosemu as Rootn - and it seems possible there is now some bug entered dosemu, because an old Dos program that ran faultlessly under openSuSE 10.3 now fails when run as Root under OpenSuSE 11.2

  • living in hope :slight_smile:

Interesting, I just tried dosemu on 11.1 and indeed it segfaults. If you search on the error message “LOWRAM mmap: Invalid argument”, it seems that dosemu fails to work on lots of distros due to the issue explained here: DOSEmu - freedos

The workaround is mentioned there. I wish one didn’t didn’t have to do that because it reduces security. However if that workaround doesn’t work on 11.2, there may be additional barriers, perhaps apparmor.

Good luck.

PS: If desperate perhaps you can run DOS inside a VM.

Additionally deactivating Apparmor with Yast does not help either. What to do next?

However it seems to be the default on Ubuntu (according to cat /proc/sys/vm/mmap_min_addr), where DOSEMU as user works.

It seems that apparmor overrides the vm.mmap_min_addr setting and it is not possible to change it by an apparmor profile for dosemu.
Apparmor must be completely switched off by apparmor=0 boot parameter.


“Apparmor must be completely switched off by apparmor=0 boot parameter.”

Hello mse1 : thank you thank you thank you :

This is very important information

best regards

I confirm: dosemu works in user account after switching off apparmor by specifying kernel boot parameter ‘apparmor=0’ .

Switching off apparmor by ‘chkconfig -d boot.apparmor’, and ‘/etc/init.d/boot.apparmor stop’ do not work. Any prior activation of AppArmor makes dosemu not work properly.

hi can you please help me
how and where do you set the kernel boot parameter

If you use grub boot manager, you can edit /boot/grub/menu.lst. After edited the file, execute ‘grub-install’ as root to reinstall grub.

No need for that. GRUB reads the file at boot. Just adding ‘apparmor=0’ at the boot parameters is enough.

Dear Forum - i have just installed newest OpenSuSE 11.3

Dosemu responds to each and every keyboard stroke with an audio “beep”

. . . otherwise, all is well :slight_smile:

best wishes

You could probably turn off the System Bell at Personal Settings->Accessibilty and uncheck Use System Bell

But I guess this is just a work-around and totally disables the system bell…

Have you tried using dosbox instead?
I found dosemu slow, despite the fact it does some things dosbox can’t.

Can you speed up dosemu, like in freedos?

Have you tried using dosbox instead?

  • no not yet
  • presently trying freeDOS with Sun’s VirtualBox, but i cannot find out how SHARED-folders works . . . the Guest Tools does not install properly??


if dosemu works for you except for the internal speaker beeps, turn it off by:

(enter root password)
echo "blacklist pcspeaker" >> /etc/modprobe.d/50-blacklist.conf
rmmod pcspeaker

The “echo…” line disables the pcspeaker driver at next boot, the next line removes the driver, thus stops the pc’s internal speaker from working.

What do you mean by ´shared folders´?