openSUSE 11.2 amarok 2 volume control

I added the packman repo to my openSUSE 11.2 system, in order to be able to play mp3 on amarok, among other things.
When I updated the system, there was an unresolved dependency concerning libxine. I solved it by choosing the first option that was presented to me at the time, don’t recall what it was…

Now I play mp3 just fine on amarok, but the kmix volume doesn’t affect amarok. If I want to reduce the volume of amarok, I must change it directly on amarok.

Don’t know if amarok is using a different engine do play sound… Any help?



I’m no expert on this but it may have to do with the ‘device’ you/amarok is
using for output being different from the ‘device’ kmix is controlling. In
Amarok under 'Settings–>Configure Amarok–>Playback–>Sound system
configureation–>Configure–>Device Prefrence–>Music there will probably
be several ‘devices’ there. Try different ones in turn to find the one
that kmix is also on. Oh, one other thing, it’s possible that not all of
them will work on your system. You can always switch them back so don’t
worry. :slight_smile:


I have some kinda funny problem here. My volume jumps arbitrarily up and down (sometimes PCM:100%, Master:14%,LFE:100%, while sometimes Master:0%, or , Master:85% i.e usually either high or low volumes overall.) when i change the song in amarok, either by pressing next (multimedia keys) or by double clicking the song in the playlist.

The PCM slider goes to 100% all the time i change the song. It is scary. anyone having the same problem or anyone with any help please!

BTW, I have reinstalled 11.2 twice,(because of KDE 4.3 crash all the times… now it “seems” stable third time)

I also installed pulse audio because I have LFE(subwoofer) in my laptop, and the default sound system without pulseaudio will not work good in my computer.:open_mouth:

I just found out that, it does the same in some other applications.
It did the same while i play videos from my browser- youtube(flash-player), some other videos with mplayer-plugin, they all did the same.

volume goes to PCM=100, Master=somewhere around 10%-20%

You should not have to re-install, even if KDE crashes.

Next time it “crashes” press <CTRL><ALT><F2>. Does that give you a log in terminal? If so, log in as root and type “shutdown -r now” for a clean shut down. Does KDE4.3 work after that?

Could it be your /home has bad settings for KDE3 ?

Did you try saving your proper mixer settings so that the volume levels are not too bad upon application start?

I tried to remove the .kde4 and .kde directories in my home directory from another window manger (FVWM). Actually the plasma-workspace was crashing all the time… it won’t show up in the desktop. Dolphin, firefox and every other applications i open (from the terminal i open through dolphin) worked fine.
But now I think i found the problem. It must have something to do with the facebook plasma applet, which i installed and added after each installation. This time kde is working great except “mute” since i have not added that applet.

As for the volume level, I got rid of pulse audio. (those volume levels changed as i move to next song or any audio stream) I now have alsa with gstreamer backend, and works good but i cannot mute Master and LFE at once. PCM mute wont do anything. it used to do vol=0 for pcm while i was using opensuse11.2 but it was for pulseaudio.

After I remove pulse audio, I have two backends for alsa:
gstreamer: problem cannot mute Master and LFE at once, I have to lower my volume until i get zero volume for PCM if i want to mute my audio.

Xine: OMG, while Master = 0, no sound at all, regardless of PCM, and LFE,
while Master is just one step upper than 0, it does not matter if master=1 or 100, it is 100% loud. It feels like instead of the slider, master has on/off switch :stuck_out_tongue: (but if i use this the mute will work for master and LFE both) if i mute one of them, it will mute all sounds.

What should i do… I am using my buttons to decrease volume until silence if i want to mute these days, I hate it. I want to press a button and no sound, and press it again, restore the volume .

Any ideas, suggestion, advices, or anything.
Thank You.

BTW oldcpu, you must be darn old, you are the one who have answered my questions more than others in these 4 years of using opensuse.
I really appreciate and want to thank you as well as every members of this community for making us easier to switch to linux.
Thank You guys.

Getting rid of pulse has helped many users, but I have never had to resort to that, so my apologies, but I do not have the experience to offer advice with this PC configuration.

I was using pulse audio from opensuse 10.3. From that time onwards the sound was always giving problems, but not serious ones. I had to do rcalsasound restart every now and then, and restart my browser if i want to hear sound from flash player if i had played song in amarok before and so on.

What i have guessed so far is pulseaudio is difficult for KDE users.

Actually I like the plans and future of Pulseaudio, that was why i was using it but, it is sometimes frustating to get choppy sounds, restart applications just to hear sound.

Thank you very much for your concern, I will be using my good ol technique to decrease volume until zero, for now. I hope thay find out the solution soon.:smiley: