openSUSE 11.2: Adobe Flash Player Broken (Somewhat)

Adobe Flash Player is somewhat broken in openSUSE 11.2. OK, it works in YouTube. But, as you may know, the Internets are series of tubes. So there are numerous troubles with other sites if you are using:

  •  **Firefox**
    

3.5.5 - Konqueror
4.3.3 “release 2” (KDE 3 Konqueror does not seem to recognize the plugin at all.) - Arora
0.10.1 - Maybe your favourite browser
? (Chrome?.. )

Here are some examples:

  • BBC NEWS | UK | UK Politics | Brown plans Afghan handover talks (Just try to make Gordon Brown speak!)

  • Starmani internetikiiruse test (Internet Speed Test: pressing button ‘Begin Test’ should (obviously) start the test.)

  • MEGAVIDEO - I’m watching it (Pressing on the red round button should start the player.)

  • SurfTheChannel - 33 (Pressing ‘click to go to host website’ should, well, take you to another website.)

             Workarounds:
    
  • Just use the the Opera
    [sic] browser. *(Firefox miraculously crashed when I was editing this line. It is very frightening… By sheer luck I had a copy of the post in the text buffer. So now I’m typing this in the Kwrite text editor hoping that the Divine Will will allow it to reach the forum.) *However I think it should also be noted that if Gordon Brown starts to speak it is very hard to stop him (unless killall npviewer.bin or refresh tab with the video). I only managed to pause video using pause button once, though I have tried to do it numerous times.

This did not help:

  •  Installing **flash-player**
    

package from openSUSE 11.1 Non-OSS repository (flash-player-10.0.12.36-4.4.i586.rpm) - Uninstalling
mysterious pullin-flash-player package: “This README is the only content of this package. The only use of this package is to trigger update of the real flash-player package.” Okay… - Renaming (moving) ~/.mozilla folder, so Firefox
would start with default profile. - Restarting browsers and hoping that it will just work this time
.

Maybe, you can help?

  • Say, that everything works fine in your openSUSE 11.2 installation, so I can be sure, that my installation is corrupt and my system configuration is all wrong.
  • Say, what works correctly and what does not in your openSUSE 11.2 system (it would be nice if you post also browsers’ versions).
  • Reveal a secret trick (or maybe wild shaman dance with tambourine
    ), which will make everything work again.

Also, a link (with the help of Google):
FF 3.5.4 for SuSe 11.2 Linux does not play flash movies
**
Thank you for your attention!**

I agree, this is an issue for as you post, but only the bbc. I have had it myself on other bbc pages

You have the mega and surf mixed up in description

Thank you, I have corrected it.
How about three other examples?
I though that they are not ‘only bbc’ and they all actually work in one** well-known** operating system.
What do you think?

The only one that doesn’t work is the bbc.

Correction. It’s working now.

I had this before too. Strange…

Most of the time the Main Add Files Button here: ImageBam - Fast, Free Image Hosting and Photo Sharing
Doesn’t work and I have to use Basic Upload
But ATM it’s OK

Hmm, just to make sure: you have tested it on openSUSE 11.2?

As in my Laptop sig - Yes

Thank you for the reply.

I have found this old thread:
Firefox flash plugin (10.0.32.18) broken - openSUSE Forums

And then a link to this bug:
https://bugzilla.novell.com/show_bug.cgi?id=537788

That seems to be the same problem.

I will try workaround listed there and post back.

Yes! The trick works.

Add a line

export GDK_NATIVE_WINDOWS=1

to this file

/usr/lib/nspluginwrapper/i386/linux/npviewer

With this it should look like this:

#!/bin/sh
TARGET_OS=linux
TARGET_ARCH=i386
export GDK_NATIVE_WINDOWS=1
. /usr/lib/nspluginwrapper/noarch/npviewer

Source:
https://bugzilla.novell.com/show_bug.cgi?id=537788#c26

Are you saying you have nspluginwrapper installed? It’s for _64 machines using 32 bit flash

And there is small update. Thanks to Richard for the note! (Though, I have not tested it myself: I edited the file manually.)

Hello Andrey S,

I agree with your comment #32 on the Bugzilla bug, but in the meantime here’s a 1-Click install for 11.2 that will install the patch that Jeff has submitted to be added into 11.2

http://software.opensuse.org/ymp/home:jeff_mahoney:branches:openSUSE:11.2/standard/nspluginwrapper.ymp

Might be a little quicker than typing in my workaround if you have a number of machines to fix this on.

Regards

Richard

Yes, I do have it installed.
Are you sure about 32 bit?

And it fixed almost all problems (except hogging my machine resources). BBC player works just fine now (pause/play work without a hitch).

Hmm, just thought a little bit. Okay, I will try to uninstall it.

Hei,
Just a remark, but I am using the kde4 konqueror and have more or less just installed openSuSE 11.2. I had no problems making Gordon Brown speak, (sounds like I pursue a political agenda:))

Cheers

Thanks for replying!
I have a little bit different results.

I tried different combinations. So I will post results for my system, so your mileage may vary:

  • Firefox with Jeffs’ nspluginwraper = flash works perfectly (all 4 examples).

  • Firefox with default nspluginwrapper = flash works only on youtube (all other free examples from my first post don’t work), but with huge troubles pausing videos.

  • Firefox without any nspluginwrapper = same as previous (bad), the only difference is that videos on youtube can be paused without problems.

  • Opera does not seem to be affected by nspluginwrapper. Everything works with it or without it, though not as good as in firefox with patched nspluginwrapper, some glitches are present(including the one in BBC player). As I understand Opera has its own wrapper called operapluginwrapper
    , which is binary file and cannot be edited as simply as nspluginwrapper.

  • Konqueror works the same with or without nspluginwrapper: youtube works fine, other listed examples do not work correctly.

Verdict:

  1. The best is Firefox with patched nspluginwrapper.
  2. Opera is usable with just flash-player installed.
  3. Konqueror is the worst and is okay for YouTube only.

I think that is it enough for today. Otherwise I may get seriously sick watching that video with Gordon Brown for 20th time.

I am not very familiar with how flash works, and discovered now that I have nspluginwrapper installed, done by the default kde4 preset selection I suppose(?). On this 32 bit machine it was a bit strange selection perhaps? Anyhow, as both of you also have mentioned, flash on linux seems always to be a bit slow and unreliable. I may, for example, not watch youtube videos (though, this machine is a bit old) without having delays (chopping), this is more or less persistent, can’t remember having similar experience on windows. However, the Gordon Brown clip was quite allright allthough I didn’t try fullscreen. The speed test was also fine.

I am from Norway and have had much struggle watching NRK streams(Norwegian broadcasting), something which is also the case when I try watching it with my other and fairly new computer, also running OpenSuSE(11.0). I have never pursued a systemetical approach to solving this issue, but by the feel of it, I think I have had most success with Firefox. But, again, the behaviour seems a bit by random; sometimes it loads, sometimes not at all. Youtube videos is fine on my new computer, whatever browser I use, but if I have to use this one I often pull the video down with Pytube first.

I have the kde4 konqueror installed (as the only browser) in OpenSuSE 11.2 with:
-nspluginwrapper
-kdebase4-nsplugin
-flash player, (installed with the package
pullin-flash-player)

  • I have none ‘swfdec’, ‘gnash’ etc. packages
    installed.

But as opposed to you, I manage to use konqueror to watch Gordon Brown quite nicely.

Not much help in this rather long post, but anyhow a view into some of my experiences on the same topic.

PS, I just tried the Mega video link as well, it played the film-clip very well. Much better, in fact, than most youtube clips does on this computer.

Good luck!

Cheers,
Olav

This fixed the problems I was having with flash (32 bit on 32 bit system) and clicking buttons on video players. Thanks!

A little bit off topic but… something must be wrong with opensuse 11.2…
I had to do the same “export” to make eclipse buttons work… and some other gtk applications needs that to work properly too. I am having same problems with flash player and, can anyone please say how can i use

export GDK_NATIVE_WINDOWS=1
0r export GDK_NATIVE_WINDOWS=true

for all the gtk applications? or any better suggestions? Its not only flash problem, it is related with gtk.

I am using a small eclipse.sh script with those lines to execute eclipse without problems.

Is it ok to use it in .profile file? I am using kde4.3

Did you see this
Opensuse 11.2 Firefox unresponsive to Flash Player Standard - Page 2 - openSUSE Forums

Though how come 32 bit users are need nspluginwrapper I’ll never know!

I don’t know either but it was installed in mine too. I did not do it by myself… I used that export line and is working good. I knew that would work : but adding it in .profile did not work.

So how can i force every gtk applications to use that variable, because i am having the problems with other gtk applications sometimes.

EDIT:

eclipse started working without the script i mentioned before. the export in .profile did a good job. It might be working on other apps too. :slight_smile: