OpenSuSE 11.2, Acer 5739G with Intel Wifi 5100 problem(noob)

Hi there, I just did a dual boot with OpenSuSE 11.2 and Windows 7. They both work perfect but for some reason the wireless (intel wifi 5100 AGN) and my wired network card (Atheros AR8131 Gigabyte controller)do not work in opensuse. Now the problem is that I do not have a clue about linux and therefore I don’t know how to fix the problem. If u guys can help me and give me a guide step by step I’ll apreciate it. By the way I searched the forum and I tried these commands “sudo /sbin/ifdown eth0” and “sudo /sbin/ifup wlan0” and both says something like device not connected/present (can’t remeber exactly). If you need more info please let me know and I will post it. Thanks guys

Have a look here
HCL/Network Adapters (Wireless) - openSUSE

Getting Your Wireless to Work - openSUSE Forums

thx man. i’ll have a look and i’ll let u know what i did.

I have read all that but I can’t make it work. I think I need the kernel and the driver but I have no ideea where to get them or install them. Any sugestions ? Thanks

Open a terminal and post result of

/sbin/lspci -nnk

Hi again, srry for the late post just came from college. I typed in the command and the result is:

00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port [8086:2a41] (rev 07)
Kernel driver in use: pcieport-driver
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
Kernel driver in use: pcieport-driver
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
Kernel driver in use: pcieport-driver
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
Kernel driver in use: pcieport-driver
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G96 [GeForce GT 130M] [10de:0652] (rev a1)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]
05:00.0 Network controller [0280]: Intel Corporation Wireless WiFi Link 5100 [8086:4232]
Subsystem: Intel Corporation Device [8086:1201]
Kernel driver in use: iwlagn
09:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:1063] (rev c0)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]

any possible solutions to my problem ? thx

05:00.0 Network controller [0280]: Intel Corporation Wireless WiFi Link 5100 [8086:4232]
Subsystem: Intel Corporation Device [8086:1201]
Kernel driver in use: iwlagn
09:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:1063] (rev c0)
Subsystem: Acer Incorporated [ALI] Device [1025:021e]

The above are your devices. I use intel wlan with the same driver listed there, but a different device. And I have no info on your 5100 device.

Your eth0 device is not showing a driver, so I suspect you may need to use ndiswrapper. Directions on that here:
Thanks to @swerdna
Madwifi or Ndiswrapper Wireless Network Drivers - Suse/openSUSE 10, 11 - LAN & Internet access

It’s important I understand that you use XP drivers.

You may just have to fiddle with the wlan or again use the ndiswrapper here too, but I’m surprised one of the wireless boffins hasn’t replied here.

i tried the ndiswrapper method and no luck. But i think i know what is the problem, the wireless card is not ON in openSuSe. If i press the wireless button on the laptop it does nothing. I know this because in windows when the wireless is on the button lights up - in openSuse it doesn’t. Thanks for the previous information man. I really want to get this working somehow.

I had this problem as well and solved it using the advice here: [ubuntu] Acer Aspire 5739G no WiFi/WLAN - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1305190). Try disabling ACPI (it worked for me). If that does work but you want ACPI enabled then compile a newer version of the kernel (or wait for an official openSUSE one). This guide How To Compile A Kernel - The SuSE Way | HowtoForge - Linux Howtos and Tutorials walks you through kernel compilation on openSUSE if you’re interested.

Hope that helps

thx very much man. it works perferct now. once i configured it with acpi=off everything went fine. also now I can see my card in normal mode (with acpi on). now the only thing left is to install my video card driver :smiley: (nvidia geforce GT 130m)

That was lucky someone else had your problem

NVIDIA drivers - openSUSE

I have this same problem with a different Acer laptop. Turning off ACPI is absolutely not an option, and I have no ability to connect to kernel.org on the laptop. (The wired ethernet connection suffers from a similar problem.) Is there another way to compile a newer kernel?

man i don’t know what to say. the funny part is that i got the wireless working but now another problem came up.

  1. I have tried the method (for video card) that caf4926 gave me and I failed :frowning: An error came up about the kernel when i tried installing the driver even though i have the kernel installed.
  2. I have installed the nvidia driver another way. Yast -> online update -> i went to search and typed in nvidia -> i installed the driver -> i have restarted opensuse and my screen was all over the place. My screen was split in 6 little images showing the same thing. Similar to 6 small monitors having the exact signal. I think that the monitor doesn’t support the resolution/refresh rate? because i connected an external monitor and it worked perfect.

ohhh btw i have used the old nvidia driver guide “Nvidia/The hard way”

now i have used the 1 click nVidia install (the link that caf4926 posted) and the same 6 small screens appeared. Below i have uploade a picture of the problem.
http://img692.imageshack.us/i/p0102100044.jpg/

http://img692.imageshack.us/i/p0102100044.jpg/

Relax, this looks like part of the desktop effects.

If you press Ctrl+Alt+Backspace quickly twice is should log you out and back in or bring you to the login screen.
Do you still have this now.

If you do still have it, we can solve it. But you must have auto-login disabled. Do you have to type your password at a login screen when you boot up?

To disable it you will need to boot to level 3 yast
Boot to Level 3, then Yast and More… - openSUSE Forums

Then do the equivalent of this
Disable Auto-Login - openSUSE Forums

One you have a login screen you can now select a console login at the login screen
http://public.bay.livefilestore.com/y1pWOjRNJKO70iCfJx-A7l2GvEGBeeHA4lA9xIORo5ygudeqnZT4ZJ8uu14PcBw53G6Pa63Xw3jqX1Ekj_n-J0uZA/console.login.png

Once at the command line and logged in do this:

mv .kde4 .kde4-backup

hit enter
Now just type: startx

man i did exactly what u said but no luck. i believe its the monitor resolution/refresh rate. It is hard too see from the picture (the pic i have posted before) but between the black lines where the image is split there are some kind of pixels, green in colour. It almost looks like artifacts. Is there any way I can change the resolution/refresh rate without loging in ? Even after auto-login disabled it still splits the image imediately after opensuse loads up. ohhh man wait i forgot to type in startx after the other command :frowning: I will do it again tonight

Again, I also had the 6 screens problem and found the answer here:

[ubuntu] Setting Up your new Acer Aspire 5739 - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1343535)

Although I used the NVIDIA utility from their website rather than the drivers available through the repository (which are a bit older).

Hope this helps you.

PS. I haven’t got the microphone to work though, so if you have any luck with that could you let me know? Thanks

add the following to the boot loader settings:

pci=use_crs

and reboot

it works for my acer 5739g