OpenSUSE 11.2 802.3ad NIC bonding?

Long time lurker since SLES10 (last visit 26-Jun-2008). First time on these new funky forums. And seeking help.

I’m attempting to install a new OpenSUSE 11.2 system (64 bit) onto an Intel-based server. I’m having no success in bonding any of my network interfaces into a single 802.ad interface.

I’m fairly certain the problem is not the switch as I’m using the same switch (Foundry FastIron SuperX) on which I have an older SLES10-based system that runs with 4 NIC ports bonded together in this fashion (as well as a number of W2K3 systems using SLA). I set up the older SLES10 box by editing /etc/sysconfig/network/ifcfg-blah files at the command-line as bonding was not supported by YAST in that version.

Now I understood, perhaps incorrectly, that YAST in OpenSUSE 11.2 permits bonding. So I bowed to the inevitable and from the GUI ran Yast->Network Settings and worked through all the tabs. I faithfully set up all the NIC ports to be switched off for bonding use then added a new Bond0 interface to which slave NIC ports are bonded. Default gateway was set to point to my router via the new Bond0 interface. I ensure that the firewall was off and that the relevant interfaces all pointed to the Firewall Disabled zone.

After setting up as required, I rebooted the system and ran a test ping to a few addresses on the network. No joy. I checked the routing table via ip route then netstat -nr and then route all on its own. The routing tables looked as expected each time.

Getting down to first principals I ran *ifconfig *and again everything looked fine. I checked via modprobe -l bonding just in case there was something fundamental missing. Nope.

I assumed that YAST hadn’t worked as advertised and jumped online to grep for more info. Firstly I see that the HOWTO is out of date (Bonded Interfaces With Optional VLAN - openSUSE). I also noted that the bonding module option *mode *no longer supports numbers but upon looking at my ifcfg-bond0 file it contained mode=802.3ad rather than mode=4 so that wasn’t it.

On comparison with SLES10 I did notice that config files of the ifcfg-eth-id: XX-XX-XX-XX-XX type were no longer used in Open SUSE 11.2 with only ifcfg-ethX config files. I examined those and also noted that the _nm_name and *UNIQUE *options were also no longer used. No need for *lspci *(or the Hardware control panel) when setting up bonding?

Example of ifcfg-bond0 file contents (edited for brevity):

STARTMODE=‘auto’
BOOTPROTO=‘static’
BONDING_MASTER=yes
BONDING_SLAVE_1=‘eth0’
BONDING_SLAVE_2=‘eth1’
BONDING_MODULE_OPTS=‘mode=802.3ad miimon=100’
IPADDR=‘194.168.108.209/24’
NETWORK=‘194.168.108.0’
BROADCAST=‘194.168.108.245’
USERCONTROL=‘no’

Example ifcfg-eth0 file:

STARTMODE=‘off’
BOOTPROTO=‘none’
IPADDR=
USERCONTROL=‘no’

I have two network cards in this system - dual gigabit ethernet NICs onboard and a quad gigabit port PCI Intel NIC. I assumed that there was an issue with the quad port card and tried bonding just the two onboard NICs and changing switch configs as required. No joy. I changed network cables, reconfigured ports used on the switch, tried different switch modules, tried multiple variations of 2 ports and 4 ports, rebooted multiple times. No joy. I binned all the YAST-created files, did them from scratch by hand, and then rebooted. No joy.

I checked that the NICs worked individually by setting them to use DHCP and rebooting. Success. Connected individually each NIC port works fine, receives DHCP lease (or works with static IP) and can ping / traceroute / browse out to the world at large. The failure to communicate beyond the network interface only applies when NIC ports are bonded.

At this stage I’m pretty much dead in the water. So my questions are as follows:

(1) Is there an official doc on 11.2 bonding that I may have missed?

(2) Has anyone successfully set up SLA/DLA bonded interfaces in Open SUSE 11.2 either via YAST or via editing ifcfg files and, if so, would you give me a few pointers please?

Any help with this would be appreciated.

70 reads and no responses? How is it that you can take a functional OS and on ‘improvement’ break a feature like port bonding? :confused:

Bottom line is that our studio will ditch SUSE as the fileserver OS of choice. Which, after 3 years, is not something we’ll do lightly but we will be forced to do so.

Ah well, caveat emptor.

You’ll want to read the man page for ifcfg-bonding, then you’ll want to read:

/usr/src/linux/Documentation/networking/bonding.txt

The first thing I see is that you do not start the underlying interfaces - the bonded interface wants the underlying interfaces to be up. On my 11.1 systems I don’t have ifcfg-eth* scripts. On 11.3RC1 I’m using the default scripts for the underlying interfaces.

My ifcfg-bond0:

BONDING_MASTER=yes
BONDING_SLAVE_0=eth0
BONDING_SLAVE_1=eth1
BONDING_MODULE_OPTS=“mode=4 miimon=100 lacp_rate=fast”
STARTMODE=onboot
USERCONTROL=no

My ifcfg-eth0 and ifcfg-eth1 scripts are as follows:

BOOTPROTO=‘static’
BROADCAST=‘’
ETHTOOL_OPTIONS=‘’
IPADDR=‘0.0.0.0/32’
MTU=‘’
NAME=‘NetXtreme BCM5721 Gigabit Ethernet PCI Express’
NETMASK=‘’
NETWORK=‘’
REMOTE_IPADDR=‘’
STARTMODE=‘auto’
USERCONTROL=‘no’

Note that my IP addresses sit on the VLANs above the bonded interface.

axisanimation wrote:

>
> 70 reads and no responses?

Bonding network interfaces is not exactly something everybody does. You
might have gotten better responses on opensuse-general (the mailing
list).

> How is it that you can take a functional OS and on ‘improvement’ break
> a feature like port bonding? :confused:
>
> Bottom line is that our studio will ditch SUSE as the fileserver OS of
> choice. Which, after 3 years, is not something we’ll do lightly but we
> will be forced to do so.

Gee, you give up quickly. Did you even bother with a bugreport?


Per Jessen, Zürich (24.9°C)
http://en.opensuse.org/User:Pjessen

You are ditching SUSE because openSUSE didn’t give you the support?
If you were using sles 10 in a commercial environment, surely you should move to sles11 (paid for with support) andnot expect free opensUSe to supply the answers to your more complicated problms for free?
Either get sles 11 or do some looking around and finding out your own answers on the net or paying someone who knows how to set it up.
As pjessen says, it’s notthesort of thing the normal user does.
Also you were given some pointers on where to look by shalpin.
After all openSUSE is free, self supported software and you sometimes have to help yourself!