opensuse 11.2 (64 bit) hangs during installation

Hello,

I’m installing 11.2 - 64 on an Opteron machine. I did not select the automatic configuration, and have selected all package groups for installation. After the install program copies all packages to the HD, and the computer reboots, I’m able to configure networking (inc proxy setup) successfully. On first try, I accepted the option to test internet connectivity, which was successful; also accepted to perform an online update – that’s where the install hangs. I guess it hangs when it is refreshing the repos.

On second try, even if I opt to do not test internet connectivity, I get the same problem. Any ideas?

Thanks for reading.

Why not try a default install, let it do auto config (only I would uncheck auto login).

When you say

have selected all package groups for installation.
Is that what you mean, install everything? Which would be odd.

Thanks for reading (and replying)!

I’ll give it a try, although I don’t like default installs …

Yep. I got plenty of space, and something I like about suse (as opposed to Ubuntu) is that you get everything but the kitchen sink …

lol!Actually:
Software.openSUSE.org

Just try different options it sounds like you are nearly there.

Good one! lol!

It seems like somebody else is having exactly the same problem, see here:
http://forums.opensuse.org/install-boot-login/426229-post-install-update-fails.html

what i would do is do the install with just one of the main package groups(KDE or GNOME) and not let it do an online update. Once it is installed log in as root and let it do an update through YAST. After the update use the DVD to install the rest of the packages.

thanks for reading. please pardon my ignorance, but how do I force it not to an online update? An I think that doesn’t even make a difference, for the problem still appears even when telling the install program NOT to do an online update; it still connects to the repos and tries to refresh them … that’s when I get the error.

Somebody else reported having exactly the same problem … my install also dies at 48% while trying to refresh this:
… openuse/distribution/11.2/repo/oss/suse/setup/descr/packages.DU.gz

Post-install update fails - openSUSE Forums

oh, sorry i didn’t see where you said it went to refresh the repos. Also, i’m not too good with openSUSE so don’t worry about your ignorance, the only reason i knew this is because i have installed it more that once and different releases.

First, can your system support 64 bit? Second you should be able to install without the repos and just using a DVD on the install screen.

thanks again for reading.

Yes, my cpus are Opterons, so they’re 64 bit.

It’s installing from the DVD, but after configuring networking, it would seem that the installer tries to refresh its repositories’ contents, regardless on whether you want it or not.

No updates are installed during an installation, but the repo’s are set up by the installer which involves their being loaded/refreshed. But it does not require this. I have installed SUSE many times without internet. I guess you could pull the cable and try.
The DVD - Have you run the media check?

Both are very good ideas – thank you. I might have downloaded a defective image; don’t think there’s a problem with the media, though, since the same iso was burnt to 2 different DVDs, and had the same problem.

However, it does seem odd that a totally unrelated person had exactly the same problem, as per one of my previous posts.

Does the install program need to connect through the network in order to do this?

If there is no net connection it will just setup the repo’s and skip anything else requiring a connection.

I’m having the exact same on the exact percentage is there a safe way to exit the update seems to be frozen, nothing else responds.

Friend, you really need to give us a bit of a run down on what you are doing, what happens, what you have tried…etc//

rrpalma wrote:
> Somebody else reported having exactly the same problem … my install
> also dies at 48% while trying to refresh this:

sounds like one of you needs to log or comment on an existing bug, see
http://en.opensuse.org/Submitting_Bug_Reports


palladium

Hello there!
I just had exactly the same problem, also with openSUSE 11.2 - 64 bit.

Obviously the installer does not reach the servers he wants for updating the repositories.

I could reach the repsitories though, when browsing to them manually on a different machine via internet browser.

Some background info about my setup:

I am running a server as a gateway, which works as “unified thread management”-server (Endian Firewall - Community Version).

This machine runs as incoming and outgoing firewall.
I analyzed the traffic of the openSUSE installer and found out that it initiates some http-traffic on port TCP/3080 (strange!?). So I opened this port in the outgoing firewall. But nothing went better. So I shut down the whole outgoing firewall (which practically opens all outgoing TCP/UDP ports whatsoever), but again with no successful result.

The final solution was:

In addition to being a firewall, Endian functions in my setup as a HTTP-proxy, running in “transparent” mode. So I entered the IP of the linuxbox into his “Bypass Transparent Proxy”-list and instantly the openSUSE installer worked like a charm: he updated all repositories and performed the online update afterwards with no problems.

I do not know if it was only the http-proxy, or a combination with the settings I had previously changed in the outgoing firewall, I am going to find this out in detail later on. But changing all the things helped definitely.

As a conclusion you can say, that it obviously has something to do with our linuxboxes not being able to talk to the openSUSE-update-servers, so check your network settings in this context.

Hope that helped, please give some feedback!

Cheers,
tomakos

P.S. I am adding some keywords so that others can find this easier:
The error message I encountered had the following elements:
ERROR
Download failed
Failed to download
repodata
[AbstractCommand.cc:195]
AbstractCommand.cc:195