Opensuse 11.1- XEN imposible to create new VM

I want to create a new VM but when I select the virtual disk I cannot select a physical disk link as
source “phy:/dev/cciss/c0d5”
protocol “phy”
size (GB) “xxx”
if receive an error message “The installation source is using an unsupported protocol.” and in the detail
“ftp://, http://, nfs://, smb=//, dev:/”

The dvd is also refused but strange when I change the device the size is correctly refreshed.

Protocol dev cannot by selected >:(
But if try to create a VM from a disk with an installed OS then protocol "Phy is accepted and the VM is created
Only when I want to install a VM is the protocol “phy” refused :sarcastic:

Any Idea?

Can u post your full vm config file and are using yast2 to create the file?


I use yast to create the VM.
I created a VM from the previous opensuse 11.0 xen installation. The VM was installed on a physical disk and contains an opensuse 11.0 version.
Now I installed the opensuse 11.1 xen and

a) I can create a VM from a physical disk where is installed the opensuse 11.0 VM

b)I cannot create a new VM where i want to install the os on another physical disk

the config file for the “Old” VM is as follow ( created in a)

extra=" "
disk= ‘phy:/dev/cciss/c0d5,xvda,w’, ‘phy:/dev/sr0,xvdb:cdrom,r’, ]
vif= ‘mac=00:16:3e:04:d8:7a,bridge=br0’, ]


Hi phil524.

I had the same problem:
Installing a new Xen-Domain will not work with error message, you wrote.

I solved it with a workaround, explainded by the installation from
openSUSE-11.1 in itself as a hvm-DomU:

  1. I change the “Virtualization Method” from para to full.
    Here I got the error message.
    I see, that the point at the bottom “Operating System Installation”
    has the installation source “cd:/”.

  2. This is my problem: I have no valid installation source, cd is
    not configured yet, so i use the network temporarily, changing the
    installation source to

  3. Configuring the System will now work for me, I gave a disk
    (using a logical volume throug LVM) and a CD-ROM as an ISO-Image and
    … (tata :wink:

  4. Finally I change the installation source back to my virtual cd-rom,
    provided by the iso-image of openSuse11.1.

Now the installation will start

The only problem I got was, that the Virtual-Machine-Manager will
not work and that in the HVM-DomU the Xen-openSUSE-11.1 will not
start, which was different to 11.0, where this cenario works stable…

Greetings from Klaus

I think, this is a bug in yast, so I hope, the people from SUSE will
fix this :wink:

Thanks, it works :slight_smile:
It take some time before it understood all your stuff but now it is installed.
Seems that yast controls some things that are not yet configured
Hope this 'll be improved.

Thanks, KlausHeinisch-san and phil524-san.
I had a same problem with that error message. I resolved by the method is change from “para” virtualize to “full” virtualize. I’m helped your comments.


I’ve been trying to install openSUSE 11.1 as a guest on a SLES10SP2 host, also tried following the guidelines from KlausHeinisch, but with no success. :frowning:

I choose full virtualization, add an LVM disk to install to and the openSUSE-DVD iso to install from. VM is created, CD boots and in the console I get a flash picture showing a CD plate with the openSUSE logo on it. Nothing more happens. No prompt, nothing to click, no text at all.

Could anyone help me out, or perhaps provide an /etc/xen/vm/opensuse11_1.cfg example file that I could use for xm create?


Switching from Para to Full is only possible if your processor supports it. It was working fine in 11.0. I have a system which will only do Para. Hence, it definitely requires a fix.

In the meanwhile I think I will use convirt.

Select SUSE Linux Enterprise Server 11 as the Operating System and point to OpenSuSE 11.1 DVD.

It worked for me. It looks like a bug in the vm-install and shows up when selecting OpenSuSE 11 as the Operating System