OpenSuSE 11.1 Xen - can't install domU

I’m trying to install Xen using OpenSuSE 11.1 on an Intel server (dual 2.66 GHz Xeon, 32-bit, 8 GB RAM). I can install a dom0 (using DVD install) [used “minimal X”, added xen]. I boot using the xen kernel, and performed all Online Updates (and necessary reboots).

I want to create a domU, so I use yast2 (GUI version) to Create one. I use an ISO image of the install DVD (the same DVD I used to install the dom0) as the install source. I use the default options for hard drive, RAM, CPU, etc. Yast2 brings up the TightVNC terminal and boots into the graphical install. I choose default options (nothing varying). The install progresses as it should.

When it gets to the point where it needs to reboot, I get the countdown (10 seconds), then, for a very brief moment, I get this screen:

Then the TightVNC window disappears, and the domU shows in the running processes in a running state. All attempts to boot this vm (even after rebooting the dom0) fail. I’ve tried several different combinations to install a domU. Nothing works.

Finally, a friend of mine used one of his OpenSuSE 11.1 servers (again, fully updated). Not only did he successfully create a domU, but he gave me his created image. I brought it to my server, and it booted just fine.

Something’s wrong with the install process. Does anyone have ANY ideas? What do these errors mean?

“error: cannot open Packages index using db3 - No such file or directory”
“Cannot open kernel image ‘/boot/vmlinuz’”

Thanks for any help!

  • Jon

same here.

Running a SUSE 11.1 Host, Dom0 installed properly.

Installing a DomU instance runs fine until the installer wants to restart, then the system hangs and can’t be shut down. After a hard reboot, there are several image files, one under /var/lib/xen/images, one under /etc/xen/images - but the VM shows shutof, errormessage says it does not find the kernel image of the vm

strange thing


I, also, am unable to shutdown the server after the tightvnc display disappears. In my first post, I said that the running domU shows to be in a “running” state. I meant “zombie” state.

I noticed that my BIOS and firmware were out of date. I updated them, hoping this would solve the problem. It didn’t. I did a fresh install (reformat & reinstall) after the BIOS update. Same issue.

When installing the domU, I had been using an ISO file (downloaded) as the install source. I’ve also tried an NFS install. Same result.

Does anyone have any thoughts? If a Xen image created elsewhere can run fine, wouldn’t this be a problem with YaST or the SuSE install process?