openSUSE 11.1 x64 Upgrade hangs on booting

I upgraded from 11.0 on my Compaq dv6505es laptop (athlon 64 x2, nvidia 730, broadcomm 4311…) and everything worked fine as before on first boot, except hi res monitor. I installed propietary driver 177.82 from nvidia repository and configured high resolution and 3D acceleration. But when system is booting it stops at grub stage 2. Pressing Esc several times makes it continue. Stop, Esc a few times and booting completes perfectly.
Although, booting in failsafe mode works fine.
I tried putting in the kernel section of grub parameters taken from failsafe mode (one by one as suggested in this forum by mingus, thanks) but it doesn’t work.

Any suggestion?

Add a 3 to the boot prompt, to come up in non-graphics mode.
Use the FOSS driver ‘nv’ and see if your system works properly.

Then try 3D drivers later when Nvidia have rpm’s for 11.1 kernel.

Proprietary drivers suck, please consider manufacturers with more open policy on documentation and FOSS support, when you purchase upgrades in future.

Thanks for your suggestion, robopensuse, but it doesn’t work.
It seems not related to video driver. I removed proprietary driver and it still hangs, even booting to text mode (runlevel 3). I mentioned the driver installation because it is the only thing I made after installing 11.1.
Last message before first hanging is “Synaptics Touchpad …” and first message after Esc, Esc, Esc is “SATA link up 1.5 Gbps …ata3.00:…”
Maybe a problem with hard drive configuration?

I have resolved the problem! I’ve done a “repair” from 11.1 DVD and it found an error in grub boot loader.
Now, everything runs ok and I’m going to enjoy it…
Thanks for your interest (mingus and robopensuse)