openSuse 11.1 won't save sound settings

Every time I reboot I have to reset the audio card and run alsaconf. These settings are never saved. How can I get Suse to save these settings?

There are two possible issues here, and it is not clear to me what is applicable to your PC:

  • having to run alsa conf
  • having to reset mixer settings

Is it essential that you have to run alsaconf? Is this because you have no sound unless you run alsaconf? If so, this could be because during boot while your sound modules are being loaded, some other process is interfering with the load. Or it could be during boot, after the sound module was loaded, the loading of some other malbehaved process (such as an ndiswrapper) disrupted the loaded alsa module.

If you have no sound after a reboot, instead of running alsaconf, what happens if instead you run: su -c ‘rcalsasound restart’ and enter root password when prompted for a password.

if that works, then simply add to your PC’s /etc/init.d/boot.local file (as a last line):
rcalsasound restart

To edit the /etc/init.d/boot.local file, in:

  • gnome type: gnomesu ‘gedit /etc/init.d/boot.local’

]kde type: ** kdesu ‘kwrite /etc/init.d/boot.local’*
and type root password when prompted for a password, and then edit and save the file. Reboot and test.

#! /bin/sh

Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.

Author: Werner Fink <werner@suse.de>, 1996

Burchard Steinbild, 1996

/etc/init.d/boot.local

script with local commands to be executed from init on system startup

Here you should add things, that should happen directly after booting

before we’re going to the first run level.

rcalsasound restart

Thanks for the reply and advice but it didn’t work. “su -c ‘rcalsasound restart’” did though.

It worked this time, go figure. Thanks again in advance.

It’s back to not working again. I sure wish I could find the answer to this problem.

Do you get any sound at all ?

There was a kernel update today, and typically kernel updates have a reputation for breaking the sound on many user’s PCs.

I updated the kernel. I get the Suse boot up music(?). I have to run the alsa start command and then I have sound. I put what you suggested in the file and it’s there but doesn’t start alsa. I had another fellow tell me he never uses kmix for sound. Is alsa the only sound structure that suse has?
#! /bin/sh

Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.

Author: Werner Fink <werner@suse.de>, 1996

Burchard Steinbild, 1996

/etc/init.d/boot.local

script with local commands to be executed from init on system startup

Here you should add things, that should happen directly after booting

before we’re going to the first run level.

rcalsasound restart

The " # " means ignore the following text in this line because it is a comment !!

Try removing the " # " in front of the “rcalsasound restart”. :slight_smile:

Are you using gnome or kde? Typically for kde one uses kmix (it works well for me). Typically for gnome one uses alsamixer.

See if reading this sound concepts wiki helps answer some of your theory questions: Sound-concepts - openSUSE

raysr11 adjusted his/her AFDB on Thursday 23 Jul 2009 21:16 to write:

>
> I updated the kernel. I get the Suse boot up music(?). I have to run
> the alsa start command and then I have sound. I put what you suggested
> in the file and it’s there but doesn’t start alsa. I had another fellow
> tell me he never uses kmix for sound. Is alsa the only sound structure
> that suse has?
> #! /bin/sh
> #
> # Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights
> reserved.
> #
> # Author: Werner Fink <werner@suse.de>, 1996
> # Burchard Steinbild, 1996
> #
> # /etc/init.d/boot.local
> #
> # script with local commands to be executed from init on system
> startup
> #
> # Here you should add things, that should happen directly after
> booting
> # before we’re going to the first run level.
> # rcalsasound restart
>
>

Try removing the # from the last line in front of the rcalsasound restart

The # just comments out the line so it is not being run.

HTH


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

#! /bin/sh

Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.

Author: Werner Fink <werner@suse.de>, 1996

Burchard Steinbild, 1996

/etc/init.d/boot.local

script with local commands to be executed from init on system startup

Here you should add things, that should happen directly after booting

before we’re going to the first run level.

rcalsasound restart

Still doesn’t work.

I am also experiencing the same problem: sound settings are not saved.

Description:
Every time I open Sound card options from YaST/YaST2, all specific values (ac97_clock, ac97_quirk, buggy_irq, buggy_semaphore) are blank (no values in them).
Reseting and saving the values will only last until I reboot or restart Yast-> Sound.

What might be the file in which these settings are supposed to be saved?

Sound card (integrated) recognized as: nForce2 AC97 Audio Controller (MCP)

System installed more then 6 months ago.
Had to install latest alsa and oss for it to work.(otherwise only 1 application could use sound)

The reason for it stopping to work is a mystery.
(On the fated day, I did not start yast, did not change sound settings, did not install anything, etc… DID run several applications using sound at the same time with amarok: gmplayer, Smplayer, Kaffeine. They worked properly until I rebooted…)