openSUSE 11.1 won't boot into Gnome

As the title says, once I’ve restarted my PC everything is normal until I have to choose whether I want openSUSE 11.1 or to boot into failsafe. I noticed that it would say something like VGA at the bottom of that screen. Once I’d chosen to openSUSE 11.1 I’d see screen messages (nothing new there I guess) then I would see that Gnome had failed to launch. I tried booting into failsafe and that gave me the same problem. It worked perfectly for about twenty-four hours, then I restarted the PC and that’s when it happened.

I’ve gone back to Ubuntu for now but would really like to get openSUSE 11.1 working again as I think it’s far better.

Any help would be very much appreciated.

Maybe you could tell us about your graphics card as this is likely the issue

My system specs are:

1GB RAM, 2.8GHZ Intel Celeron (D) processor, 80GB HDD, nVidia GeForce 6200.

Lets switch to vesa and then get your nvidia driver installed

At boot, where you said you could see the ref to VGA. Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA.
Remove all text and now type just the nimber:
3
and hit enter

at the login type your user name and then password
now type:
su
then the root password

now type this:

sax2 -r -m 0=vesa

(N.B. the 0 is a zero not a letter)

now reboot
if you don’t get a gui login
login as user and try this at the cli

startx

Do you have the nvidia repo added. If not get it and add the driver via yast.
Or try the one-click
Read more here

Geoff

I’ve reinstalled openSUSE 11.1 now and I have followed the instructions set out by caf4926 and it went to a totally white screen, so what I did then was to install ubuntu, format the drive and reinstall openSUSE 11.1. Now the pc has been restarted 3 or 4 times and it works perfectly. I’ll just remind myself that if it kicks into CLI again I’ll just type startx.

Thanks to everyone who replied, much appreciated.