OpenSUSE 11.1: WLAN USB Ralink RT73


yesterday I’ve change my system to OpenSUSE 11.1. It’s my first step.

Everything seems to run well but only Internet don’t work, >:(
I want to use internet with D-Link DWL-G122 (Ralink RT73 Revision C1), WPA2 & the AVM Fritzbox.
The Hardware-Compatibility-List told me that this WLAN-stick works with OpenSUSE 11.1: HKL/Netzwerkkarten (WLAN) - openSUSE

I have copied file rt73.bin to /lib/firmware successfully.

Now I want to configure the stick with YaST, but YaST tells me that I have to install a firmware before I can configurate the WLAN-stick.

I’m new @Linux & don’t know what to to now… :shame:

Please help me, if you can…

Enter the command ‘dmesg | grep firmware’ to see if the firmware is correct.

thx for your fast answer, firmware is installed! Anyway I found my sulution what my problem is: I have removed another PCI-WLANcard (I didn’t use or have configured this card) and now everything works fine. THX! rotfl!

Well done for getting it working!
For people who are even newer to Linux, if such a thing is possible, could somebody please walk me through that first step?

I’m using the same kit only it’s version B1.

What is really frustrating is that it appeared to work the first time I plugged it in, at least there was a selection of networks to choose from, but since I hadn’t plugged in my own wireless router, I unplugged the key. Now I scan for networks and get nothing. I know the router is OK since my room mate is connected OK.

If anyone can offer some clear advice it would be much appreciated.


You need to open a terminal (Konsole, Terminal, xterm… names vary), type the line as seen, hit return.

Don’t know how to fix the problem though…

I typed

dmesg | grep firmware

In Konsole and didn’t get a whole lot of information back.
I’m currently at work and will post the result this evening, but it was literally one line of text…

So something is not right there. When checking to see if the firmware is installed:
What am I looking for?
If it is absent, from where do I obtain it?

Anyone got any ideas on why/how I could scan networks correctly the 1st time I put the key in? I had a similar issue with a previous Debian install where recognition of this same USB stick, and the ability to scan networks, was intermittent.

What are people’s recommendations for the best [lowest-hassle, plug-and-play (if poss.)] USB WiFi device? It may be the simplest thing to go out and purchase a new one that is better supported.


In fact, I get this:

intel_rng: don't want to disable this in firmware setup, and if

Something wrong.


Hmmm. Maybe try “dmesg | grep rt73” or “dmesg | grep ralink” or some such. Note that it is case sensitive, so you may have to play with that (obviously I can’t test, cos I don’t have one…)

Another option is to just plug the thing in once the system’s on, give it ten seconds to think about it, then just type “dmesg”. That dumps the whole kernel messages, but cos you’ve just plugged the thing in, the interesting bit should be right at the end.

As to where you’d get the driver, don’t know. The Ralink page is being characteristically useless (I’ve had this fun myself, for a different chipset).

This looks like it might help, if it has the right firmware…

In fact, ignore that link - have you installed the ralink package in YaST software management? That would be the first thing, as it certainly does appear to contain the right firmware…

I realise that I should have looked here


Because according to the list:

(does not work on SMP kernels!) hardware version B1 (not C1)
and I have the B1. So I suppose that trying to get this to work is not an option.

I guess the sensible plan is to go out and buy any USB with a green tick under 11.1?

ZyXel G-220 looks good.

Anyone confirm a good PnP experience of this?


Do you have an SMP kernel? ‘uname -a’ should tell you.

Hmm. I’d just install the ralink package in YaST and see what happens. It might frazzle your hardware, but judging by the absence of google hits that chipset brings up saying “Don’t try to run this on Linux!” I’d say you’re about as likely to get killed unplugging it and putting a new one in… :wink:

It might not work. But it might… no harm trying.

I think I have an SMP kernel since ‘uname -a’ yields:

Linux linux-jyxq #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux

None of the commands besides ‘dmesg’ (on its own) work, so as suggested I tried that. I think the part required is as follows:

usb 5-3: new high speed USB device using ehci_hcd and address 3                                            
usb 5-3: configuration #1 chosen from 1 choice                                                             
usb 5-3: New USB device found, idVendor=2001, idProduct=3c00                                               
usb 5-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0                                          
usb 5-3: Product: 802.11g WLAN Adapter                                                                     
usb 5-3: Manufacturer: ANI                                                                                 
phy0: Selected rate control algorithm 'pid'                                                                
Registered led device: rt2500usb-phy0::radio                                                               
usbcore: registered new interface driver rt2500usb                                                         
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=225 TOS=0x18 PREC=0x00 TTL=255 ID=10254 PROTO=UDP SPT=5353 DPT=5353 LEN=205                    
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=46896 OPT (94040000) PROTO=2
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=252 TOS=0x18 PREC=0x00 TTL=255 ID=8009 PROTO=UDP SPT=5353 DPT=5353 LEN=232
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=181 TOS=0x18 PREC=0x00 TTL=255 ID=56585 PROTO=UDP SPT=5353 DPT=5353 LEN=161
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=115 TOS=0x18 PREC=0x00 TTL=255 ID=50981 PROTO=UDP SPT=5353 DPT=5353 LEN=95
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:1b:63:cd:c8:eb:08:00 SRC= DST= LEN=115 TOS=0x18 PREC=0x00 TTL=255 ID=45882 PROTO=UDP SPT=5353 DPT=5353 LEN=95

Is that the relevant bit?

Any suggestions before I hit the shops (or my computer!)


Looking at the HCL, I think you’re looking at the wrong chipset.

The one for the rt73 seems to suggest it does work with the firmware.

I’d honestly suggest going for it - I can’t see it doing any harm.

First step, open YaST (how you do that depends on your desktop environment - but it’ll be in a menu under ‘administrator settings’ or something).

Select software management, and type ‘ralink’ in the search box. Tick the package that appears, and select ‘apply’ to install it. I’ve just tried installing it myself, and it obligingly puts the file in the directory for you…

Reboot the system (may not be strictly necessary, but it won’t hurt either), and try configuring it again. And that’s the bit I’ve no idea about. Possibilities are going straight for your network manager, or trying in YaST. Or hoping you can find a manual somewhere, or some kind soul who’s got one can explain it…

You’re out of my depth, I’m afraid…

You could just install it anyway and see what happens - that’s what I’d do. :slight_smile:

I do note that the HCL doesn’t state that it’s been tested against 11.1. Personally, I’d just install the ralink package through YaST software management, reset, and try configuring it again. It may well not do anything - but I honestly can’t imagine it causing harm - your call.

I’m gonna give that a go this evening.
Fingers crossed!

It is very relevant, because it shows that you added your post to the wrong thread.

Your device is not a rt73 but a rt2500 and any posts regarding the installation of a firmware binary are completely unrelated to your device.

If you had posted the minimum information on your hardware (as explained in the stickies) one would have known this right away.

Also this “do you have a smp kernel” (regarding problems on older versions of opensuse, there is no “non smp”-kernel any longer since at least 11.0) are most likely irrelevant.


Ah. Woops. I did read the package details, but evidently I misread it, and Akoellh is quite right - that chipset isn’t in it.

Sorry to have misled you…


Well done for spotting that. Of course, posting on the “wrong thread” is unintentional, that really goes without saying. I based my questions on reading around the subject, and the SMP issue arose as a result of the query regarding the comments in the HCL, which appeared to relate specifically to my device. Make, model number and hardware version are the best that I could do in terms of ‘minimum information’.

If I knew the answer to these questions, I wouldn’t be wasting your time posting here in the first place…


When trying to follow the sticky (the 2nd one) I get the following:

IEEE 802.11bg  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=22 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

but when I scan I get:

sudo /usr/sbin/iwlist scan
root's password:
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     No scan results

The sticky say “The main point is that any output here requires the driver to be loaded and
functioning. This fact should be reported.”

I’m at a loss for what more information I can give, but am open to any suggestions on what to do next. (Or else I’ll just assume that the comment in the HCL was valid and go and buy a different USB)

Thanks again.