openSUSE 11.1 serial Tablet PC doesn't work (HP 2710p)

I have recently tried openSUSE 11.1 x86-64,
which I installed on hard disk, and openSUSE
11.1 x86 from the LiveCD.

In both cases I was not able to get my TabletPC to work
(I have HP Compaq 2710p - it is a serial wacom penabled TabletPC).

I tried to configure tablet through sax2
and tried using my old xorg.conf ,
with which tablet PC works fine in openSUSE 11.0 x86.
I have also tried to install wacom drivers
from Index of /repositories/home:/dkukawka/openSUSE_11.1 repository.
But nothing helped.

Has anybody succeeded in configuring
any wacom tablet - USB or serial, external or built-in
under openSUSE 11.1 x86 or openSUSE 11.1 x86-64?

I have found the answer myself,
so I think I should post it here too.

There is no need in adding additional repository.

The solution is simple:
during tablet configuration in sax2 ‘Port and Mode’ tab
COM-5 /dev/ttyS4 ] should be chosen instead of default COM-1 /dev/ttyS0 ],
which worked fine under opensuse 11.0.

Also, see this thread:
Tablet PC functions in 11.1 - openSUSE Forums

Ihave a similar issue with my HP TC4400 laptop with a wacom tablet and pen. Was working fine under 10.2, no tablet features under 11.1 working at all. I’ll give the changed Comport a go tonight when I get home.

I tried the change above on my HP TC4400 (on openSUSE 11.2, not 11.1), but after restarting XServer and issuing any xsetwacom commands against it, the pen no longer works at all. Resetting back to /dev/ttyS0 brings the pen back, but then if I try something like the following:

xsetwacom set “Mouse[5]” Rotate NONE

I get the error:

Error (2): WacomConfigOpenDevice: No such device
Set: Failed to open device ‘Mouse[5]’

Don’t get the error if I use COM5:/dev/ttyS4, but then I don’t get the pen either, which sort of defeats the point.

Any ideas?

Well I don’t know anything about this software/hardware but it strikes me that if you are using ttyS0, then shouldn’t you use:

xsetwacom set “Mouse[1]” Rotate NONE

or maybe

xsetwacom set “Mouse[0]” Rotate NONE

? I’m assuming the Mouse index is the serial port index.

Found a solution for rotation on TC4400 in the 11.2 release notes:

sudo -i
delete /etc/X11/xorg.conf

Restart X-Server (CTRL+ALT+BSP)

*run SaX2
Activate Tablet PC-4400
Set Port to COM5:ttyS4
Add a Pen and an Eraser

Restart X-Server *

xsetwacom list now works correctly and yields mouse, stylus and eraser with their Mouse[x] identifiers and
xsetwacom set Mouse[x] rotate DIRECTION correctly rotates the stylus to match the screen rotation set with KRandR.

However, there is still a problem - rotation causes the stylus to become wrongly calibrated in the horizontal plane by about 2.5cm - not sure how to fix that.

There is a way to calibrate stylus (and eraser). That is especially useful, when you return from s2ram and calibration becomes corrupt. For example these are commands to calibrate my HP 2710p in normal position:

xsetwacom set Mouse[3] BottomX 16520
xsetwacom set Mouse[3] BottomY 26312
xsetwacom set Mouse[5] BottomX 26167
xsetwacom set Mouse[5] BottomY 16365
xsetwacom set Mouse[7] BottomX 26167
xsetwacom set Mouse[7] BottomY 16365
xsetwacom set Mouse[3] TopX 0
xsetwacom set Mouse[3] TopY 0
xsetwacom set Mouse[5] TopX 155
xsetwacom set Mouse[5] TopY 260
xsetwacom set Mouse[7] TopX 155
xsetwacom set Mouse[7] TopY 260

I can list numbers from other position (rotated 90, 180 and 270 degrees), but I think correct numbers for your laptop would be different anyway. It has 4:3 screen, right?

Also there is graphical calibration tool called wacomcpl . If it works for you you don’t have to make up those numbers by yourself. And if wonder, what calibration numbers are set at the moment, issue command

xsetwacom get Mouse[3] BottomX
xsetwacom get Mouse[3] BottomY

and so on…

Also note, that if you don’t use xorg.conf file (hello openSUSE 11.2!) or if there is no wacom device listed in your xorg.conf (as in my system), wacomcpl will not work and xsetwacom will not accept names such as Mouse[3] . So you should use these device names:

"Wacom Serial Tablet PC Pen Tablet/Digitizer"


"Wacom Serial Tablet PC Pen Tablet/Digitizer eraser"

For details see these bug reports: Linux Wacom Tablet Project: Detail: 2937367 - xsetwacom still doesn’t work if you haven’t an xorg.conf