opensuse 11.1 RC1 blank screen after boot live cd


i am trying to start Opensuse 11.1 rc1 on an acer ferrari 1000 laptop, but after the boot process i get blank screen.
The graphics card that uses this laptop is the ATI radeon xpress 1150.
How can i solve the problem so i can install opensuse?
Other distribution boot & install without problem.


Try a different option when running the live cD. The first menu you get after booting, which is all green, gives you the choice of OpenSUSE Live (KDE) [or gnome if it is a gnome live CD], failsafe settings, check installation media, … etc … If you look at the bottom of that screen you will see some options associated with F3. Try selecting a lower resolution, or select VESA. Note after the install is complete, these settings can be changed.

the only option that worked is the text.

i did the installation through the text, but now i have the same problem deep black screen.

Any suggestion,because i cannot use the laptop at all?


how can i boot in text mode now?

You did not eventually get any GUI even using Text, correct? So you have not installed anything, correct? You boot from the Live-CD and go to a black screen - does the green screen with the progress bar show up at all? When you booted using Text, did you see text scrolling up the screen? The more precise the description of what you see, the better we can help.

Also, on the Live-CD menu, in the Boot Options field down below, type this and see if it helps:


i was able to boot into text mode. idid the installation through text mode & yast2. After the insallation, boot again & i got the same problem.

OK, so you successfully installed. So, at the green boot menu screen, in the Boot Options line down below, type just the number “3” (without quotes!). That will take you to a command line prompt, login as your user. Then do this (the “su” will prompt you for the root password):

sax2 -r -m 0=vesa

If that doesn’t work, try:

sax2 -r -m 0=radeon

If the gui doesn’t start, each time you should see some error message from the X server. Post that back here. And, to the following:

more /etc/X11/xorg.conf

That will scroll the X server configuration file. Look for the “Device” Section, you should see something like this:

Section “Device”
Identifier “Device[0]”
Driver “radeon”
VendorName “ATI”
BoardName “ATI Radeon Express 1150”
Screen 0

That is just an educated guess. Post back here what yours actually is.


i type the number 3 but cannot get text login, just blank screen:(

When did you type the number 3 ? You need to type it at the correct time in the boot sequence (ie when the grub boot menu appears, and you should see the 3 in the options line when you type it)

at the boot menu i get the green screen og opensuse & have 2 options. the 2nd one is the failsafe. so, in the line at the bottom i type 3. Is that correct?

iknow i have boot again from the live cd in text mode & i have mount the / partition of my installation at the HD.

Can i do something there?


i can see my /etc/X11/xorg.conf file

Section Device
BoardName Radeon XPRESS 200M 5975 (PCIE)
Driver Radeon

but my graphics card is a radeon xpress 1150.

did it recognize it wrong?

ok i can boot in text mode know with vesa 3 options.

what can i do from here ?

ok now i did what you worte me before.

i have X enviroment KDE 4.1 .

but the resolution is not good.

is there something that i can do from now on?


Congratulations on getting this far! Well done.

You can now look at installing custom ATI drivers. I don’t know if those drivers are available yet for 11.1 (someone else will need to answer there).

Hey if you’re looking for ATI Drivers. You’ll probably be able to download the latest drivers for Linux. Even if you’re using 11.1, the drivers should still be useful. But I must warn you, if you’re gonna do it the hard way I suggest you follow the directions of this page

ATI - openSUSE

I’m not 100% positive because I’m using NVidia with 11.1 Beta 5 and it seems to work. But then I had lots of help from this place (Forums)

You may need to follow these instructions for your Radeon Express 200M ATI Radeon Xpress - openSUSE. It builds upon what is on the ATI page linked above, just some tweaking in the setup command.

Also, there may not be a driver released by ATI yet for 11.1. You can try adding a repository in YaST with this url (don’t bother trying to check it in your browser; the website is secured and cannot be accessed that way):

If it is not accepted, you have 2 choices: Install 11.0 instead of 11.1 (you can update the KDE 4.0 that comes with 11.0 to 4.1 so your KDE will be very close to what is in 11.1) or you can install the ATI driver by compiling it from a script downloadable from the ATI website. The ATI page linked above describes this as “the hard way”, and lists all the packages you will need to install in order to compile the driver.

i download the drivers from ati installed but nothing after that. i do not know how to proceed.
i cannot understand how other distributions like ubuntu, recognizes the proprietary drivers & install them with no problem.

this is 2nd day trying to fix it. it is waste of time really.

i would like to see asap the opensuse to support all of these with no problem.

Sorry about that, but this is how i feel.

Also, i appreciate your support & your quick answers to my problem.



Sorry to read about your frustrations.

The reason why other distributions recognize the proprietary drivers is they follow a different philosophy than openSUSE Linux. Please note the open in openSUSE Linux. Novell/SuSE-GmbH have adopted a policy to try follow the open source free software definition a lot close than most other Linux distributions. Free Software Philosophy - openSUSE This means that openSUSE Linux may not in some cases work out of the box with some hardware. There are openGL (open source graphic) drivers that work for most cases, but not all.

The openSUSE Linux community, made up mostly of volunteers, have tried to provide guides and repositories for making the installation of such proprietary drivers easier, but more help is always needed.

Also note you are trying a Release Candidate version of 11.1. NOT the final released version. Hence such problems crop up with Distributions (and not just openSUSE) when they are being prepared (but not yet finished) for release. Hence while I sympathize, your criticisms at this stage are in part self inflicted.

If you want a stable easy to install openSUSE, then install openSUSE-11.0 and choose the KDE-3.5.9 or Gnome desktop.

Again, sorry to read of your difficulties, but what motivated you to use a product that has not yet been released, and still has known rough edges ?? …

ok i understand why this is happening. I understand also that it is a RC version.

i will give it a try once again.

I really want to use opensuse, & i cannot, that is why i am disappointed.


ok i installed the driver from ati, how i continue now? how can i load the new driver?