OpenSuse 11.1 post install nightmare for a newbie


I usually use debian based distros like Ubuntu or Elive, purely because I had problems with YaST under openSUSE 10.0 and synaptic seemed a lot less volatile at the time, but for some reason they don’t boot on my ASUS M2N-E SLI motherboard.

Anyway I install OpenSUSE 11.1 64-bit and it installs and works fine imidiately after install. however, when it runs the updates and I reboot, SUSE suddenly can’t find the hard drive it was installed on and hangs. I honestly can’t work out what’s wrong.

When I boot for the first time it works install 3 initial updates then another 77. I reboot and the hard drive is not found. The drive is perfectly fine and has not bad sectors or any such issue.

I also tried the latest SOAD based on openSUSE 11.1 32-bit and its the exact same issue. Something seems to be installed in the update that kills SUSE

Anyone have the same problem or know how to fix it?

Many thanks

Are you using dual boot?
When you restart the pc, did you see the boot screen?
Which graphic card do you have?

Hi mmarif4u

Thanks for your reply. Nope I’m not dual booting there is very little that the person who will be using this computer the most will require windows specifically for and most everything else works via Wine or VMWare/Parallels.

Basically when I reboot, I get the OS selection menu, I hit enter for it to start and the boots screen kicks in then after a minute or 2 it returns to text mode saying it can’t find the hard drive. From the text it seems to load up or probe all the hardware but returns a message to effectively saying it can’t find the hard drive.

I’m using an ATI Radeon HD 3670 card
The processor is an AMD Athlon X2 64bit.

I did wonder if it was the same issue as I was having trying to get Ubuntu 9.04 to run but its completely different. Ubuntu could not make sense of how acpi objects were being passed so it just wouldn’t do anything, here its an issue with the hard drive vanishing in SUSE’s mind.

Thanks again


Try this one 1st, hope it will help.

ATI - openSUSE

Yeah, no I have tried to install the graphics card using the instructions in that link but every time I tried to run

SaX2 -r -m 0=fglrx

SaX2 would crash. So as a last resort I just downloaded and installed the drivers manually directly from the ATI site following instructions from another link. However, I’ve now discovered from

ATI Installer HOWTO for SUSE/Novell users

that I need to recompile the kernel after every update if using the manual install. Would it be this that’s cause the problem?

Also would it make a difference if I installed all the automatic updates Yast/SUSE wants to install before I install the ATI drivers? I know one of the 80 file/program updates involved SaX2.

AFAIK, after fresh installation, its a good idea to update the system 1st, then install any other softwares/drivers.
In your case, i would recommend, 1st update your system with latest updates, but unfortunately you cant’ do this now, because the update servers are down till Monday morning. So you have to wait.

ATI and Nvidia drivers always like this in Linux, you have to install it either easy way and hard way. It depends, if easy one works, then skip hard one. If no then follow the hard one.
And it seems that in your case, you are going to follow the hard one, and again i would say, update your system 1st.
As i can’t provide much information about ATI/Nvidia drivers, because i did not use it all till now.

The kernel update has damaged your GRUB. Boot from the Install DVD (64bit). Start the installer and go on upto the point where you have the choice to do a new install or upgrade existing. There’s an extra option: repair installed system. Run it, it will create a new bootloader configuration and write it to disk. Reboot when finished and let the system start from HDD. Should fix the problem.

Concerning the ATI driver: yes, you do need to recompile the driver for the new kernel (either through repos or by hand), but no need to run sax2 again, since the X-server has already been configured correctly

Hi guys

Thanks, for all the help. I did a fresh install and as you said mmarif4u I ran the online update in YaST it took a couple of hours rebooted and then installed the ATI driver the easy way. Except that instead of logging out and then crtl+alt+f1 I decided again to play it extra safe and just rebooted straight into init 3 from grub and did the SaX2 bit and its worked.


Thats a good news, you make the things work.

Updates? how you update the system, i think the servers are down. Am i right?