opensuse 11.1 on Lenovo u330 brightness workaround

This has been bugging me for few days, the screen is either too bright or too dark and, yes, it’s all random. Accidentally I found a workaround tonight. Since I’ve been seeing people have all kinds of similar problem on the Internet, I’m simply posting this workaround that might help some others, and also hoping maybe someone can give some insight and provide a true solution to this. So, thanks in advance.


  1. most Fn+X keys work, like volume control, but not Fn+Up/Down for brightness, even though the transparent window shows up when I adjust it (but with blank brightness level).

  2. Checked /proc/acpi/video/OVGA/DD0X/brightness values, being <not supported> so the “echo -n X” method didn’t work for me. I realise some people are in the same case.

  3. The brightness level changes by itself sometimes after logout then log back in. This gives me a blind idea how X window might be source of this problem…

So, workaround

  1. Ctrl+Alt+F1 to get out of the X window session.

  2. Based on prior screen brightness level, use the same Fn+Up/Down key to adjust the level, even you can’t see anything.

  3. Ctrl+Alt+F7 to get back to the GUI, and the brightness is actually now changed. Tried a few times and it actually works pretty well.

Finally, I’m not an expert, but happy to provide any logs if anyone is interested.



Thx, your workaround helped me a lot. I wonder if here is anybody who can help us with more pretty solution? Also I really miss sound volume controls on my u330 :frowning:

From a command line you can use:

xbacklight -set 100

That will get you 100% brightness. You can change the integer to represent a different percentage of brightness you wish to use.

I’ve had the same exact problem on my T410, with opensuse 11.4. Apparently, the problem has been around for some time… I have an NVidia display card, and apparently the proprietary driver is causing this issue for me. (They say it has been fixed but I’m suspecting a regression - I’m currently on 275.21).

The way I have been able to fix the issue is to add

Option "RegistryDwords" "EnableBrightnessControl=1"

at the end of /etc/X11/xorg.conf.d/xx-device.conf (where xx is a number, the file name is 50-device.conf for me)

Hope this will help others…

props to Ben for the workaround, that worked nicely. I made the adjustment that Lucian has suggested, haven’t restarted X yet, I am currently running the same nVidia device driver.