opensuse 11.1 nvidia

Still no nvidia Opensuse 11.1 3D support

Tried to install the nvidia driver from the nvidia site:
Unable to load the kernel module ‘nvidia.ko’

Again the stupid nvidia license reason.
Not customer friendly I think.
I have bought the nvidia hardware fair.


Thats odd because I have been using nvidia drivers on a 11.1 for a couple weeks now.

What problems are you having?

Its a kernel error in the log file it says:

Unable to load the kernel module ‘nvidia.ko’

I have preinstalled kernel-source , gcc, make and linux
Think I need a nvidia -kernel -header

They still haven’t repos for opensuse 11.1 but you can install their latest drivers with the command :

And then I get error:
Unable to build the NVIDIA kernel module
Unable to load the kernel module ‘nvidia.ko’

And then I get error:
Unable to load the kernel module ‘nvidia.ko’

ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
‘/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.

No you don’t probably best to install the drivers from Nvidia easiest is to make a folder nv in your home and download them there.
Once downloaded log out then choose console login in the menu at the bottom left of the screen.
Log on as root and type cd /home/<yourusername>/nv then sh NVIDIA then press tab to fill out the whole name then press enter and answer yes to all the questions.
When done type exit then ctlr+delete to reboot.
If the screen settings are wrong when you login open a console and type
sudo nvidia-settings set your resolution and choose save to xconfig.
Once the drivers reach the repos you can add them, though they are usually a bit behind the ones from Nvidia.
So you may want to keep them. The only downside is that you have to reinstall them if the kernel is upgraded.


I have a 4 page post related to nvidia driver installation here

If your problem is 3D rendering, this thread should help a lot.

I can not get further then step 5 :

  1. Install kernel sources (already had gcc and make, duh)
  2. Downloaded the drivers from Nvidia
  3. Went to runlevel 3 by opening a terminal and typing “init 3”
  4. Logged in as root
  5. sh <nvidia installer file>.run -q
    The Nvidia software did its thing and compiled with the linux sources. After the installer was done:
  6. Typed “sax2 -r -m 0=nvidia”
  7. reboot

step5 gives unable to build nvidia kernel ( at 60% )

which version kernel-source and gcc do I need they are not the same !!.

exactly, downgrade or upgrade what needed, You need same version sources as Your kernel, in 11.1 right now 4.1 is default.

On my laptop, I had the same errors a few days ago when some upgraded kernel version was installed on this opensuse 11.1 by the opensuse updater whereas the kernel source was not updated. Today i downgraded to the previous kernel version. Then kernel and kernel-source were on the same version. So the nvidia driver installed properly.

gcc is version 4.3 how can i downgrade that and de kernel source 4.1

sorry was not looking right gcc was 2.6

When in software management highlight kernel-default, then click versions tab and click the right one?
If that doesn’t work try simply to reinstall it. As far as i know, right know there’s only one version available

gcc 4.1 is in the Factory repo. And @Christophe_deR is right, there was a mis-match between the source and the kernel upgrade in 11.1 Updates.

btw, 11.1 is not released: There will be issues.

fwiw, I compiled the driver several weeks ago (before the recent kernel updgrade).

I am using RC1 the final release, intern release was on 4 dec.
So I expected the mis-match is fixed. The public release is 17 dec but when there is no easy way to get opensuse 11.1 nvidia we better wait.

gcc is version 4.3-34.159 can not downgrade this is the only version under tab version.
kernel-source and header

I didn’t tell You to downgrade gcc :slight_smile: It has to be the same, what i wanted You to downgrade is all kernel related rpms like base, extra and default. When looking at version at software management You see end like 4.1 then it’s a good one.

By the way, from what i understand GM edition didn’t add any additional updates(that’s why it’s called internal hehe) :slight_smile: If it did we would have GM editions all over before public release rotfl!