openSuse 11.1 not booting after changing default to Windows


I’m running a Dell Latitude D630 with an 120 Sata Disk. I’ve installed Windows XPSP3 and openSuse 11.1.

Today, I tried to change the the default boot to Windows XP and now the system isn’t booting anymore:

“Error No Operating system”

I used the repair option of openSuse 11.1 to repair my system, but that didn’t work too.

sda 117,79
sda1 94,10 MB Dell Utility
sda3 93,68 GB Extended
sda5 8,01 GB Linux Native Ext3 /
sda6 601 GB Linux Native Ext3 /home
sda7 77,68 GB Win95 FAT32 LBA FAT
sda8 2,01 GB Linux swap Swap

Any idea?


Can you be more specific on this point - what exactly did you change and how?

Same thing happened to me and about 80,000 other people.

What I did was a reinstall of 11.1, in which I set Windows as the default OS at the beginning of the install process, right after entering usernames and passwords, but just before clicking on the “Install” button.

There is a “Bootloader” option you can configure. Set Windows as the default OS there.

For some reason, if you do it at the beginning of the install, it works fine, But change the default OS after the installation is complete, it destroys your master boot record.

There may be other ways of fixing the problem, but I struggled for several days with this annoying bug and this was the best solution I could come up with (that actually worked).

Hi foresthill
You should have just been able to edit the /boot/grub/menu.lst file and
change the default setting to which ever menu item windows was starting
from 0 for the first YaST menu entry.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1 day 1:58, 2 users, load average: 0.25, 0.20, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

You’re absolutely correct on this point Malcolm. However, those of us who have been using SuSE Linux/openSUSE for a number of years have become accustomed to using the Boot Loader module in YaST2 to make these simple changes. In openSUSE 11.1, a serious bug in that module has resulted in unbootable systems for many users around the world.

One can use the Installation/Repair DVD to get to a command prompt where VI (nano, whatever) can be used to repair the damaged menu.lst. Unfortunately the attractive boot menu is gone, replaced by black & white text; and I have yet to see a meaningful repair solution offered in these forums.

Many of us - like foresthill - who have had this unfortunate experience have learned that making these changes at installation is just as easy (easier?) as editing menu.lst manually following installation. And no, the bootloader repair option on the DVD can’t be used to fix the damage, either. It identifies that the bootloader is flawed, offers to make a repair, and then reports that the effort failed.

I’m sorry if I sound bitter, but this bug cost me considerable time before I figured out that the problem is in the system and not a result of error on my part. I have long touted the reliability and high quality finish of openSUSE, so a glaring bug like this one is a personal embarrassment.

Hello milehigh.

I confirmed your observation thus: I have installed windows and some Linux distros and 11.1 on a spare computer. I went into Yast → bootloader module. I set the default booting to windows. I rebooted. The bios reported that there was no operating system and the computer stopped at that point.

So I used the install DVD → Repair Installed System → Expert Tools → Repair Bootloader → Success messake → Next → Finish → Restart → bypass an error message → Reboot. The bios reported that there was no operating system and the computer stopped at that point.

I would like to pursue this more. I have only this reference to it:

Do you have any links that I can follow – links to bug reports or to forum posts, or to anything relating to this problem?


One can use the Installation/Repair DVD to get to a command prompt where VI (nano, whatever) can be used to repair the damaged menu.lst. Unfortunately the attractive boot menu is gone, replaced by black & white text; and I have yet to see a meaningful repair solution offered in these forums.

I must be missing something. Changing anything in the menu.lst boot stanzas, or changing which stanza is the boot default, has absolutely no bearing on the display of the graphical menu, which is the file /boot/message. The location of that file must be correct (e.g., (hd0,0)/boot/message), so if a partition number needs to be changed in a stanza it may also need to be changed in the gfxmenu statement at the top of menu.lst. Otherwise, there should be no effect.

As a valuable but little-known aside, and of course this only applies when the user understands the basics of menu.lst and the grub installation: In the YaST Boot Loader, whether during install or from Repair, the user can see what the literal changes will be from what has been done in the gui, by clicking on Other/Edit Configuration Files. That presents an editing window for menu.lst,, and /etc/grub.conf - the latter file being a scriptlet fed to the grub shell which is what does the actual grub installation. The user can makes changes there which will be reflected upon returning to the gui screens. A good technique for ensuring that YaST is going to do as you intended. (There are a few YaST actions, e.g., installing generic boot code to the MBR or marking a partition active, in which these files are not involved.) Just fwiw . . .

I’m documenting this simply to get a trail of what works and what doesn’t for this bug.

Further to this I tried reinstalling the bootloader with the install DVD another way: Boot off DVD → Rescue System → enter “root” at login prompt.
Enter this command to switch into grub: grub
I get the grub prompt >
Locate the openSUSE partition with this command: find /boot/grub/menu.lst
That gives (hd0,13)
Enter: root (hd0,13)
Enter: setup (hd0)
Enter: quit
I get the Linux prompt #
Enter: reboot

That gets me to the abbreviated grub menu with only the option to boot to openSUSE 11.1 and via that I get back into openSUSE 11.1.

So now to get a complete bootloader I go to Yast __. Bootloader → Other → Propose New Configiuration → OK.

I reboot to see if the bootloader repair is good.

It is repaired and I can boot into all of my operating systems.

Conclusion: there’s something defo wrong with the bit that changes the default boot item in Yast → bootloader. It corrupts the master boot record. But the situation is retrievable by standard methods. These methods are certainly not available semi-intuitively via Yast and/or the Installation media.

PS the nice graphical bootloader screens stayed throughout all of the above.*

It seems that pretty much any post-install changes made to the bootloader destroys the MBR in 11.1. I just changed the video mode in the bootloader to 1024 x 768 (I forget what the exact number was, 0x317a or something).

When I rebooted, I got “No Operating System Found”. So people need to be careful not to make ANY post-install changes to their 11.1 bootloader configuration unless they can figure out the rescue procedure above, which looks anything but intuitive.

It’s a shame the standard rescue tools on the install disc don’t work. This only adds to the frustration.

Installed YaST Boot Loader, installer’s Boot Loader, DVD Repair Boot Loader - all use the same object code. Some variations in how the code is called, but in most cases will all behave the same. And btw, there is a great deal more going on in that code than one would think - it attempts to compensate for all the irregularities in MBR’s and boot sectors between varying OS’s, manufacturer’s, and file systems.

While of course the Repair option should work as advertised, I side with the grub manual: Use the grub shell.

@foresthill ==> Can you tell me two things: (1)which partition openSUSE 11.1 is installed on? (2) which partition has the asterisk beside it when you execute the command: sudo /sbin/fdisk -l

By the way, “No Operating System Found” is usually thrown by the bios when there is no executable boot code in the MBR of the disk it is trying to boot from (remember, every disk has an MBR).

“No Operating System” is thrown by the “generic boot code” that can be installed optionally by YaST; this is actually DOS code and would be the error thrown by W98 or earlier.

“Missing operating system” is thrown by the XP or Vista MBR code.

(John: From looking at the code, I finally found the “generic” program file and how it is being installed by YaST, if you’re interested.)


Your rescue procedure worked. Thanks mate!

I believe /dev/sda11 is where OpenSuse 11.1 is located. I have OpenSuse 11 on /dev/sda 7.

/dev/sda2 is where the asterisk is (this is a FAT 32 storage partition with no OS on it)


Then I think the key to your and my quite similar experiences lies in the inability of Grub to cope well with high order partitions. I can’t express it better than that because I don’t properly understand Grub. I think the problem isn’t with Yast, rather it’s likely with Grub, which is very old.

OK I’ve figured out what you have to do to get it to work for you. Use Yast’s bootloader module. Set windows as the default with that and at the same time go to the tab “Boot Loader Installation” and put the checkmark onto “Boot from the MBR”.

For exact details see here: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

That fixes it for me. Maybe will work for you too?

Hi Swerdna,

your hint with the rescue system worked well for me, now my system is running again.


It would be interesting to install 11.1 on a hard drive with nothing else, so that there would only be 3 partitions, and see if the same thing happens if you mess with the bootloader settings.

Maybe I will try this on an old hard drive if I get bored.

Excellent, glad you’re restored.