OpenSUSE 11.1 No SLI support?

Ok, this is what is happening:

2x NVIDIA 7900 GS (w/sli bridge)

So, installed OpenSUSE 11.1 (clean install)

i installed the new drivers from the nvidia site itself, after a bit tweaking around i got it working.

It wouldnt load up right away, said no screens found. Did sax2 -r and fixed it.

Going into terminal (using su), i try to enable SLI support by typing:

nvidia-xconfig --sli=Auto

After exiting, and re-starting x, i get the no screens found again. So i go back to sax2 fix it again, but when i go into the nvidia manager, sli is not enabled…Any idea as to why is this happening?

Can anyone reproduce?

Just a +1 bump, same problem, same attempted fixes just a different series (8000) of Nvidia cards.

I also have 2 cards set up in SLI. Here is what happens. Nvidia drivers installs and works. After adding the SLI option in the xorg.conf, the machine will not boot x correctly. In fact, x attempts to restart on tty7, and hangs. I reboot, to clear all processes, and run sax2, which switches to the other card! The black screen is on the card which should be screeen 0. X cannot make a successful configuration with the option in the file. Remove the option, it works. Since I run SLI, 11.1 will not work for me. Is this a SUSE issue? Nvidia? I have successfully ran SLI on several distros, including Mandriva, PCLinuxOS and openSUSE. I also tried the 86_64 version. So I went back to 10.3.

The same problem.>:)
I have 2 nvidia cards (7600GT) and with it an amount of problems. First the history. I began with suse 10.2 - at that time only 1 card and everything was good. Then I bought 2te card and with suse 10.3 everything was excellent - SLI and compiz function perfectly. Then comes 11.0 and it was quite bad - suse did not want 2 cards- with SLI display was black, but I tricked suse, while I installed nvidia drivers and compiz first with a card and then made the second. However, suse 11.1 cannot be tricked. I google and google, tried with different drivers, with sax2 and nvidia server settings configutation - everything in wain! With a 1 card is everything o.k., the second does not go. What should I do now - wait on suse 11.2 and hope, it would better handle with nvidia?

Same problem,twin 6800 gt,must be nvidia issue,will not work in Ubuntu,Ultimate edition,OpenSuse or any other distro ihave tried except windoze.:stuck_out_tongue:

In Ubuntu getting SLI to work was a snap I just used the following.

sudo nvidia-xconfig --sli-auto

The trouble I have found with OpenSUSE 11.1 is after running that command in terminal, I couldn’t get back into KDE without running the following from su

sax2 -f

So I compromised, I used the following command.

sudo vi /etc/X11/xorg.conf

and I added

Option “SLI” “AUTO”

to the following section

Section “Device”
BoardName “GeForce 8800 Ultra”
BusID “1:0:0”
Driver “nvidia”
Identifier “Device[0]”
Screen 0
VendorName “NVIDIA”
Option “SLI” “AUTO”

Please beware that is you are going to do this, it would be a good idea to run this command before editing your xorg.conf

sudo cp -i /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

don’t forget the -i switch, as it will prompt you before overwriting a file, in which case I always add a digit after backup so I can have multiple return points if necessary.

I hope this helps,