Opensuse 11.1 needs tweaking

I have tried to install opensuse 11.1 rc about 13 times, each attempt was a total failure… I can say this becuz I am using opensuse 11 and have been for a year now along with Windows XP as a dual boot system. I have a tyan momboard, hpt 372 raid controller, I use 4 hard drives, suse is on the secondary primary and windows uses the primary drive. What I have found is that after a 11.1 install, my root partition is not found and that is problaby the reason for the boot problem. because my compter starts up I get the text line stating that grub 1.5 ist starting, then the computer goes through the boot all over again… What ever they did to 11.1 I thing they need to reverse engineer it so it works as good as or better the 11… But dont break it, you guys had something really good with 11, dont screw it up…

Thanks for the information but you really should report this as a bug. For more information go to Submitting Bug Reports - openSUSE

W.C. Fields once said “If at first you don’t succeed, try again. Then quit. No sense in making a dam fool of yourself!” I am about 9 attempts behind you. I quit and now am using the mini-iso to install 11.2, I think:\

Hey Prexy;

I dont feel too bad now, at least someone else shares my concern, with suse 11.1… I thought and I still hope they work out the details with the 11.1 version… But anyway happy suseing …

This is not a serious or particularly difficult problem. Post back some information and we can take it from there: Do you have grub installed in the boot disk MBR and it is controlling the dual-boot with Windows? Do you get the green grub menu? Do you by chance have a Live-CD?

The thing with the new installer (I think 11.0 had that too) is that when it sees an existing installation (XP, Vista, etc) it will default to not writing it’s boot code in the MBR (Master boot record).
This means your previous OS should boot as it normally did.

To override this you can select to write the generic code the MBR (it’s in the advanced boot options).

I’ve been closely watching users’ experiences with this, and I think it is not quite that simple. If SuSE is installed on a logical partition - which is often required especially with Vista (it is common for there to already be 3 primary partitions) - the only way to boot openSUSE is to install grub in the MBR. Vista can boot from a logical partition, but that requires setting it up for chainloading with either the MS tool bcdedit or with a 3rd-party tool like EasyBCD. XP installations typically use only 1 or 2 primaries so there is usually a primary partition for openSUSE that XP can boot, but that requires extra work most users don’t know how to do; and, XP cannot boot a logical under any circumstance.

I have not been able to find the logic that the installer uses to decide how to (a) repartition and (b) which boot loader installation approach to use. It looks to me as if the installer will use the Windows loader if it can, which is to say, if openSUSE can be installed on a primary, in which case that primary is marked active with the bootable flag. Otherwise grub will be installed in the MBR with a pointer to the openSUSE partition.

Is there any way to salvage the xp side or am i going to have to reinstall completely :expressionless: I have 11.1 and I get the green grub that says windows in it but doesnt recognize it. Ive tried navigating through the grub but it couldnt recognize the drive just that something was there taking up space.

First, let me offer that you will very likely get more help faster if you open your own thread. The title for this thread - which is old, too - isn’t helpful, either. I suggest something like “lost XP boot from grub”.

Usually a problem like this is easily fixed. You could try going to YaST Boot Loader, click Other, click Propose New Configuration. Before doing that, do two things: First, run YaST Online Update and make sure that the “perl-bootloader” and “parted” patches are installed (I suspect you may have been bitten by one of the 2 bugs those patches fix). Then make a backup copy of the grub menu.lst, from a terminal, thus:

su -
cp /boot/grub/menu.lst /boot/grub/menu.lst.backup

If that doesn’t fix the problem, you will need to post some information back here, but since you can boot into openSUSE that should be easy. Open a terminal, and post the output of these commands:

su -
fdisk -lu
cat /boot/grub/
cat /boot/grub/menu.lst
cat /etc/grub.conf

Again, I suggest doing all of this in a new thread.