OpenSuse 11.1 needed more testing

I feel I need to take the development team to task about this release. I just started work in a computer repair store where everything is Windows and just starting to sell Mac. The PC we use to backup data to for customers became corrupted with viruses so we had to reinstall. I suggested installing openSUSE as it could run windows in virtualbox and sandbox any virus issues and also make for a quick snapshot reinstall if something went wrong. Well I use 11.0 and noticed 11.1 had been released.
After getting the livecd it hung trying to start X with garbage on the screen. I thought it might have been a bad md5sum but the iso was fine when i rechecked. burned it at a slower speed and tried again…no luck. Tried it on another pc and it went to a console, tried startx but couldn’t start.
Eventually found out it was intel driver bug!!
Seriously, there are a HUGE number of people that have onboard intel drivers…did you not test this on a few different systems before releasing it on us!! how embarrasing and also bad for the linux cause it is when my colleagues just look at that and go “Oh yeah linux is awesome, nice one!” I had to bring in 11.0 and install that to get it to work. I haven’t tried the full install DVD, but I imagine if it’s in the kernel then it would be the same.
Mandriva one 2009 had a similar problem with nvidia drivers. I mean seriously these things need to be checked and FIXED before a major release is out…how the hell was this missed???

If someone can fill me in on the whole process for testing this kind of thing I’d appreciate it.

Long time openSUSE lover,

I have a laptop with Intel graphics. It works.

I have read of problems with some Intel drivers. … But this is not true for all Intel drivers. Still, I had thought Intel were quite good at supporting the opensource community with drivers, so I can understand some disappointment.

This is a good question, as IMHO the BEST WAY to ensure your PC (or multiple PCs) will have a functioning driver is to participate in the development testing process yourself. That is what I do, and that way, if a bug was not reported that impacts me in a major way, I have no one to blaime but myself.

Reference the process, please read our stickie (ignore my babbling part, and read snakedriver’s more factual section):
Welcome to the Pre-Release/Beta Forum - openSUSE Forums

You could have another try using the install DVD.

As an older rule with openSUSE, if you wanna take a peek and play around - use the LiveCD.
If you are going for a long lasting install - use the DVD.

Experiences are it’s a much more stable install (pre and post).


Hello !
I had problem with the intel driver:
I had the solution given to me hee on this forum.

I installed with the dvd, and I had absolutely no problem :slight_smile:

Anyway, with the livecd, try to enter level 3, by typing “level3” (without the “”) in grub ,while the livecd launches.
Then, type in “root” and hit enter. Then, “sax2 -r -m 0=vesa” (0 is a zéro, and not the letter “o”)

You’ll be able to configure the screen the way you want and test the configuration !

Have you tried that? Is there still problem ?

Anyway, the good thing to test is to try a “rerelease” beta/rc and repoart as many bug as you can !
Then, when it’s out, search the forum for answer. And if there are not answer, ask for help, like you did here :slight_smile:

Good luck !

Did you know you’re part of the developing and QA team?
Only kidding…

The problem was well known before release and discussed. There were even suggestions to postpone the release.

It is caused by Intel development driver, switching over to EXA which is newish and still undergoing development. You can work round the issue most likely by going back to the older XAA acceleration method, that they are ‘deprecating’.

Not all Intel graphics was affected, so the decision to ship was made. It is an issue that can be worked round. There will be updates, and most likely Intel will sort out the driver problems with EXA over the next few months.

New openSUSE releases, are on the bleeding edge, for the next month or so 11.0 will be a more solid and useful OS for a lot of ppl. It may look fairly bad, but actually last year, OS 10.3 was in really terrible shape for the first month after release, 11.1 looks good in comparison.

It just takes time not only to find problems, but also to get fixes in time to be integrated with the release kernel.

Best to be cautious with new releases until they’ve settled down, especially in ‘production’ enviroments.

An amen to @robopensuse’s post. The corp IT way is to (a) wait and (b) simulate. I’ve had many client shops with a policy to only roll 1 release behind. I always go early to a new release - but on a test instance in the same hardware. Depending on what happens, I’ll go/no-go. And of course an issue like this is hardly unique to Linux - Vista drivers come to mind. But nonetheless, that is no excuse.

As far as this specific issue, the problem is with certain new versions of the integrated intel graphics device, reported most often in combination with display power management hardware on laptops. The bug reports are lonnnng - dev’s are tearing their hair out with this one. Adding to the craziness is that it seems that with some kernels, the problem resolves - IIRC, Mandriva’s is working. Last I checked, no one seems to know why.

Well according to the comments on the Phoronix benchmarking article, it was because Mandriva’s packager chose to default to XAA still, over-riding the EXA as default change.

But that’s 2nd hand info, not checked it out, but in the context it seemed plausible and there were refs to a mail list thread, with Mandriva devs discussing similar probs and rollback idea.