OpenSuse 11.1 nagios-www install broken?

I built a new 11.1 with nagios and installed nagios-www.
I get an error 500, CGI script error. I have tried re-installing the nagios-www piece and it doesn’t help.

This feels like a directory permissions issue, but need help finding the directory in question.

Also Nagios is being rev’ed faster than OpenSuse, is it possible to request more frequent RPM configurations?
Is there a how to on updating RPMs?


Hi Dave & welcome!

Maybe this link will help you : Installing Nagios on openSUSE 11.0 | DiWi

It’s written for openSUSE 11.0 but should also apply to 11.1.

It should get you a decent Nagios setup and also explain how to keep the packages up to date using the build service.


Thanks, a great resource in your message and the build service was just what I was trying to find!

I went through the directories at the end of the document and my new install and their contents match an older install I have on 11.0 in terms of owner and permissions.
I also compared the apache2 configs for the main files.

Since I’m getting a cgi error, any specific hints what you would look for? I’m more than willing to try your special quickstarts, but have an awful lot in the .cfg files already.


Hi Dave,

I’ve just installed Nagios on an openSUSE 11.1 system (it’s a 32bit system in this case). No issues here.

Where exactly are you getting the cgi error? Any specifics in the error message?

As a first you could try installing these packages (packeges already installed will be skipped):

su -
zypper install nagios nagios-plugins nagios-plugins-extras nagios-nrpe rrdtool php5 php5-gd php5-zlib apache2-mod_php5 perl-SNMP  libwavpack1

After that restart the Nagios and apcache2 service.

If you already have your desired Nagios configuration you can keep it by making a backup of /etc/nagios/* and just transfer that configuration to a new system.

hope that helps,

Well I ran your zypper installs
restarted both nagios and apache2, same error.

I go to http://hostname/nagios, it prompts for a user and password. Then I get:

"Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
Apache version/SUSE"

monitoring checks are working, notifications are working, its just the web console that is not working.

A virtually clean new install of nagios and apache.

Have you made any changes to the apache http.conf file or other?

Do you get a normal page when going to the webroot? (http://hostname).
Also, are you trying to access the web page on the system locally or from a remote system and are there any messages with more detail in /var/log/messages or /var/log/apache2/* ?

I’m not apache savvy enough with troubleshooting these generic CGI errors without having more detail… my first hunch would be to deinstall the apache packages, remove relevant configs in /etc/apache and reinstall the apache packages and maybe also the nagios-www package.

Sorry I’m not of more use… :confused:

The Apache default page isn’t working, I think it was at one point. There are plenty of resources to check on that problem, so I’ll let you move to another question. I went ahead and uninstalled nagios-www, then reinstalled Apache and got the same result. So I’ll have to do slightly deeper surgery!

Thanks for the resources you have provided.



I’ve also the issue.
My problem was solved by changing the password of the user nagios admin with the following command:

htpasswd2 -c /etc/nagios/htpasswd.users nagiosadmin

This worked for me


Thank you very match! Your post has helped to solve my problem :slight_smile:

Hi !

I got the same problem with a fresh new installation. It seems that the nagios installation didn’t create the “htpasswd.users” file in /etc/nagios/

Run the previous command and you got its solved. Hope this helps to devs to find the problem. I got no errors during installation (all packages are from suse repository).

This is not a flaw in the package, it’s designed to work like this.

Please refer to** /usr/share/doc/packages/nagios/README.SuSE **

Nagios Documentation

1) Quickstart

A quickstart installation guide can now be found in the 
package nagios-www. You can find the quickstart guide 
(quickstart.html) in the following subdirectory:


The quickstart covers all the basic steps you need to follow
to install Nagios, the Nagios plugins, and start out monitoring
the machine that Nagios is installed on.

* Remember to create a htpasswd.users file in /etc/nagios:
*   htpasswd2 -c /etc/nagios/htpasswd.users nagiosadmin 
* And set the correct rights for this file:
*   chmod 640 /etc/nagios/htpasswd.users
*   chown root:www /etc/nagios/htpasswd.users
* You should also add a mail alias for the nagiosadmin to your
* /etc/aliases file like:
* nagiosadmin: root
* and afterwards update the database with "newaliases"
* Note: the RPM tries to do this automatically

In the future, please read the documentation.